3.0. -- 3.1 jetzt schon umstellen?

Diskussionen über aktuelle und zukünftige phpBB-Versionen.
Wichtig: Bitte unbedingt die Forum-FAQ beachten! Kein Support!
Forumsregeln
Bitte unbedingt die Forum-FAQ beachten!
Benutzeravatar
abelius-kiel
Mitglied
Beiträge: 288
Registriert: 15.03.2011 08:59

3.0. -- 3.1 jetzt schon umstellen?

Beitragvon abelius-kiel » 27.10.2015 17:19

Hallo allerseits,

seit Jahren verwalte ich ein recht erfolgreiches phpBB Forum: http://imkerforum.nordbiene.de , derzeit phpbb 3.0,12.

Dies mit vielen stylistischen Änderungen und vielen MODs (mChat, Gallery, Board3, whowashere, etc. etc).

Meine Frage: bietet 3.1 bereits ähnlich viele Extensions? Konkreter: ist der Inhalt derr "alten" Gallery auch in der dann "neuen Gallery" problemlos vorhanden?

Also kurzum: Jetzt schon updaten? 8)

LG
Kai

Benutzeravatar
AYYILDIZLAR
Ehemaliger
Beiträge: 4148
Registriert: 09.11.2010 18:08
Kontaktdaten:

Re: 3.0. -- 3.1 jetzt schon umstellen?

Beitragvon AYYILDIZLAR » 27.10.2015 19:25

Hallo,

Für die genannten MODs (mChat, Gallery usw.) von dir, gibt es inzwischen auch die heutigen Extensions. Ob es für den Who Was Here auch eine Extension gibt, kann ich dir leider nicht sagen. Am besten mal Google fragen, der wird dir sicherlich weiterhelfen.

Grüße
DasEtwasAndereMotorradforum.de
Deutsche Übersetzung der Tapatalk Extension | Deutsche Übersetzung der Tapatalk MOD
Bitte keine PN wegen Support, werde diese zukünftig ignorieren und gleich löschen.

Lehrling
Supporter
Supporter
Beiträge: 2919
Registriert: 15.01.2012 20:00
Kontaktdaten:

Re: 3.0. -- 3.1 jetzt schon umstellen?

Beitragvon Lehrling » 27.10.2015 19:28

AYYILDIZLAR hat geschrieben:Ob es für den Who Was Here auch eine Extension gibt, kann ich dir leider nicht sagen.

Die gibt's hier: https://github.com/bb3mobi/who-was-here

Benutzeravatar
gn#36
Administrator
Administrator
Beiträge: 9174
Registriert: 01.10.2006 16:20
Wohnort: Ganz in der Nähe...
Kontaktdaten:

Re: 3.0. -- 3.1 jetzt schon umstellen?

Beitragvon gn#36 » 27.10.2015 20:14

Die Menge an Extensions hat sicherlich noch nicht die Menge an verfügbaren Mods überschritten. Aber der Support von 3.0 läuft demnächst aus und die Frage ist: Möchtest du ein Forum ohne jedwede Sicherheitsupdates danach wirklich noch weiter betreiben? Im Bezug auf selbige solltest du übrigens so oder so mindestens auf 3.0.14 updaten - es gab ein paar kleinere Sicherheitsprobleme die seit 3.0.12 korrigiert wurden.

Auch wenn 3.0.x am ersten Tag nach der Umstellung sicherlich noch nicht unsicher wird sollte man spätestens dann anfangen mit dem Umstieg, selbst wenn er danach noch etwas Zeit kostet. Wenn es einen Mod nicht als Extension gibt kann man vielleicht auf eine andere Alternative wechseln ohne größere Funktionsverluste. Bei manchen Mods hat sich die Suche vielleicht sogar erledigt, weil phpBB selbst in der neuen Version die entsprechende Funktionalität bietet. Wenn du vor dem Wechsel entsprechend recherchierst kannst du evtl. sogar die Daten aus dem alten Mod in "andere", ähnliche Extensions mitnehmen, indem du sie vorher konvertierst.
Begegnungen mit dem Chaos sind fast unvermeidlich, Aber nicht katastrophal, solange man den Durchblick behält.
Übertreiben sollte man's im Forum aber nicht mit dem Chaos, denn da sollen ja andere durchblicken und nicht nur man selbst.

Talk19zehn
Ehemaliger
Beiträge: 4376
Registriert: 08.06.2009 12:03

Re: 3.0. -- 3.1 jetzt schon umstellen?

Beitragvon Talk19zehn » 27.10.2015 22:05

Hi,
gn#36 hat geschrieben:Wenn du vor dem Wechsel entsprechend recherchierst kannst du evtl. sogar die Daten aus dem alten Mod in "andere", ähnliche Extensions mitnehmen, indem du sie vorher konvertierst.

8) Wo finde ich, du, er, sie eine verständliche An, - Einleitung? Oder was ist gemeint? Ähnlichkeiten nutzen unter Umständen wenig ... :oops:

:-? Für NIcht-Programmierer eher kompliziert, - oder?

Grüße

Benutzeravatar
redbull254
Valued Contributor
Beiträge: 10362
Registriert: 05.01.2006 13:01
Kontaktdaten:

Re: 3.0. -- 3.1 jetzt schon umstellen?

Beitragvon redbull254 » 28.10.2015 01:54

Hallo erstmal,

Hallo Marina,
Talk19zehn hat geschrieben:8) Wo finde ich, du, er, sie eine verständliche An, - Einleitung? Oder was ist gemeint? Ähnlichkeiten nutzen unter Umständen wenig ... :oops:


fängt schon beim eigenen Style/Template an. Wie bekommt man den auf die neue phpBB 3.1.x Version aktualisiert? Ich glaube, neben den Mods vermissen viele eine Kurzanleitung für den Komplett-Umstieg. phpBB3.0.xx wird sicher nicht in den nächsten Jahren gehackt werden, da bin ich sicher. Von daher ist jede Kurzschluss-Reaktion zu vermeiden. Selbst phpBB1/2 ist meines Wissens nach noch nie gehackt worden, außer der Administrator hat massive Sicherheitsfehler gemacht. Wer für sein Forum alle nötigen Mods als Extensions findet, sollte sicherlich auf die aktuelle phpBB-Version 3.1.x umsteigen, allein schon um auf lange Sicht den Anschluss nicht zu verpassen. Wer (noch) keine passenden Extensions für sein Forum findet, kann sich sicher noch eine Zeitlang entspannt zurück legen. Selbst einige Mitglieder des Entwickler-Teams betreiben m.W. weiterhin (noch) ihre phpBB 3.0.14 Foren. und die sollten es doch am besten wissen. ;-)

Benutzeravatar
gn#36
Administrator
Administrator
Beiträge: 9174
Registriert: 01.10.2006 16:20
Wohnort: Ganz in der Nähe...
Kontaktdaten:

Re: 3.0. -- 3.1 jetzt schon umstellen?

Beitragvon gn#36 » 28.10.2015 11:45

Talk19zehn hat geschrieben:8) Wo finde ich, du, er, sie eine verständliche An, - Einleitung? Oder was ist gemeint? Ähnlichkeiten nutzen unter Umständen wenig ... :oops:

:-? Für NIcht-Programmierer eher kompliziert, - oder?

Tja, das mit der Anleitung ist leider schwierig. Ich gebe dir recht, dass man für viele Konvertierungen wohl Programmierkenntnisse brauchen dürfte, aber nicht um zu schauen ob es ähnliche Mods gibt.

Nehmen wir als Beispiel mal Kalender-Mods. Da gibt's für 3.0 und älter ne gewisse Auswahl, auch wenn man evtl. einige der älteren Modelle nirgendwo mehr findet. Für 3.1 gibt es nun auch wieder Kalender Extensions. Vermutlich wird man von 3.0 seine Kalendereinträge mitnehmen wollen, aber ich kenne im Moment keinen Kalender Mod, der einen direkten Nachfolger mit Upgrademöglichkeit hat (lasse mich da gerne eines besseren belehren, ist aber für das Beispiel auch nicht so wichtig).

Der Aufwand, selber eine neue Kalender Extension zu programmieren ist viel größer als wenn man nur die Daten vom alten ins neue Format bringen muss und die Extension ansich schon existiert. Wenn man das nicht selber hinkriegt gibt's ja immer noch die Jobbörse, oder vielleicht kriegt man auch den Extension Autor der neuen Extension überredet, wenn viele vom selben alten Mod umsteigen wollen diesen alten Mod zu berücksichtigen und einen Konverter zu erstellen.

redbull254 hat geschrieben:fängt schon beim eigenen Style/Template an. Wie bekommt man den auf die neue phpBB 3.1.x Version aktualisiert?

Da gibt's bestimmt noch mehr, wofür es mal Anleitungen geben sollte, zumindest rudimentäre. Vielleicht fangen wir in einem separaten Thema einfach mal an zu sammeln? Das macht es einfacher, den Bedarf abzuschätzen und vielleicht findet sich dann ja leichter jemand, der welche erstellt? Ich habe z.B. auch noch ein oder zwei Anleitungen die ich versprochen hatte auf meiner Liste stehen, bin aber noch nicht dazu gekommen diese zu erstellen.
Begegnungen mit dem Chaos sind fast unvermeidlich, Aber nicht katastrophal, solange man den Durchblick behält.
Übertreiben sollte man's im Forum aber nicht mit dem Chaos, denn da sollen ja andere durchblicken und nicht nur man selbst.

Benutzeravatar
Crizzo
Administrator
Administrator
Beiträge: 9356
Registriert: 19.05.2005 21:45
Kontaktdaten:

Re: 3.0. -- 3.1 jetzt schon umstellen?

Beitragvon Crizzo » 28.10.2015 19:23

Hi,

redbull254 hat geschrieben:fängt schon beim eigenen Style/Template an. Wie bekommt man den auf die neue phpBB 3.1.x Version aktualisiert?


Zum Beispiel so: viewtopic.php?p=1345049#p1345049
phpBB Translations & International Support Teams Manager


Zurück zu „phpBB Diskussion“