phpBB 3.1 Framework / Symfony 3.1-Beta1 erschienen

Diskussionen über aktuelle und zukünftige phpBB-Versionen.
Wichtig: Bitte unbedingt die Forum-FAQ beachten! Kein Support!
Forumsregeln
Bitte unbedingt die Forum-FAQ beachten!
Talk19zehn
Ehemaliger
Beiträge: 4279
Registriert: 08.06.2009 12:03

phpBB 3.1 Framework / Symfony 3.1-Beta1 erschienen

Beitragvon Talk19zehn » 21.05.2016 13:11

Hello, meinen Informationen zur Folge steht "Symfony 3.1" kurz vor dem Abschluss einer Veröffentlichung. Informationen findet man bspw. unter:
https://entwickler.de/online/php/symfon ... 46357.html
bzw. bzgl. dem derzeitigen Stand der Neuerungen, Verbesserungen, Updates auf
https://github.com/symfony/symfony/pull/18776

Mich würde es brennend interessieren, ob phpBB 3.1.9 davon profitieren wird und demnach für phpBB-3.1.9 ein Update geplant wird und anstünde.
Ich würde schon gerne wissen, was phpBB 3.1 Ascraeus "in den letzten Zügen" bis zum [EOL im Nov. 2016] u.U. mitbringt. Ob also "Symfony 3.1" berücksichtigt werden wird.

In der Konsequenz könnte ich vermuten, dass neuere Features seitens der Entwickler für phpBB 3.2 Rhea wiederum in Teilen in das auf 3.1.9 folgende Update einfließen. Ist das korrekt?

Dank und beste Grüße
Angaben ohne Gewähr, da von zahlreichen Komponenten abhängig. 8)

Benutzeravatar
Crizzo
Administrator
Administrator
Beiträge: 9246
Registriert: 19.05.2005 21:45
Kontaktdaten:

Re: phpBB 3.1 Framework / Symfony 3.1-Beta1 erschienen

Beitragvon Crizzo » 21.05.2016 14:28

Hi,

phpBB 3.1 benötigt min. PHP 5.3.3 und nutzt Symfony 2.3.x, was wiederum min. PHP 5.3.3 benötigt.

phpBB 3.2 benötigt min. PHP 5.4 und nutzt Symfony 2.8.x, was wiederum min. PHP 5.3.9 benötigt.

Symfony 3.0.x/3.1.x benötigt min. PHP 5.5.9.

Sofern also die mind. Anforderungen für die jeweiligen phpBB-Versionen nicht deutlich nach oben korrigiert werden, wird sich vermutlich keine neuere Symfony-Version in einen der Bugfix-Releases für die neue Version befinden.

Gibt es denn eine konkrete Funktion von Symfony 3.0/3.1, die du nicht in 2.3 oder 2.8 findest?

Grüße
phpBB Translations & International Support Teams Manager

Benutzeravatar
marc1706
phpBB.com
Beiträge: 319
Registriert: 20.08.2008 11:11
Wohnort: München
Kontaktdaten:

Re: phpBB 3.1 Framework / Symfony 3.1-Beta1 erschienen

Beitragvon marc1706 » 23.05.2016 21:28

phpBB 3.2 nutzt das LTS Release von Symfony, die aktuelle Version 2.8. Die nächste LTS Version von Symfony ist erst wieder die Version 3.4. Stabile Versionen von phpBB werden vorerst nur LTS Releases von Symfony verwenden.
phpBB Lead Developer


Zurück zu „phpBB Diskussion“