Letztes Attachmentbild im anzeigen

In diesem Forum können Mod-Autoren ihre Mods vorstellen, die sich noch im Entwicklungsstatus befinden. Der Einbau in Foren im produktiven Betrieb wird nicht empfohlen.
Forumsregeln
phpBB 2.0 hat das Ende seiner Lebenszeit überschritten
phpBB 2.0 wird nicht mehr aktiv unterstützt. Insbesondere werden - auch bei Sicherheitslücken - keine Patches mehr bereitgestellt. Der Einsatz von phpBB 2.0 erfolgt daher auf eigene Gefahr. Wir empfehlen einen Umstieg auf phpBB 3.0, welches aktiv weiterentwickelt wird und für welches regelmäßig Updates zur Verfügung gestellt werden.
mora
Mitglied
Beiträge: 64
Registriert: 19.08.2005 11:23

Beitrag von mora »

Hallo, ich nochmal!

bei der Ausführung habe ich jetzt ein

unexpected T_STRING
irgendwo hier

Code: Alles auswählen

$user_link = append_sid($phpbb_root_path.'profile.php?mode=viewprofile&u='.$attach_user['user_id']); 
echo '<a href="'.$user_link.'">'.$user_attach['username'].'</a><br /> 
?

fanrpg
Mitglied
Beiträge: 2909
Registriert: 13.12.2004 22:41

Beitrag von fanrpg »

Code: Alles auswählen

$sql = "SELECT * FROM `phpbb_attachements` WHERE `extension`= 'jpg' OR `extension` = 'jpeg' OR `extension` = 'png' ORDER BY `attach_id` DESC LIMIT 1"; 
if(!($result = $db->sql_query($sql))) 
{ 
message_die(GENERAL_ERROR, 'Could not query last attachement', '', __LINE__, __FILE__, $sql); 
} 
$row = $db->sql_fetchrow($result); 
$attach_id = $row['attach_id']; 
$filename = $row['real_filename']; 
$topic_id = $row['topic_id']; 
$poster_id = $row['poster_id']; 
$sql = "SELECT `username`, `user_id` FROM `".USERS_TABLE."` WHERE `user_id` = '".$poster_id."' LIMIT 1"; 
if(!($result = $db->sql_query($sql))) 
{ 
message_die(GENERAL_ERROR, 'Could not query attachement->userdata', '', __LINE__, __FILE__, $sql); 
} 
$attach_user = $db->sql_fetchrow($result); 

     $size = getimagesize('media/'.$filename.'); 
       $height = $size[1]; 
       $width = $size[0]; 
     if ($height > 150) 
         { 
               $height = 150; 
               $percent = ($size[1] / $height); 
               $width = ($size[0] / $percent); 
         } 
     else if ($width > 150) 
         { 
               $width = 150; 
               $percent = ($size[0] / $width); 
               $height = ($size[1] / $percent); 
         } 
$user_link = append_sid($phpbb_root_path.'profile.'.$phpEx.'?mode=viewprofile&u='.$attach_user['user_id']); 
$topic_link = append_sid($phpbb_root_path.'viewtopic.'.$phpEx.'?t='.$topic_id);
echo '<a href="'.$user_link.'">'.$user_attach['username'].'</a><br /> 
<a href="'. $topic_link .'"><img src="media/'.$filename.'" alt="" border="0" width="'.$width.'" height="'.$height.'"></a>';
Versuchs so mal.

mora
Mitglied
Beiträge: 64
Registriert: 19.08.2005 11:23

Beitrag von mora »

(sorry, hat etwas gedauert, war noch beschäftigt)

Ähm, nee, gleiche Fehlermeldung.

Ich habe den Code in eine eigene Datei abgelegt und davor diese Anweisungen gemacht

Code: Alles auswählen

define('IN_PHPBB', true);
$phpbb_root_path = './';
include($phpbb_root_path . 'extension.inc');
include($phpbb_root_path . 'common.'.$phpEx);
Ist das ausreichend oder brauchts noch was?
Vielleicht liegt es auch daran.

fanrpg
Mitglied
Beiträge: 2909
Registriert: 13.12.2004 22:41

Beitrag von fanrpg »

KB:phpbb_seite

Das mit dem in der Mitte ersetzen wo /***** Inhaltsbereich ******/ steht.

Das dürfte reichen.

mora
Mitglied
Beiträge: 64
Registriert: 19.08.2005 11:23

Beitrag von mora »

Ok, hab ich.

Trotzdem weiterhin die gleiche o.g. Fehlermeldung nach der letzten else-if-Anweisung .

fanrpg
Mitglied
Beiträge: 2909
Registriert: 13.12.2004 22:41

Beitrag von fanrpg »

Poste mal die ganze Fehlermeldung und nicht nur ein Teil.

mora
Mitglied
Beiträge: 64
Registriert: 19.08.2005 11:23

Beitrag von mora »

Parse error: syntax error, unexpected T_STRING in /home/www/doc/12252/xxxxxxxx.de/www/show_lastpic.php on line 52

fanrpg
Mitglied
Beiträge: 2909
Registriert: 13.12.2004 22:41

Beitrag von fanrpg »

Nimm das mal:

Code: Alles auswählen

$sql = "SELECT * FROM `phpbb_attachements` WHERE `extension`= 'jpg' OR `extension` = 'jpeg' OR `extension` = 'png' ORDER BY `attach_id` DESC LIMIT 1"; 
if(!($result = $db->sql_query($sql))) 
{ 
message_die(GENERAL_ERROR, 'Could not query last attachement', '', __LINE__, __FILE__, $sql); 
} 
$row = $db->sql_fetchrow($result); 
$attach_id = $row['attach_id']; 
$filename = $row['real_filename']; 
$topic_id = $row['topic_id']; 
$poster_id = $row['poster_id']; 
$sql = "SELECT `username`, `user_id` FROM `".USERS_TABLE."` WHERE `user_id` = '".$poster_id."' LIMIT 1"; 
if(!($result = $db->sql_query($sql))) 
{ 
message_die(GENERAL_ERROR, 'Could not query attachement->userdata', '', __LINE__, __FILE__, $sql); 
} 
$attach_user = $db->sql_fetchrow($result); 

     $size = getimagesize('media/'.$filename); 
       $height = $size[1]; 
       $width = $size[0]; 
     if ($height > 150) 
         { 
               $height = 150; 
               $percent = ($size[1] / $height); 
               $width = ($size[0] / $percent); 
         } 
     else if ($width > 150) 
         { 
               $width = 150; 
               $percent = ($size[0] / $width); 
               $height = ($size[1] / $percent); 
         } 
$user_link = append_sid($phpbb_root_path.'profile.'.$phpEx.'?mode=viewprofile&u='.$attach_user['user_id']); 
$topic_link = append_sid($phpbb_root_path.'viewtopic.'.$phpEx.'?t='.$topic_id); 
echo '<a href="'.$user_link.'">'.$user_attach['username'].'</a><br /> 
<a href="'. $topic_link .'"><img src="media/'.$filename.'" alt="" border="0" width="'.$width.'" height="'.$height.'"></a>';

mora
Mitglied
Beiträge: 64
Registriert: 19.08.2005 11:23

Beitrag von mora »

Jetzt sehe ich zumindest schon mal header und footer aber es gibt ein SQL-Error
:
Could not query last attachement

DEBUG MODE

SQL Error : 1146 Table 'dbxxxxx.phpbb_attachements' doesn't exist

SELECT * FROM `phpbb_attachements` WHERE `extension`= 'jpg' OR `extension` = 'jpeg' OR `extension` = 'png' ORDER BY `attach_id` DESC LIMIT 1

Line : 23
Zuletzt geändert von mora am 28.11.2005 18:08, insgesamt 1-mal geändert.

mora
Mitglied
Beiträge: 64
Registriert: 19.08.2005 11:23

Beitrag von mora »

stopp, ich benutze ja ein anderes präfix (nicht phpbb)...

Antworten

Zurück zu „phpBB 2.0: Mods in Entwicklung“