Anti-Bot-Question Mod

In diesem Forum können Mod-Autoren ihre Mods vorstellen, die sich noch im Entwicklungsstatus befinden. Der Einbau in Foren im produktiven Betrieb wird nicht empfohlen.
Forumsregeln
phpBB 2.0 hat das Ende seiner Lebenszeit überschritten
phpBB 2.0 wird nicht mehr aktiv unterstützt. Insbesondere werden - auch bei Sicherheitslücken - keine Patches mehr bereitgestellt. Der Einsatz von phpBB 2.0 erfolgt daher auf eigene Gefahr. Wir empfehlen einen Umstieg auf phpBB 3.0, welches aktiv weiterentwickelt wird und für welches regelmäßig Updates zur Verfügung gestellt werden.
sehomer
Mitglied
Beiträge: 3
Registriert: 23.07.2008 13:25

Beitragvon sehomer » 23.07.2008 13:32

hallo,

ich habe gestern den antibotquestion-mod installiert und hab gleich mal ne registrierung probiert... jetzt kommt immer die fehlermeldung:

Du musst alle benötigten Felder ausfüllen.
Die angegebene Mailadresse ist ungültig.


nun meine frage: bei den codeänderungen ist mir aufgefallen, daß eine FIND-stelle mehrmals in der Datei kam - muss ich alle ändern, oder nur die jeweils nächste, wenn ich in der Reihenfolge arbeite, die die installationsanweisung vorgibt.

Danke und viele Grüße
Sebastian

- Sim -
Mitglied
Beiträge: 24
Registriert: 27.02.2006 11:51
Wohnort: Jülich Germany
Kontaktdaten:

Beitragvon - Sim - » 29.08.2008 09:41

Hallo

habe den Mod seit Monaten verbaut, und keinerlei Probleme gehabt, seit ein paar Minuten dieser Fehler:

Code: Alles auswählen

Could not delete stale anti bot question data

DEBUG MODE

SQL Error : 1153 Got a packet bigger than 'max_allowed_packet'

........

'ffd7c14168d60c7693691e25cb4da526', 'ffd8afbfdbf7a36ed4d033ee3a0a99f4', 'ffd96f2d8d13433c584a8a914a3f8ba5', 'ffda9154bd77590f0ef6600a7a22b70d', 'ffe174e00b2a04a20f9e1562fffab2d6', 'ffe7b7ad82538a373d491e8375593eca', 'ffebf552821cce2ae567d0d1381a72d0', 'fff12be8ecf8fe16d05a3b58e21b40f9', 'fff6bc5dd91676ad1fb7dda6d10e5938', 'fff790ec2c28e3eb1a4121d19f1d1db4', 'fff7fe3ce6fa4b54e5c42262d89dcd57', 'fff838cc3baef799948825fe97ed8a96', 'fff8e799054614452f95aeb36b4a8ea5', 'fffdf3f1df9429e96081a9ee04fbbbec', 'fffe1c6dc9e49aaec38e25d4dbb81b50', 'fffec772337a4daf1cf306b107a5b999')

Line : 75
File : functions_abq.php



hat evtl jemand ne Idee?

Benutzeravatar
Würzi
Ehemaliger
Beiträge: 3187
Registriert: 30.10.2005 02:51
Wohnort: Würzburg
Kontaktdaten:

Beitragvon Würzi » 29.08.2008 10:01

Ich hab ne Idee :o

Die Suchfunktion hier :o

Got a packet bigger than 'max_allowed_packet' :wink:

- Sim -
Mitglied
Beiträge: 24
Registriert: 27.02.2006 11:51
Wohnort: Jülich Germany
Kontaktdaten:

Beitragvon - Sim - » 29.08.2008 10:03

habs nun auch gefunden,.

danke :P

- Sim -
Mitglied
Beiträge: 24
Registriert: 27.02.2006 11:51
Wohnort: Jülich Germany
Kontaktdaten:

Beitragvon - Sim - » 29.08.2008 11:27

aber es kann doch nicht sinn der Sache sein, die max packets zu erhöhen, vielleicht sollte der mod geändert werden (können) damit gar nicht so große abfragen entstehen? Das lahmt ja auch alles....

- Sim -
Mitglied
Beiträge: 24
Registriert: 27.02.2006 11:51
Wohnort: Jülich Germany
Kontaktdaten:

Beitragvon - Sim - » 29.08.2008 13:04

hab mal auf Version 3.0.0 geupdatet.

Nun funktioniert es wieder, und das Forum ist merklich flotter...

s0801634
Mitglied
Beiträge: 7
Registriert: 04.05.2008 23:16
Wohnort: Detmold

Beitragvon s0801634 » 08.09.2008 12:00

Ich habe den MOD gestern auch zum Laufen bekommen :grin:

Jedoch: Auf der Seite "Registrierung" steht oben über dem Registrierungsformular noch diese hässliche Zeile:

Warning: mysql_free_result(): supplied argument is not a valid MySQL result resource in /homepages/42/d201861658/htdocs/tripguru/forum/db/mysql4.php on line 318


Was soll mir das sagen bzw. wie bekomme ich diese Zeile wieder weg?


Gruß aus Detmold,
Michael

fry13
Mitglied
Beiträge: 2
Registriert: 08.09.2008 19:49

Beitragvon fry13 » 08.09.2008 20:00

ich habe genau den selebn fehler, nur halt mit entsprechent anderem link

Code: Alles auswählen

Warning: mysql_free_result(): supplied argument is not a valid MySQL result resource in /home/www/web12/html/forum/db/mysql4.php on line 318

und er steht nicht nur über der registrierung sondern auch ganz oben bei jedem schreiben eines neuen beitrags zusammen mit

Code: Alles auswählen

Warning: Cannot modify header information - headers already sent by (output started at /home/www/web12/html/forum/db/mysql4.php:318) in /home/www/web12/html/forum/includes/page_header.php on line 479

Warning: Cannot modify header information - headers already sent by (output started at /home/www/web12/html/forum/db/mysql4.php:318) in /home/www/web12/html/forum/includes/page_header.php on line 485

Warning: Cannot modify header information - headers already sent by (output started at /home/www/web12/html/forum/db/mysql4.php:318) in /home/www/web12/html/forum/includes/page_header.php on line 486


ich benutze die 2.0.23 mit dem skin athena

kann mir wer weiterhelfen?

fry13
Mitglied
Beiträge: 2
Registriert: 08.09.2008 19:49

Beitragvon fry13 » 09.09.2008 01:04


miniaturenmaler
Mitglied
Beiträge: 3
Registriert: 11.11.2008 21:36

Re: Anti-Bot-Question Mod

Beitragvon miniaturenmaler » 19.01.2009 23:47

Hallo zusammen

Ich habe ein kleine Frage....
Und zwar wollte ich heute den Mod installieren. Allerdings erscheint im Installationsmenu, sobald ich auf (um nur ein Beispiel zu nennen) "Configuration" klicke folgende Fehlermeldung:

phpBB : Critical Error

Could not query config information in abq_config

DEBUG MODE

SQL Error : 1146 Table 'db1833303.ANTI_BOT_QUEST_CONFIG_TABLE' doesn't exist

SELECT * FROM ANTI_BOT_QUEST_CONFIG_TABLE WHERE config_name NOT LIKE 'AutoQuestion_%' AND config_name NOT LIKE 'Color_%'

Line : 324
File : abq_config.php


Kann mir Jemand helfen? Ich weiss nicht, woran es liegen könnte.



EDIT:
Falls es was bringt hier noch die paar Zeilen rund um Zeile 324:

$sql = 'SELECT *
FROM ' . ANTI_BOT_QUEST_CONFIG_TABLE . '
WHERE config_name NOT LIKE \'AutoQuestion_%\' AND config_name NOT LIKE \'Color_%\'';
if(!$result = $db->sql_query($sql))
{
message_die(CRITICAL_ERROR, "Could not query config information in abq_config", "", __LINE__, __FILE__, $sql);
}


Zurück zu „phpBB 2.0: Mods in Entwicklung“