[Beta] Hostingscript für phpBB

In diesem Forum können Mod-Autoren ihre Mods vorstellen, die sich noch im Entwicklungsstatus befinden. Der Einbau in Foren im produktiven Betrieb wird nicht empfohlen.
Forumsregeln
phpBB 2.0 hat das Ende seiner Lebenszeit überschritten
phpBB 2.0 wird nicht mehr aktiv unterstützt. Insbesondere werden - auch bei Sicherheitslücken - keine Patches mehr bereitgestellt. Der Einsatz von phpBB 2.0 erfolgt daher auf eigene Gefahr. Wir empfehlen einen Umstieg auf phpBB 3.0, welches aktiv weiterentwickelt wird und für welches regelmäßig Updates zur Verfügung gestellt werden.
leon1222
Mitglied
Beiträge: 130
Registriert: 03.03.2006 16:48

Beitragvon leon1222 » 30.04.2006 20:43

was soll bei der config datenbank benutzer heißen
ich habe nur nen datenbank namen und ein passwort.

Benutzeravatar
tas2580
Ehemaliger
Beiträge: 2803
Registriert: 01.07.2004 05:42
Wohnort: /home/tas2580
Kontaktdaten:

Beitragvon tas2580 » 30.04.2006 20:44

@Ankkah: schmeiß mal die .htaccess raus, es kann sein das dein Webspace kein mod_rewrite unterstützt. Dann musst du für das Forum die Dateien aus einem normalen phpBB nehmen und alles bis auf die config.php damit ersetzen.

@leon1222: Da muss es auch einen Benutzer geben, einfach mal den Hoster fragen.
Heute ist ein guter Tag um dein Forum zu testen.
Ehemaliger Benutzername: [BTK] Tobi

Ankkah
Mitglied
Beiträge: 21
Registriert: 27.04.2006 21:07

Beitragvon Ankkah » 01.05.2006 06:55

juhuu ich habs geschafft es geht

danke danke

Ankkah
Mitglied
Beiträge: 21
Registriert: 27.04.2006 21:07

Beitragvon Ankkah » 06.05.2006 16:59

wäre noch cool wen es prüft ob es das Forum xy gibt und fals nicht anstatt das hier:
phpBB : Kritischer Fehler

Could not query config information

DEBUG MODE

SQL Error : 1146 Table 'usr_web223_1.mail_config' doesn't exist

SELECT * FROM mail_config

Line : 214
File : common.php


was anderes kommt
z.B.

Dieses Forum existiert nicht.

zur Startseite

Benutzeravatar
tas2580
Ehemaliger
Beiträge: 2803
Registriert: 01.07.2004 05:42
Wohnort: /home/tas2580
Kontaktdaten:

Beitragvon tas2580 » 06.05.2006 20:11

Suche in common.php

Code: Alles auswählen

$sql = "SELECT *
   FROM " . CONFIG_TABLE;
if( !($result = $db->sql_query($sql)) )
{
      message_die(CRITICAL_ERROR, "Could not query config information", "", __LINE__, __FILE__, $sql);
}

ersetze mit

Code: Alles auswählen

$sql = "SELECT *
   FROM " . CONFIG_TABLE;
if( !($result = $db->sql_query($sql)) )
{
   header("HTTP/1.1 301 Moved Permanently");
   header("Location: http://www.deine-domain.de/kein-forum.html");
   //   message_die(CRITICAL_ERROR, "Could not query config information", "", __LINE__, __FILE__, $sql);
}

Dann legst du dir einfach auf deine-domain.de/kein-forum.html eine Datei die angezeigt werden soll wenn es kein Forum gibt.
Heute ist ein guter Tag um dein Forum zu testen.
Ehemaliger Benutzername: [BTK] Tobi

Ankkah
Mitglied
Beiträge: 21
Registriert: 27.04.2006 21:07

Beitragvon Ankkah » 08.05.2006 14:48

Danke es geht 8)

Benutzeravatar
Bonaparte
Mitglied
Beiträge: 308
Registriert: 07.12.2004 23:24
Wohnort: Hamburg
Kontaktdaten:

Beitragvon Bonaparte » 02.06.2006 14:31

Ist es eigenltich möglich das Script ohne Wildcard Subdomains und stattdessen in einem Unterverzeichnis laufen zu lassen?

leon1222
Mitglied
Beiträge: 130
Registriert: 03.03.2006 16:48

Beitragvon leon1222 » 04.06.2006 11:36

das würd mich auch interresieren kann man es umprogrammieren damit es
ohne subdomains läuft,

Stefajo
Mitglied
Beiträge: 69
Registriert: 12.11.2005 19:39

Beitragvon Stefajo » 05.06.2006 20:10

Also ich find die Idee von dir sehr gut :) :)
Ich hab mal aus Interesse probiert, dass aufn Funpic Webspace zu legen, allerdings kommt immer wenn ich im Adminbereich auf Konfiguration gehe folgende Fehlermeldung: Unknown column 'mailtext' in 'field list'

Und wenn man ein Forum erstellt, funktioniert es nicht :(

Gruß

Stef

Ankkah
Mitglied
Beiträge: 21
Registriert: 27.04.2006 21:07

Beitragvon Ankkah » 08.06.2006 06:21

Das sollte dir helfen:
:wink:

außerdem bekomm ich immer Unknown column 'mailtext' in 'field list'
Was soll ich tun?
Spiel mal diesen Dump in die DB ein.

Code: Alles auswählen

CREATE TABLE `hp_einstellungen` (
  `email` varchar(255) NOT NULL default '',
  `seitenname` varchar(255) NOT NULL default '',
  `posting` longtext NOT NULL,
  `template` varchar(255) NOT NULL default '',
  `mailtext` longtext NOT NULL
) TYPE=MyISAM;

INSERT INTO `hp_einstellungen` VALUES ('mail@deine-domain.de', 'Kostenloses Forum!', 'gjcmbv,en.\r\n\r\nwww.anything4free.de', 'blau', 'Ihr Forum wurde angelegt!\r\n\r\nSie können es jetzt unter #domain# aufrufen und sich mit den Benutzerdaten die Sie bei der Bestellung angegeben haben anmelden.\r\n\r\nViel Spass mit Ihrem neuen Forum\r\nIhr Multi SEO phpBB Team!');

CREATE TABLE `hp_freeforen` (
  `ID` int(11) NOT NULL auto_increment,
  `vorname` varchar(255) NOT NULL default '',
  `name` varchar(255) NOT NULL default '',
  `adresse` varchar(255) NOT NULL default '',
  `domain` varchar(255) NOT NULL default '',
  `plz` varchar(255) NOT NULL default '',
  `ort` varchar(255) NOT NULL default '',
  `website` varchar(255) NOT NULL default '',
  `email` varchar(255) NOT NULL default '',
  `admin` varchar(255) NOT NULL default '',
  `admin_email` varchar(255) NOT NULL default '',
  `passwort` varchar(255) NOT NULL default '',
  `tel` varchar(255) NOT NULL default '',
  `status` int(11) NOT NULL default '0',
  `time` timestamp(14) NOT NULL,
  PRIMARY KEY  (`ID`)
) TYPE=MyISAM AUTO_INCREMENT=25 ;

CREATE TABLE `hp_texte` (
  `nutz` longtext NOT NULL,
  `home` longtext NOT NULL
) TYPE=MyISAM;

INSERT INTO `hp_texte` VALUES ('TEST', '<h1>Kostenloses phpBB Forum</h1>\r\n<p>Gehe in den Adminbereich um diesen Text zu bearbeiten!</p>');


Zurück zu „phpBB 2.0: Mods in Entwicklung“