unerwünschte Bots bzw. E-Mail-Spider aushebeln

In diesem Forum können Mod-Autoren ihre Mods vorstellen, die sich noch im Entwicklungsstatus befinden. Der Einbau in Foren im produktiven Betrieb wird nicht empfohlen.
Forumsregeln
phpBB 2.0 hat das Ende seiner Lebenszeit überschritten
phpBB 2.0 wird nicht mehr aktiv unterstützt. Insbesondere werden - auch bei Sicherheitslücken - keine Patches mehr bereitgestellt. Der Einsatz von phpBB 2.0 erfolgt daher auf eigene Gefahr. Wir empfehlen einen Umstieg auf phpBB 3.0, welches aktiv weiterentwickelt wird und für welches regelmäßig Updates zur Verfügung gestellt werden.
Benutzeravatar
Saint
Mitglied
Beiträge: 1164
Registriert: 09.04.2004 14:06
Wohnort: Hamburg
Kontaktdaten:

Beitragvon Saint » 05.06.2004 23:17

itst hat geschrieben:Mehr Sicherheit bedeutet weniger Freiheit.

Da stimme ich Dir zu 100% zu.
~~~ Facebook: Das Wikileaks für den Freundeskreis. ~~~

Board3 PortalHarmony Remote ForumSqueezebox Forum

Benutzeravatar
Wuppi
Mitglied
Beiträge: 685
Registriert: 14.05.2002 23:04
Wohnort: Köln

Beitragvon Wuppi » 06.06.2004 11:21

Saint hat geschrieben:Wieso macht Ihr Euch denn so einen Stress?
Ich denke mit diesem Mod kann man sämtliche email Spider erschlagen, da dann der Emailbutton für Gäste gar nicht mehr vorhanden ist.
Es sei denn die kleinen Kotzbrocken können sich inzwischen als User tarnen.
:wink:


Mhhh .. hatte vor 2-3 Jahren mit nem eMail-Grabber rumgespielt - der hatte ne Funktion um sich auf Passwortgeschützten Seiten einzuloggen! (Account muß natürlich vorhanden sein - bei großen Foren macht man sich einfach die Arbeit mal eben - lohnt ja *G*) ... weiß nur nicht welches "System" da direkt unterstützt wurde - ins Forum kam ich damit jedenfalls nicht.

Da vor 2-3 Jahren den Grabbern den ich hatte, noch JavaScript beigebracht werden mußte, aber JS heute standard ist (eMails in JS "versteckt" werden per default gefunden), denk ich mal das es mit der Forenanmeldung auch kein wirkliches Problem mehr gibt - find leider den Grabber den ich damals genutzt habe, nicht mehr :( Nur nen ganz anderen - der konnte es jedenfalls noch nicht.

Bis denne
Wuppi

PS: es gab mal div. Mod-Ansätze wie man als Gast trotzdem an die Mails kommt, aber nur wenn der Gast keine KI hat ;) ... hier im Forum - aber leider nicht weiterverfolgt :( U.a. "klick auf Mail-Button" -> fenster öffnet sich -> zahl abtippen -> email-Link wird im Fenster angezeigt)

Benutzeravatar
strg0
Mitglied
Beiträge: 123
Registriert: 04.09.2003 15:27
Wohnort: Essen
Kontaktdaten:

Beitragvon strg0 » 13.06.2004 16:06

larsneo hat geschrieben:das ist der msnbot - siehe z.b. http://www.masterhilfe.de/thema-2112.html


mhh ja ok es ist der msnbot.. der kommt regelmässig und druchwühlt alles .. soweit klar...
aber wie kann ich ihn verbannen... den vorschlag von "seite1" hab ich schon in meiner htacess kopiert..leider ohne erfolg..
wie kann ich eindeutige ip´s von meiner domain verbannen..
Franky

www: wo tut´s weh?

Benutzeravatar
larsneo
Valued Contributor
Beiträge: 2613
Registriert: 07.03.2002 15:23
Wohnort: schwäbisch gmünd
Kontaktdaten:

Beitragvon larsneo » 13.06.2004 20:19

wieso über ip? der msnbot hat ja einen eindeutigen USER_AGENT, also sollte

Code: Alles auswählen

RewriteCond %{HTTP_USER_AGENT} ^msnbot [OR]
als erweiterung der liste eigentlich völlig ausreichen...
gruesse aus dem wilden sueden
larsneo
..::[cms-sicherheit]::..

Hacke.Peter
Mitglied
Beiträge: 5
Registriert: 21.04.2004 13:00
Wohnort: Hessen
Kontaktdaten:

Beitragvon Hacke.Peter » 14.06.2004 15:33

Hi zusammen,

habe den Rat befolgt und mir eine .htaccess zusammenstellen lassen (von Web4Free.at)

leider funktioniert da irgendwas nicht.

Ich habe die geänderte Datei auf den FTP meines Providers geschoben und bekam danach Fehler 500 interner Serverfehler: Das Script konnte nicht ausgeführt werden...

Nach einigem ausprobieren habe ich festgestellt, daß es an dem Eintrag "RewriteEngine On" liegt. Kann es sein daß mein Provider das nicht unterstützt oder so?

Gruß Hacke.Peter

Benutzeravatar
larsneo
Valued Contributor
Beiträge: 2613
Registriert: 07.03.2002 15:23
Wohnort: schwäbisch gmünd
Kontaktdaten:

Beitragvon larsneo » 14.06.2004 15:49

Kann es sein daß mein Provider das nicht unterstützt oder so?


<hauch_in_die_glaskugel>
ja
</putz_die_glaskugel>

lesestoff: smart questions (*scnr*)
gruesse aus dem wilden sueden
larsneo
..::[cms-sicherheit]::..

Benutzeravatar
Wuppi
Mitglied
Beiträge: 685
Registriert: 14.05.2002 23:04
Wohnort: Köln

Beitragvon Wuppi » 14.06.2004 16:26

Hi

mit der Liste hab ich das gleiche Problem - aber die unterscheidet sich doch nur von der Menge von der von Larsneo (welche klappt)!?!?

Bis denne
Wuppi

Hacke.Peter
Mitglied
Beiträge: 5
Registriert: 21.04.2004 13:00
Wohnort: Hessen
Kontaktdaten:

Beitragvon Hacke.Peter » 14.06.2004 17:48

@larsneo: :o

Danke für den Lesetipp!

Schalte jetzt meinen Rechner aus und schäme mich zu Tode ein Problem zu haben... :oops:

Hacke.Peter
Mitglied
Beiträge: 5
Registriert: 21.04.2004 13:00
Wohnort: Hessen
Kontaktdaten:

Beitragvon Hacke.Peter » 14.06.2004 17:52

@Wuppi:

Das Problem ist der Eintrag "RewriteEngine on". Die Anzahl der Einträge ist irrelevant.
Versuche das gerade mit meinem Provider zu klären. Erfahrungsgemäß dauert sowas immer etwas länger. Deshalb hatte ich auf Tipps gehofft...

Egal - Danke Dir. Wenn ich mal nicht mehr auf Glas hauchen muß lasse ich es dich wissen.

Gruß Hacke.Peter

Benutzeravatar
strg0
Mitglied
Beiträge: 123
Registriert: 04.09.2003 15:27
Wohnort: Essen
Kontaktdaten:

Beitragvon strg0 » 17.06.2004 21:00

larsneo hat geschrieben:wieso über ip? der msnbot hat ja einen eindeutigen USER_AGENT, also sollte

Code: Alles auswählen

RewriteCond %{HTTP_USER_AGENT} ^msnbot [OR]
als erweiterung der liste eigentlich völlig ausreichen...


ich habe das ausprobiert und mir fällt auf das der bot (welcher auch immer ) das irgendwie nicht aufhält...
diese IP´s waren in den letzten tagen aktiv

Code: Alles auswählen

65.54.164.92
65.54.164.82 (diese mind. 3x)
62.241.52.125
66.196.90.65
66.196.90.113

somit sind es nicht statische IP´s .. msnbot sollte doch statische IP´s sein.

ich probiere nun dies mal aus..
das hier setzte ich in meine .htaccess

Code: Alles auswählen

Order deny,allow
deny from 62.241.164.125
deny from 65.54.164.82
deny from 66.196.90.65   
deny from 66.196.90.113

ob´s was bringt sehe ich in den nächsten tagen
Franky

www: wo tut´s weh?


Zurück zu „phpBB 2.0: Mods in Entwicklung“