kein Zugang zum Administrationsbereich

phpBB 3.0 hat sein "End of Life" erreicht. Eine Neu-Installation wird nicht mehr unterstützt.
Gesperrt
Lehrling
Supporter
Supporter
Beiträge: 3498
Registriert: 15.01.2012 20:00
Kontaktdaten:

kein Zugang zum Administrationsbereich

Beitrag von Lehrling » 29.10.2014 16:18

Hallo,
ich habe mein Testforum kopiert, also Dateien und Tabellen der Datenbank, und in einen Unterordner verschoben. Ich kann mich einloggen und als registrierter Benutzer alle Funktionen ausüben, aber ich komme nicht in den Administrationsbereich hinein. Wenn ich mich dort einloggen will, werde ich zum übergeordneten Forum weitergeleitet. Wenn ich megaschnell bin und es schaffe, mein Passwort in das Eingabefeld zu tippen, dann werde ich schon zum Administrationsbereich geführt, aber in der Regel ist das System schneller und dann lande ich auf der Index-Seite des übergeordneten Ordners.
Kann es etwas mit diesem Code

Code: Alles auswählen

define('IN_PHPBB', true); 
$phpbb_root_path = (defined('PHPBB_ROOT_PATH')) ? PHPBB_ROOT_PATH : './../'; 
in der index.php des Ordners adm zu tun haben?
Wie gesagt, das kopierte Forum liegt in einem Ordner, der im Hauptforum liegt.
LG Beate

Helmut
Mitglied
Beiträge: 2048
Registriert: 27.12.2002 20:35
Wohnort: Augsburg
Kontaktdaten:

Re: kein Zugang zum Administrationsbereich

Beitrag von Helmut » 02.11.2014 11:54

Hallo Beate,

also habe ich das richtig verstanden, du hast eine Kopie des Forums im root Verzeichnis in einen Unterordner angelegt?

Wenn dem so ist, dann wird das immer Probleme bereiten, das hängt auch mit den Cookies zusammen. Also besser eine Kopie des Forums in ein eigenes Verzeichnis anlegen das nicht im Root Verzeichnis eines anderen Forums liegt, sondern außerhalb. Du hast aber schon in der phpbb_config einen neuen Cookie Namen vergeben und den Pfad angepasst und das cache/ Verzeichnis bereinigt? Dann noch den Cache vom Browser leeren und ggf. die Coookies vom Forum löschen.

Die von dir genannten Angaben in der adm/index.php stimmen schon, da diese sich ja auf das Root Verzeichnis des Forums beziehen.

Gruß Helmut
Ich bin nicht ganz dicht.... na und.

Meine HP

Lehrling
Supporter
Supporter
Beiträge: 3498
Registriert: 15.01.2012 20:00
Kontaktdaten:

Re: kein Zugang zum Administrationsbereich

Beitrag von Lehrling » 02.11.2014 13:52

Hallo Helmut,
Helmut hat geschrieben:Also besser eine Kopie des Forums in ein eigenes Verzeichnis anlegen das nicht im Root Verzeichnis eines anderen Forums liegt, sondern außerhalb.
Das geht leider nicht, weil sich dann der Domainname ändert.
Du hast aber schon in der phpbb_config einen neuen Cookie Namen vergeben und den Pfad angepasst und das cache/ Verzeichnis bereinigt? Dann noch den Cache vom Browser leeren und ggf. die Coookies vom Forum löschen.
Ähm, nein. :oops: Der Cookiename ist etwas kryptisch: vier Buchstaben und eine Zahl. Wie muss ich das jetzt ändern? Und bei Pfad steht /.
Der Ordner, in dem die Kopie liegt, heißt alt. Soll ich jetzt bei Pfad /alt eingeben?
LG Beate

Benutzeravatar
Elsensee
Ehemaliges Teammitglied
Beiträge: 832
Registriert: 19.05.2010 15:14
Wohnort: Hamburg
Kontaktdaten:

Re: kein Zugang zum Administrationsbereich

Beitrag von Elsensee » 02.11.2014 14:27

Lehrling hat geschrieben:Ähm, nein. :oops: Der Cookiename ist etwas kryptisch: vier Buchstaben und eine Zahl. Wie muss ich das jetzt ändern? Und bei Pfad steht /.
Der Ordner, in dem die Kopie liegt, heißt alt. Soll ich jetzt bei Pfad /alt eingeben?
LG Beate
Den Cookienamen kannst du ändern, wie du willst.
Und ja, beim Pfad musst du "/alt" eintragen. :wink:
Posts mostly powered by GitHub and phpBB.de Cross-Reference

2015-03-20 - Never forget 8)

Gesperrt

Zurück zu „[3.0.x] Installation, Update und Konvertierung“