Seite 1 von 1

Sql Fehler: Update nötig? Wie updaten per FTP?

Verfasst: 04.11.2013 11:36
von Shran
Hallo,

ich bin der Gründer des Trekdinner Hildesheim. Wir haben auch ein Forum, das habe ich aber nicht selbst erstellt, sondern ein ehemals recht aktives Mitglied, welches aber weggezogen ist.

Das Design für unser Forum wurde leicht angepasst, um individuell erkennbar zu sein als das Forum des TD Hildesheim. Das ist auch der Grund, aus dem ich mich nie daran traute, ein Update vorzunehmen. Ich kenne mich mit phpbb nicht aus und befürchtete, dass Design zu zerstören, wenn ich ein update draufziehe.

Jetzt allerdings gibt es akutell ein richtiges Problem: Wenn man sich im Forum anmeldet (trekdinner-hildesheim.de), erscheint folgende Fehlermeldung:

General Error
SQL ERROR [ mysqli ]

Table './usr_ph16s614_2/tdhifo_sessions' is marked as crashed and should be repaired [145]

An sql error occurred while fetching this page. Please contact an administrator if this problem persists.

Ich komme noch per filezilla an die Daten.

Was muss ich tun, um unser Forum zu retten? Die Foreninhalte habe ich schon per filezilla gerettet, sprich kopiert. Aber was muss ich tun, damit das Forum wieder läuft?

Meine phpbb - Kenntnisse beschränken sich auf das Registrieren von Benutzern und das administrieren von Forenbeiträgen. Gern lerne ich dazu, habe aber im Moment keine Ahnung, was zu tun ist.

Kann wer helfen? :o :oops:

Re: Sql Fehler: Update nötig? Wie updaten per FTP?

Verfasst: 04.11.2013 11:39
von Crizzo
Hi,

melde dich in PHPMyAdmin (oder einer ähnlichen MySQL-Software ein), gehe in die Datenbank deines Forums und markiere die genannte Tabelle und wähle "Tabelle reparieren".

Umgang mit phpMyAdmin

Grüße

PS: Wenn das wirklich noch ein phpBB2.x ist, solltest du zudem drigend aktualisieren: Updateanleitung für phpBB 3.0.x

Re: Sql Fehler: Update nötig? Wie updaten per FTP?

Verfasst: 04.11.2013 13:35
von Shran
Hallo,

vielen DANK !!! Das hat geklappt.

Jetzt konnte ich ausfindig machen, dass mein Forum die Version 3.0.10 hat. Also nicht 2.0 oder so. Wäre es verfehlt an dieser Stelle danach zu fragen, ob ich mein teils eigens erstelltes Design zerschieße, wenn ich ein update installiere?

Wie notwendig sind die updates? Ich habe bei Windows - Updates z.B. schon manchmal gemerkt, dass sie mehr Ärger als Besserung brachten. Ist das bei phpbb auch so?

Re: Sql Fehler: Update nötig? Wie updaten per FTP?

Verfasst: 04.11.2013 14:35
von Crizzo
Nein, die Updates sind wichtig.

Den Style musst du manuell aktualisieren oder eine aktuelle Version vom Style Autor installieren. Sofern du das selbst machen musst, dann hier entlang: https://area51.phpbb.com/code-changes/3.0.10/?styles --> "Ordner: prosilver oder subsilver auswählen (hängt von deinem Style ab) und dann alle Dateien ausführen.
gelb = Code-Stelle ändern
grün = Code ergänzen
rot = löschen

Dabei ist in der Linken Spalte die alte Datei und rechts die neue.


Grüße