BBCodes für JW Player

Fragen zur Bedienung von phpBB 3.0.x, Probleme bei der Benutzung und alle weiteren Fragen inkl. Update auf die neuste phpBB 3.0.14 Version
Forumsregeln
phpBB 3.0 hat das Ende seiner Lebenszeit überschritten
phpBB 3.0 wird nicht mehr aktiv unterstützt. Insbesondere werden - auch bei Sicherheitslücken - keine Patches mehr bereitgestellt. Der Einsatz von phpBB 3.0 erfolgt daher auf eigene Gefahr. Wir empfehlen einen Umstieg auf phpBB 3.1, welches aktiv weiterentwickelt wird und für welches regelmäßig Updates zur Verfügung gestellt werden.
Antworten
Benutzeravatar
bce
Mitglied
Beiträge: 93
Registriert: 06.08.2008 22:26
Kontaktdaten:

BBCodes für JW Player

Beitrag von bce »

hallo.
habe den aktuellen JW Player in mein Forum integriert.
habe nun eingerichtet, dass mittels bbcode videos eingebunden werden können.

der bbcode sieht folgendermaßen aus:

Code: Alles auswählen

[mp4]{INTTEXT},{URL},{NUMBER},{NUMBER2},{NUMBER3}[/mp4]
die dazugehörige html-ersetzung:

Code: Alles auswählen

<div id="myElement">Loading the player...</div>

<script type="text/javascript">
    jwplayer("myElement").setup({
		title: "{INTTEXT}",
        file: "{URL}",
        image: "http://domain/videos/bild.jpg",
        height: {NUMBER3},
		width:{NUMBER2},
		aspectratio: "16:9",
		html5player: "http://www.domain/videos/jwplayer.html5.js"
    });
</script>
der aufruf in einem beitrag sieht so aus
[mp4]Name des Videos....,http://www.domain/videos/video.mp4,1,640,360[/mp4]
diese genannte lösung funktioniert wunderbar!


nun möchte ich, dass das hinterlegte bild ebenso dynamisch mit angegeben werden kann.

hierzu habe ich den bbcode so geändert. {URL2} ist neu hinzugekommen:

Code: Alles auswählen

[mp4]{INTTEXT1},{URL},{URL2},{NUMBER},{NUMBER2},{NUMBER3}[/mp4]
die dazugehörige html-ersetzung:

Code: Alles auswählen

<div id="myElement">Loading the player...</div>

<script type="text/javascript">
    jwplayer("myElement").setup({
		title: "{INTTEXT1}",
        file: "{URL}",
        image: "{URL2}",
        height: {NUMBER3},
		width:{NUMBER2},
		aspectratio: "16:9",
		html5player: "http://www.domain/videos/jwplayer.html5.js"
    });
</script>
der aufruf schaut nun so aus
dieser bbcode samt aufruf funktioniert jedoch überhaupt nicht.

an was kann das liegen?
++ Spendentafel für die Homepage - samt Einbauanleitung und Installdateien ++ BC Erlbach +++ Erlbacher Kirwe +++

Benutzeravatar
Miriam
Mitglied
Beiträge: 12310
Registriert: 13.10.2004 07:18
Wohnort: Ammerland
Kontaktdaten:

Re: BBCodes für JW Player

Beitrag von Miriam »

Was haben Deine Tests mit einer händisch fest eingetragenen URL für das Bild ergeben?
Gruss, Miriam.
Ich schmeiß' alles hin und...
... lasse es liegen

Benutzeravatar
bce
Mitglied
Beiträge: 93
Registriert: 06.08.2008 22:26
Kontaktdaten:

Re: BBCodes für JW Player

Beitrag von bce »

Code: Alles auswählen

image: "http://domain/videos/bild.jpg",
so wurde das Bild angezeigt
++ Spendentafel für die Homepage - samt Einbauanleitung und Installdateien ++ BC Erlbach +++ Erlbacher Kirwe +++

Benutzeravatar
Miriam
Mitglied
Beiträge: 12310
Registriert: 13.10.2004 07:18
Wohnort: Ammerland
Kontaktdaten:

Re: BBCodes für JW Player

Beitrag von Miriam »

Dann kann es doch fast nur noch an Deiner URL2 Variablen liegen.
Gruss, Miriam.
Ich schmeiß' alles hin und...
... lasse es liegen

Benutzeravatar
bce
Mitglied
Beiträge: 93
Registriert: 06.08.2008 22:26
Kontaktdaten:

Re: BBCodes für JW Player

Beitrag von bce »

konnte das problem nun nach langer tüftelei lösen :roll:
kann es mir aber nicht erklären wieso und warum....

folgende lösung funktioniert:

Code: Alles auswählen

[mp4]{INTTEXT},{NUMBER2},{NUMBER3},{URL},{INTTEXT2}[/mp4]

Code: Alles auswählen

<div id="myElement">Loading the player...</div>

<script type="text/javascript">
    jwplayer("myElement").setup({
		title: "{INTTEXT}",
        file: "{URL}",
        image: "http://www.domain/{INTTEXT2}",
        height: {NUMBER3},
		width:{NUMBER2},
		aspectratio: "16:9",
		html5player: "http://www.domain/jwplayer.html5.js"
    });
</script>

jetzt kommt das unerklärliche: wenn ich die parameterreihenfolge ändere funktioniert es nicht mehr!
folgender eintrag funktioniert nicht: (number wurde ans ende gesetzt)

Code: Alles auswählen

[mp4]{INTTEXT},{URL},{INTTEXT2},{NUMBER2},{NUMBER3}[/mp4]

edit:

jetzt wird es noch kurioser:

im beitrag füge ich folgenden tag ein.
[mp4]Weihnachtsfeier 1234567,640,360,http://www.domain/forum.mp4,back13.jpg[/mp4]
dieser funktioniert.


ändere ich nun den dateinamen des bildes in
backwh13.jpg
so funktioniert alles nicht mehr! :o

hexerei?! :roll:
++ Spendentafel für die Homepage - samt Einbauanleitung und Installdateien ++ BC Erlbach +++ Erlbacher Kirwe +++

Antworten

Zurück zu „[3.0.x] Administration, Benutzung und Betrieb“