Fehlermeldung bei Beitrag suche der Mitglieder

Fragen zur Bedienung von phpBB 3.0.x, Probleme bei der Benutzung und alle weiteren Fragen inkl. Update auf die neuste phpBB 3.0.14 Version
Forumsregeln
phpBB 3.0 hat das Ende seiner Lebenszeit überschritten
phpBB 3.0 wird nicht mehr aktiv unterstützt. Insbesondere werden - auch bei Sicherheitslücken - keine Patches mehr bereitgestellt. Der Einsatz von phpBB 3.0 erfolgt daher auf eigene Gefahr. Wir empfehlen einen Umstieg auf phpBB 3.1, welches aktiv weiterentwickelt wird und für welches regelmäßig Updates zur Verfügung gestellt werden.
Benutzeravatar
zx9r-treiber
Mitglied
Beiträge: 1401
Registriert: 05.10.2007 16:26
Wohnort: Moormerland
Kontaktdaten:

Fehlermeldung bei Beitrag suche der Mitglieder

Beitragvon zx9r-treiber » 09.04.2017 21:35

Version 3.0.14
Datenbank = MySQL 5.5.54-0ubuntu0.12.04.1
Server = PHP Version 5.3.29

Seid der Anbieter ein Update ausgeführt hat kommt folgende Fehlermeldung.


Wenn ich über das Profil eines Mitglied nach seinen Beiträgen suche bekomme ich folgende Fehlermeldung =

SQL ERROR [ mysql4 ]

Expression #1 of ORDER BY clause is not in SELECT list, references column 'db68797x1859517.p.post_time' which is not in SELECT list; this is incompatible with DISTINCT [3065]

SQL

SELECT DISTINCT SQL_CALC_FOUND_ROWS p.post_id FROM phpbb_posts p WHERE p.poster_id = 786 AND p.forum_id <> 158 ORDER BY p.post_time DESC

BACKTRACE


FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/db/dbal.php
LINE: 757
CALL: trigger_error()

FILE: [ROOT]/includes/db/mysql.php
LINE: 193
CALL: dbal->sql_error()

FILE: [ROOT]/includes/search/fulltext_native.php
LINE: 1002
CALL: dbal_mysql->sql_query()

FILE: [ROOT]/search.php
LINE: 540
CALL: fulltext_native->author_search()

Ich bin leider nicht so gut das ich das selber hin bekomme. Ich weiß bis jetzt nur das ich etwas umstellen muss. Nur was ?

und NEIN, ich habe mein Forum noch nicht auf Version 3.1.x umgestellt. Das möchte ich auch noch nicht.
Gruß
M&K (Michael & Kathy)
"Unser Problem ist auch nicht die Globale Erwärmung ..... sondern die Globale Verblödung!"

Benutzeravatar
vfrblue
Junior Supporter
Beiträge: 645
Registriert: 22.11.2016 18:46
Wohnort: Niedersachsen-West
Kontaktdaten:

Re: Fehlermeldung bei Beitrag suche der Mitglieder

Beitragvon vfrblue » 09.04.2017 21:52

Vielleicht ist es ein falscher "mysql"-Treiber. Es sollte der "mysqli"-Treiger geladen werden.
Schau mal in der "config.php" deines Boards und überprüfe die Einträge:

Code: Alles auswählen

<?php
// phpBB 3.1.x auto-generated configuration file
// Do not change anything in this file!
$dbms = 'phpbb\\db\\driver\\mysqli';
.....
Gruß Hermann

Forum VFR-OC
User: phpbbtest PW: vfroc

Benutzeravatar
zx9r-treiber
Mitglied
Beiträge: 1401
Registriert: 05.10.2007 16:26
Wohnort: Moormerland
Kontaktdaten:

Re: Fehlermeldung bei Beitrag suche der Mitglieder

Beitragvon zx9r-treiber » 09.04.2017 21:59

Ich benutze noch Version 3.0.14 !

und nicht 3.1.10 oder höher ....
Gruß
M&K (Michael & Kathy)
"Unser Problem ist auch nicht die Globale Erwärmung ..... sondern die Globale Verblödung!"

Benutzeravatar
vfrblue
Junior Supporter
Beiträge: 645
Registriert: 22.11.2016 18:46
Wohnort: Niedersachsen-West
Kontaktdaten:

Re: Fehlermeldung bei Beitrag suche der Mitglieder

Beitragvon vfrblue » 09.04.2017 22:03

zx9r-treiber hat geschrieben:Ich benutze noch Version 3.0.14 !

und nicht 3.1.10 oder höher ....

Aber du benutzt MySQL 5.5.54. Die Versionsangabe in meinem Beispiel ist von meiner lokalen 3.2er Installation.
Gruß Hermann

Forum VFR-OC
User: phpbbtest PW: vfroc

Benutzeravatar
zx9r-treiber
Mitglied
Beiträge: 1401
Registriert: 05.10.2007 16:26
Wohnort: Moormerland
Kontaktdaten:

Re: Fehlermeldung bei Beitrag suche der Mitglieder

Beitragvon zx9r-treiber » 09.04.2017 22:30

Meine Config =

Code: Alles auswählen

// phpBB 3.0.x auto-generated configuration file
// Do not change anything in this file!
$dbms = 'mysql';
$dbhost = 'mysql.webhosting18.1blu.de';
$dbport = '';
$dbname = 'db68797x1859517';
$dbuser = xxxxxx
$dbpasswd = xxxxxx

$table_prefix = 'phpbb_';
$acm_type = 'file';
$load_extensions = '';

@define('PHPBB_INSTALLED', true);
@define('DEBUG', true);
// @define('DEBUG_EXTRA', true);
?>


und die lief seid jahren so.
Kann es sein das es daran liegt das der Anbieter neue PHP Versionen aufgespielt hat?
Es ist jetzt eine 5.3.29 per Adminbereich gemeldet ..... ich könnte höher oder tiefer gehen per "php.conf" ... also auf die 5.2 oder die 5.6 oder noch höher. (für das 3.10.x muß ich eh später höher schalten.)
Gruß
M&K (Michael & Kathy)
"Unser Problem ist auch nicht die Globale Erwärmung ..... sondern die Globale Verblödung!"

Benutzeravatar
vfrblue
Junior Supporter
Beiträge: 645
Registriert: 22.11.2016 18:46
Wohnort: Niedersachsen-West
Kontaktdaten:

Re: Fehlermeldung bei Beitrag suche der Mitglieder

Beitragvon vfrblue » 09.04.2017 22:40

Code: Alles auswählen

$dbms = 'mysql';

ändern in

Code: Alles auswählen

$dbms = 'mysqli';
Gruß Hermann

Forum VFR-OC
User: phpbbtest PW: vfroc

Benutzeravatar
zx9r-treiber
Mitglied
Beiträge: 1401
Registriert: 05.10.2007 16:26
Wohnort: Moormerland
Kontaktdaten:

Re: Fehlermeldung bei Beitrag suche der Mitglieder

Beitragvon zx9r-treiber » 09.04.2017 23:09

nun läuft absolut nix mehr ..... habe die Änderung wieder zurück genommen aber es läuft auch dann nix mehr ....
Gruß
M&K (Michael & Kathy)
"Unser Problem ist auch nicht die Globale Erwärmung ..... sondern die Globale Verblödung!"

Benutzeravatar
Mahony
Ehemaliger
Beiträge: 10878
Registriert: 17.11.2005 22:33
Wohnort: Esslingen (Neckar)
Kontaktdaten:

Re: Fehlermeldung bei Beitrag suche der Mitglieder

Beitragvon Mahony » 09.04.2017 23:29

Hallo
Leere mal den cache (per FTP-Programm ALLES außer der .htaccess und der index.htm löschen).

Grüße: Mahony
Taekwondo in Berlin
Wer fragt, ist ein Narr für fünf Minuten, wer nicht fragt, ist ein Narr für immer.

Benutzeravatar
zx9r-treiber
Mitglied
Beiträge: 1401
Registriert: 05.10.2007 16:26
Wohnort: Moormerland
Kontaktdaten:

Re: Fehlermeldung bei Beitrag suche der Mitglieder

Beitragvon zx9r-treiber » 10.04.2017 00:20

Danke, das hat geklappt .... zu mindestens ist das Forum wieder da.

Nur der erste Fehler mit die Beitragssuche der Mitglieder gibt noch die Fehlermeldung raus.
Gruß
M&K (Michael & Kathy)
"Unser Problem ist auch nicht die Globale Erwärmung ..... sondern die Globale Verblödung!"

Benutzeravatar
Mahony
Ehemaliger
Beiträge: 10878
Registriert: 17.11.2005 22:33
Wohnort: Esslingen (Neckar)
Kontaktdaten:

Re: Fehlermeldung bei Beitrag suche der Mitglieder

Beitragvon Mahony » 10.04.2017 00:40

Hallo
Kann es sein, dass du MySQL 5.7 im Einsatz hast?
Falls Ja, dann schau mal hier -->> https://www.phpbb.com/community/viewtop ... &t=2372006


Grüße: Mahony
Taekwondo in Berlin
Wer fragt, ist ein Narr für fünf Minuten, wer nicht fragt, ist ein Narr für immer.


Zurück zu „[3.0.x] Administration, Benutzung und Betrieb“