Umstellung 3.0.12 und höher auf php7

Fragen zur Bedienung von phpBB 3.0.x, Probleme bei der Benutzung und alle weiteren Fragen inkl. Update auf die neuste phpBB 3.0.14 Version
Forumsregeln
phpBB 3.0 hat das Ende seiner Lebenszeit überschritten
phpBB 3.0 wird nicht mehr aktiv unterstützt. Insbesondere werden - auch bei Sicherheitslücken - keine Patches mehr bereitgestellt. Der Einsatz von phpBB 3.0 erfolgt daher auf eigene Gefahr. Wir empfehlen einen Umstieg auf die neuste phpBB-Version, welches aktiv weiterentwickelt wird und für welches regelmäßig Updates zur Verfügung gestellt werden.
Antworten
4adapro
Mitglied
Beiträge: 1
Registriert: 25.10.2018 09:42

Umstellung 3.0.12 und höher auf php7

Beitrag von 4adapro »

Falls jemand aktuelle eine Lösung sucht um sein älteres phpBB 3.0.12 oder höher auf PHP 7 umzustellen:

https://forum.dion-designs.com/viewtopi ... 90f861b335

Da gibt es ein Patchscript dass die nötigen Änderungen vornimmt. Ging bei mir mit 3.0.14 problemlos in 2 Sekunden.

Man muss auch vorher in der Datei config.php im Hauptordner von PHPBB noch
$dbms = 'mysql';
auf
$dbms = 'mysqli';
ändern.

Dann läufts wieder fehlerfrei mit PHP7.x
Benutzeravatar
Dr.Death
Moderator
Moderator
Beiträge: 16447
Registriert: 23.04.2003 08:22
Wohnort: Xanten
Kontaktdaten:

Re: Umstellung 3.0.12 und höher auf php7

Beitrag von Dr.Death »

Na denn, viel Spass beim Supporten mit diesen gepachteten Boards.....
Benutzeravatar
Melmac
Ehemaliges Teammitglied
Beiträge: 3623
Registriert: 15.10.2012 03:27

Re: Umstellung 3.0.12 und höher auf php7

Beitrag von Melmac »

Man sollte sich dann aber auch der Konsequenzen bewusst sein, die dies mit sich bringt: Support gibts dann auch nur noch bei Dion und für die Behebung eventueller Sicherheitslücken etc. darf man selbst sorgen.

phpBB 3.0 ist längst End of Life und wird schon lange nicht mehr mit Bugfixes oder Securityupdates versorgt.

Wer also weiß, was er macht und wie er sich im Fall des Falles selbst behelfen kann, für den ist das okay. Wer nicht, der sollte sich gut überlegen, ob es wirklich zwingende Gründe gibt, bei dieser veralteten Linie bleiben zu müssen.
Handle nur nach derjenigen Maxime, durch die du zugleich wollen kannst, dass sie ein allgemeines Gesetz werde.
(Immanuel Kant)
Antworten

Zurück zu „[3.0.x] Administration, Benutzung und Betrieb“