Update 3.0.14 auf 3.2.5

Fragen zur Bedienung von phpBB 3.0.x, Probleme bei der Benutzung und alle weiteren Fragen inkl. Update auf die neuste phpBB 3.0.14 Version
Forumsregeln
phpBB 3.0 hat das Ende seiner Lebenszeit überschritten
phpBB 3.0 wird nicht mehr aktiv unterstützt. Insbesondere werden - auch bei Sicherheitslücken - keine Patches mehr bereitgestellt. Der Einsatz von phpBB 3.0 erfolgt daher auf eigene Gefahr. Wir empfehlen einen Umstieg auf phpBB 3.1, welches aktiv weiterentwickelt wird und für welches regelmäßig Updates zur Verfügung gestellt werden.
Benutzeravatar
kblaubaer
Mitglied
Beiträge: 32
Registriert: 15.07.2011 09:29

Re: Update 3.0.14 auf 3.2.5

Beitragvon kblaubaer » 15.03.2019 17:38

Hallo,
Mylady hat geschrieben:Meines Wissens kann 3.0.x nicht mit PHP 7.2 umgehen - eben weil da viele Befehlssätze verändert wurden. Wie Mahoney schon sagt: updaten. Umstellen vielleicht erst danach, wenn möglich - das Update unter 5.6 machen.

leider nicht mehr möglich, ich bin mit 3.0.14 schon auf PHP7.2! Dann muss ich wohl am Wochenende....
Grüße, Michael

Edit: Das Backup der MySQL-Datenbank, ist das eine Vorsichtsmaßnahme? Welche Backupmöglichkeit (der vielen) soll ich nehmen, die Datenbank ist 178 MB groß? Mein Provider bietet PHPMyAdmin an, aber in der Backup-Übersicht steht, dass PHPMyAdmin nur für Backups <2MB zu verwenden ist??

Benutzeravatar
chris1278
Mitglied
Beiträge: 1390
Registriert: 12.11.2007 06:20
Wohnort: Euskirchen
Kontaktdaten:

Re: Update 3.0.14 auf 3.2.5

Beitragvon chris1278 » 15.03.2019 19:21

Such hier mal nach mysqldumper der is dafür besser geeignet.

Benutzeravatar
kblaubaer
Mitglied
Beiträge: 32
Registriert: 15.07.2011 09:29

Re: Update 3.0.14 auf 3.2.5

Beitragvon kblaubaer » 16.03.2019 11:30

Hallo,
das Update auf Version 3.2.5 ist erfolgt und es scheint alles wieder zu funktionieren - puh - bin ich froh! :grin:

Danke für eure Hilfe soweit!

Nun muss ich mich mit der neuen Board-Funktionalität vertraut machen... :P . Gleich die erste Frage dazu: Seit dem Update ist mein Board-Logo oben links futsch; da hat sich wieder das PHPBB-Logo eingeschlichen. Wo kann ich das im ACP ändern?

Ein zufriedener blaubaer

Edit: Unter dem Reiter Erweiterungen im ACP bekomme ich eine Fehlermeldung "Kann Modul acp_mobiquo.php nicht finden....." - das hängt wahrscheinlich damit zusammen, dass ich noch keinen Lauf mit dem stk gemacht habe und dass das die Reste vom Tapatalk-Mod sind, die die 3.2.5-Version nicht mehr behandeln kann?

Benutzeravatar
schnagga
Mitglied
Beiträge: 782
Registriert: 10.03.2006 18:26
Wohnort: Verden
Kontaktdaten:

Re: Update 3.0.14 auf 3.2.5

Beitragvon schnagga » 16.03.2019 12:04

Teste mal das: https://www.phpbb.com/community/viewtopic.php?t=2400186

Edit:
Hab dein Edit übersehen.
Ja, schiebe erst mal das STK drüber.
Zuletzt geändert von schnagga am 16.03.2019 12:13, insgesamt 2-mal geändert.
Ein Tischtennis-Forum aus Verden

Benutzeravatar
Dr.Death
Moderator
Moderator
Beiträge: 15617
Registriert: 23.04.2003 08:22
Wohnort: Xanten
Kontaktdaten:

Re: Update 3.0.14 auf 3.2.5

Beitragvon Dr.Death » 16.03.2019 12:06

Für Fragen, die jetzt nichts mehr mit dem eigentlichen Thema "Update 3.0.14 auf 3.2.5" zu tun haben, bitte ein eigenes Thema im passenden Forum erstellen.
Vielen Dank.

Benutzeravatar
kblaubaer
Mitglied
Beiträge: 32
Registriert: 15.07.2011 09:29

Re: Update 3.0.14 auf 3.2.5

Beitragvon kblaubaer » 16.03.2019 12:25

Hallo Dottore,
Dr.Death hat geschrieben:Für Fragen, die jetzt nichts mehr mit dem eigentlichen Thema "Update 3.0.14 auf 3.2.5" zu tun haben, bitte ein eigenes Thema im passenden Forum erstellen.
Vielen Dank.

stimmt, hatte ich im Überschwang meiner Gefühle glatt vergessen....
Bevor mich der Tod ereilt, mache ich das natürlich gerne... :P
Grüße, Michael

Benutzeravatar
kblaubaer
Mitglied
Beiträge: 32
Registriert: 15.07.2011 09:29

Re: Update 3.0.14 auf 3.2.5

Beitragvon kblaubaer » 17.03.2019 09:43

Hallo,

jetzt habe ich wohl die Datenbankreinigung mit dem STK etwas übertrieben. Ich habe sämtliche Optionen durchlaufen lassen - auf jeden Fall konnte ich das Forum danach nicht mehr starten; es kamen jede Menge Fehlermeldungen. Habe erstmal wieder die Datenbanksicherung zurückgespielt - jetzt läuft das Forum wieder.

Wie gehe ich weiter vor, welche Datenbankreinigungs-Optionen soll ich mindestens wählen? Ich möchte in jedem Fall diese Fehlermeldung

Code: Alles auswählen

Allgemeiner Fehler
Kann Modul ./../includes/acp/acp_mobiquo.php nicht finden

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/functions_module.php
LINE: 573
CALL: trigger_error()

FILE: [ROOT]/adm/index.php
LINE: 82
CALL: p_master->load_active()


wegbekommen und die Tapatalk-Mod-Reste. Diese Fehlermeldung taucht auf, wenn ich im ACP den Reiter Erweiterungen aufrufe.

Leider funktionieren die PGN4Web-BBCodes nicht mehr - hat jemand Erfahrung mit PGN4WEB unter V3.2.5 - muss ich die BBCodes neu installieren?

Grüße, Michael
Forum

PS: Das Site-Logo ist wieder drinnen. :grin:

Benutzeravatar
Mahony
Ehemaliger
Beiträge: 11764
Registriert: 17.11.2005 22:33
Wohnort: Esslingen (Neckar)
Kontaktdaten:

Re: Update 3.0.14 auf 3.2.5

Beitragvon Mahony » 17.03.2019 19:31

Hallo
kblaubaer hat geschrieben:Ich habe sämtliche Optionen durchlaufen lassen - auf jeden Fall konnte ich das Forum danach nicht mehr starten

Alle Optionen durchlaufen zu lassen, war schon korrekt. Hast du anschließend auch das cache-Verzeichnis geleert (per FTP-Programm ALLES außer der .htaccess und der index.htm aus dem cache-Verzeichnis löschen) ?

Grüße: Mahony
Taekwondo in Berlin
Wer fragt, ist ein Narr für fünf Minuten, wer nicht fragt, ist ein Narr für immer.

Benutzeravatar
kblaubaer
Mitglied
Beiträge: 32
Registriert: 15.07.2011 09:29

Re: Update 3.0.14 auf 3.2.5

Beitragvon kblaubaer » 17.03.2019 19:50

Hallo Mahony,
Mahony hat geschrieben:Hast du anschließend auch das cache-Verzeichnis geleert (per FTP-Programm ALLES außer der .htaccess und der index.htm aus dem cache-Verzeichnis löschen) ?

das habe ich nicht gemacht - bei dem Satz "Sicherheitshalber Board- und Browsercache leeren" konnte ich mit Boardcache nichts anfangen, nun ist es klar - ich versuch's nochmal mit Boardcache leeren im FTP-Verzeichnis /cache/.. :P
Danke, Michael

Benutzeravatar
kblaubaer
Mitglied
Beiträge: 32
Registriert: 15.07.2011 09:29

Re: Update 3.0.14 auf 3.2.5

Beitragvon kblaubaer » 18.03.2019 10:56

Hallo,

auch das Leeren des Cache-Verzeichnisses hat nichts genützt.

Folgende Fehlermeldung kam am Ende der Datenbankbereinigung beim letzten Schritt:

Code: Alles auswählen

Fatal error: SQL ERROR [ mysqli ]

Table 'DB707634.phpbb_pages' doesn't exist [1146]

SQL

SELECT page_id, page_route FROM phpbb_pages in /mnt/web411/a0/64/52331664/htdocs/miclangschach.de/forum/phpbb/db/driver/driver.php on line 997 Error 256: SQL ERROR [ mysqli ]

Table 'DB707634.phpbb_pages' doesn't exist [1146]

SQL

SELECT page_id, page_route FROM phpbb_pages at file /mnt/web411/a0/64/52331664/htdocs/miclangschach.de/forum/phpbb/db/driver/driver.php line 997


Liegt vielleicht daran, dass ich die Erweiterung "Pages" vor der Datenbankbereinigung installiert hatte?

Bei Aufruf des Forums kam dann diese Fehlermeldung:

Code: Alles auswählen

Allgemeiner Fehler
SQL ERROR [ mysqli ]

Table 'DB707634.phpbb_pages_pages_links' doesn't exist [1146]

SQL

SELECT ppl.*, pl.page_link_location, pl.page_link_event_name, p.page_route, p.page_title, p.page_icon_font, p.page_display, p.page_display_to_guests FROM (phpbb_pages_pages_links ppl) LEFT JOIN phpbb_pages_links pl ON (pl.page_link_id = ppl.page_link_id) LEFT JOIN phpbb_pages p ON (p.page_id = ppl.page_id) ORDER BY p.page_order ASC, ppl.page_link_id ASC

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 997
CALL: trigger_error()

FILE: [ROOT]/phpbb/db/driver/mysqli.php
LINE: 193
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/phpbb/db/driver/factory.php
LINE: 329
CALL: phpbb\db\driver\mysqli->sql_query()

FILE: [ROOT]/ext/phpbb/pages/operators/page.php
LINE: 283
CALL: phpbb\db\driver\factory->sql_query()

FILE: [ROOT]/ext/phpbb/pages/event/listener.php
LINE: 103
CALL: phpbb\pages\operators\page->get_page_links()

FILE: [ROOT]/vendor/symfony/event-dispatcher/EventDispatcher.php
LINE: 184
CALL: phpbb\pages\event\listener->show_page_links()

FILE: [ROOT]/vendor/symfony/event-dispatcher/EventDispatcher.php
LINE: 46
CALL: Symfony\Component\EventDispatcher\EventDispatcher->doDispatch()

FILE: [ROOT]/phpbb/event/dispatcher.php
LINE: 62
CALL: Symfony\Component\EventDispatcher\EventDispatcher->dispatch()

FILE: [ROOT]/phpbb/event/dispatcher.php
LINE: 46
CALL: phpbb\event\dispatcher->dispatch()

FILE: [ROOT]/includes/functions.php
LINE: 4210
CALL: phpbb\event\dispatcher->trigger_event()

FILE: [ROOT]/index.php
LINE: 240
CALL: page_header()


Nach Restore der Datenbank konnte ich das Forum wieder starten! Dann hat aber der ACP nicht mehr funktioniert (Die Fehlermeldung hatte ich nicht gespeichert, war aber etwas im Zusammenhang mit der Erweiterung VigLink). Darauf hin habe ich über das STK beide Erweiterungen, VigLink und Pages, deaktiviert, und ich konnte das ACP wieder aufrufen.

Soweit der Stand der Dinge.

Ich habe immer noch diese Fehlermeldung bei Aufruf des Reiters Erweiterungen im ACP:

Code: Alles auswählen

Allgemeiner Fehler
Kann Modul ./../includes/acp/acp_mobiquo.php nicht finden

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/functions_module.php
LINE: 573
CALL: trigger_error()

FILE: [ROOT]/adm/index.php
LINE: 82
CALL: p_master->load_active()


Weitere Vorgehensweise:
Ich werde mal über das ACP die beiden Erweiterungen VigLink und Pages aus dem Forum löschen und in der STK-Datenbankbereinigung nur den Abschnitt "nach weiteren Modulen suchen" und "Module zurücksetzen" laufen lassen, da hier Folgendes kommt:

Code: Alles auswählen

Nach weiteren Modulen suchen
EINTRÄGE   TYP   VORGANG   
ACP_MOBIQUO (199) --» gehe zum Administrationsbereich undefiniert [ACP_CAT_DOT_MODS (31)]   Zusätzlich   Löschen   
ACP_MOBIQUO_SETTINGS (202) --» gehe zum Administrationsbereich undefiniert [ACP_MOBIQUO (199)]   Zusätzlich   Löschen   
ACP_TAPATALK_REBRANDING (203) --» gehe zum Administrationsbereich undefiniert [ACP_MOBIQUO (199)]   Zusätzlich   Löschen   
ACP_VIGLINK_SETTINGS (219) --» gehe zum Administrationsbereich undefiniert [ACP_BOARD_CONFIGURATION (3)]   Zusätzlich   Löschen   
ACP_PAGES (220) --» gehe zum Administrationsbereich undefiniert [ACP_CAT_DOT_MODS (31)]   Zusätzlich   Löschen   
ACP_PAGES_MANAGE (221) --» gehe zum Administrationsbereich undefiniert [ACP_PAGES (220)]   Zusätzlich   Löschen   


Diese Meldung zeigt mir, dass es Probleme mit dem alten Mod "Tapatalk" und den Erweiterungen VigLink und Pages gibt. Mal sehen, was da jetzt kommt...

Was meint ihr zur weiteren Vorgehensweise?

Grüße, Michael


Zurück zu „[3.0.x] Administration, Benutzung und Betrieb“