eMosbat TinyMCE Integration (Probleme)

Du hast Probleme beim Einbau oder bei der Benutzung eines Mods? In diesem Forum bist du richtig.
Forumsregeln
phpBB 3.0 hat das Ende seiner Lebenszeit überschritten
phpBB 3.0 wird nicht mehr aktiv unterstützt. Insbesondere werden - auch bei Sicherheitslücken - keine Patches mehr bereitgestellt. Der Einsatz von phpBB 3.0 erfolgt daher auf eigene Gefahr. Wir empfehlen einen Umstieg auf phpBB 3.1, welches aktiv weiterentwickelt wird und für welches regelmäßig Updates zur Verfügung gestellt werden.
---
Bei Fragen zu einem bestimmten Mod sind Mod-Name und die Downloadquelle des Mods erforderlich. Letztere in Form der URL zum Download. Hiervon kann lediglich bei sehr bekannten und verbreiteten Mods abgesehen werden, soweit eindeutig ist, um welchen Mod es sich handelt. Es liegt allerdings im Ermessen der Moderatoren, das Thema ggf. zu schließen, daher sollte im Zweifel der Link angegeben werden.
Antworten
chris90
Mitglied
Beiträge: 37
Registriert: 06.11.2014 10:54

eMosbat TinyMCE Integration (Probleme)

Beitrag von chris90 » 06.11.2014 12:31

Hallo,

kleines oder größeres Problem mit eMosbat TinyMCE Integration.

1. Problem mit dem Optionen Einstellungen, wenn ich die Optionen sehen möchte im ACP:
[phpBB Debug] PHP Warning: in file [ROOT]/includes/acp/acp_emotinymce.php on line 184: Invalid argument supplied for foreach()

2. Problem, der Editor wird falsch dargestellt siehe Bild:
[ externes Bild ]

Ich verwende als Style Oxygen und habe alle Dateien vom Style Ordner "Prosilver" aus eMosbat TinyMCE in den Oxygen Style Ordner kopiert.

Und der Rest ist natürlich auch Installiert.

Vielen Dank für hilfe.

Benutzeravatar
Elsensee
Ehemaliges Teammitglied
Beiträge: 832
Registriert: 19.05.2010 15:14
Wohnort: Hamburg
Kontaktdaten:

Re: eMosbat TinyMCE Integration (Probleme)

Beitrag von Elsensee » 06.11.2014 18:38

Ich schätze, das zweite Problem resultiert aus dem ersten. Also erstmal das erste lösen. :D

Kannst du mal nur Zeile 184 aus der includes/acp/acp_emotinymce.php hier in einem Codeblock posten oder auch wahlweise die ganze Datei im Pastebin und dann hier verlinken?
Posts mostly powered by GitHub and phpBB.de Cross-Reference

2015-03-20 - Never forget 8)

chris90
Mitglied
Beiträge: 37
Registriert: 06.11.2014 10:54

Re: eMosbat TinyMCE Integration (Probleme)

Beitrag von chris90 » 06.11.2014 19:22

Danke für deine Antwort.

Also das ist der Quellcode gibts da überhaupt 184 Zeilen :D

edit: code im pastebin => https://www.phpbb.de/support/pastebin.p ... iew&s=1469
Zuletzt geändert von Elsensee am 06.11.2014 20:54, insgesamt 1-mal geändert.
Grund: Code ins Pastebin gepackt

Benutzeravatar
Elsensee
Ehemaliges Teammitglied
Beiträge: 832
Registriert: 19.05.2010 15:14
Wohnort: Hamburg
Kontaktdaten:

Re: eMosbat TinyMCE Integration (Probleme)

Beitrag von Elsensee » 06.11.2014 21:02

Elsensee hat geschrieben:Kannst du mal nur Zeile 184 aus der includes/acp/acp_emotinymce.php hier in einem Codeblock posten oder auch wahlweise die ganze Datei im Pastebin und dann hier verlinken?
Sorry, falls ich mich hier unklar ausgedrückt habe. Ich meinte entweder diese eine Zeile hier ODER die ganze Datei im Pastebin. :)
Das habe ich nun mal für dich übernommen, aber ich weise hiermit mal auf den KB:knigge hin. :wink:


Nach etwas Recherche habe ich.. keine Ahnung. :D
Dieser Fehler tritt normalerweise auf, wenn man *kein* Array an ein foreach-Konstrukt übergibt, aber da hier alles mod-spezifisch ist, muss das wohl an der Modifikation selbst liegen. Ich würde hierfür mal den MOD-Autor anschwärzen. :P Falls du ihm das mitteilen möchtest, sage ihm, dass du die deutsche Übersetzung benutzt (wovon ich jetzt einfach mal ausgehe). :wink:

Dein zweites Problem hatte ich erst nicht beachtet, weil ich ja dachte, es ginge von dem ersten aus, is' aber völliger Blödsinn. :lol:
Ich tippe darauf, dass du entweder deinen Board-/Template-/Browser-Cache nicht gelöscht hast oder etwas beim Einbau falsch gemacht hast. :wink:
Posts mostly powered by GitHub and phpBB.de Cross-Reference

2015-03-20 - Never forget 8)

chris90
Mitglied
Beiträge: 37
Registriert: 06.11.2014 10:54

Re: eMosbat TinyMCE Integration (Probleme)

Beitrag von chris90 » 13.03.2015 19:38

Hallo,

auch diesen Thread möchte ich kurz mal wiederbeleben, ich habe das Mod in meinen phpbb neuinstalliert, mein Forum ist in einem Wordpress Blog eingebunden mit dem Plugin https://wordpress.org/plugins/wp-united/

Das Plugin funktioniert auch sehr gut, jedoch gibts bei machen Sachen aufgrund der css Verarbeitung Probleme.

Wenn ich das Mod "eMosbat TinyMCE" aktiviere, wird es sehr fehlerhaft angezeigt. Um genau zu sein nur 2 Buttons die keine Funktion haben im Editor.

Kennt wer eine gute Lösung oder möchte sich ein paar Euro dazu verdienen um das Problem anzugehen.

Nur mit Treffen.


MfG

regazer
Mitglied
Beiträge: 278
Registriert: 04.01.2014 16:08

Re: eMosbat TinyMCE Integration (Probleme)

Beitrag von regazer » 14.03.2015 02:36

Hast Du schon unter https://www.phpbb.com/community/viewtop ... &t=2160273 alles durchgelesen ?
Never run a touching system. Automatic updates can be dangerous. :o
To steal ideas from one person is plagiarism. To steal from many is research. :lol:

chris90
Mitglied
Beiträge: 37
Registriert: 06.11.2014 10:54

Re: eMosbat TinyMCE Integration (Probleme)

Beitrag von chris90 » 14.03.2015 09:57

Danke, Ja habe ich, das Problem besteht nur solange es im Blog eingebunden ist.

Also: Phpbb in Wordpress einblenden.

Wenn ich umstelle auf Wordpress in Phpbb einblenden, oder Phpbb vollkommen alleine laufen lasse funktioniert "eMosbat TinyMCE" hervorragend.

regazer
Mitglied
Beiträge: 278
Registriert: 04.01.2014 16:08

Re: eMosbat TinyMCE Integration (Probleme)

Beitrag von regazer » 15.03.2015 21:42

Leider habe ich momentan keine Möglichkeit, das weiter zu prüfen.

So wie Du es schilderst, hat es den Anschein, daß in Wordpress einige zusätzliche Deklarationen nötig sind. :roll:
Never run a touching system. Automatic updates can be dangerous. :o
To steal ideas from one person is plagiarism. To steal from many is research. :lol:

Antworten

Zurück zu „[3.0.x] Mod Support“