Fehler beim Upgrade von 3.0.12 auf 3.0.13PL1 mit Sprachdatei

Du hast Probleme beim Einbau oder bei der Benutzung eines Mods? In diesem Forum bist du richtig.
Forumsregeln
phpBB 3.0 hat das Ende seiner Lebenszeit überschritten
phpBB 3.0 wird nicht mehr aktiv unterstützt. Insbesondere werden - auch bei Sicherheitslücken - keine Patches mehr bereitgestellt. Der Einsatz von phpBB 3.0 erfolgt daher auf eigene Gefahr. Wir empfehlen einen Umstieg auf phpBB 3.1, welches aktiv weiterentwickelt wird und für welches regelmäßig Updates zur Verfügung gestellt werden.
---
Bei Fragen zu einem bestimmten Mod sind Mod-Name und die Downloadquelle des Mods erforderlich. Letztere in Form der URL zum Download. Hiervon kann lediglich bei sehr bekannten und verbreiteten Mods abgesehen werden, soweit eindeutig ist, um welchen Mod es sich handelt. Es liegt allerdings im Ermessen der Moderatoren, das Thema ggf. zu schließen, daher sollte im Zweifel der Link angegeben werden.
chris_54
Mitglied
Beiträge: 23
Registriert: 16.04.2015 22:20

Fehler beim Upgrade von 3.0.12 auf 3.0.13PL1 mit Sprachdatei

Beitragvon chris_54 » 17.05.2015 11:21

Hallo zusammen,

ich wollte nun von 3.0.12 auf 3.0.13 PL1 automatisch upgraden.
Dabei kam es zu folgender Fehlermeldung:

Warning: include(./../language/de/mods/acp_phpbb_seo.php): failed to open stream: No such file or directory in /WWWROOT/11111/htdocs/forum/install/index.php on line 151 Warning: include(): Failed opening './../language/de/mods/acp_phpbb_seo.php' for inclusion (include_path='.:/etc/php:/usr/local/share/php5.0:/usr/local/share/php5:/usr/local/share/php:/usr/share/php5.0:/usr/share/php5:/usr/share/php:.:/php/includes:/etc/php') in /WWWROOT/11111/htdocs/forum/install/index.php on line 151 [phpBB Debug] PHP Warning: in file [ROOT]/install/index.php on line 362: Cannot modify header information - headers already sent by (output started at [ROOT]/install/index.php:151)
[phpBB Debug] PHP Warning: in file [ROOT]/install/index.php on line 363: Cannot modify header information - headers already sent by (output started at [ROOT]/install/index.php:151)
[phpBB Debug] PHP Warning: in file [ROOT]/install/index.php on line 364: Cannot modify header information - headers already sent by (output started at [ROOT]/install/index.php:151)
[phpBB Debug] PHP Warning: in file [ROOT]/install/index.php on line 365: Cannot modify header information - headers already sent by (output started at [ROOT]/install/index.php:151)


Ich denke es liegt daran, dass das Upgrade Paket keine de-Sprachdateien enthält (sondern nur en und fr). Was muss ich machen um das Upgrade trotzdem erfolgreich durchführen zu können?

Schon vorab vielen Dank.

Gruß

Chris

Lehrling
Supporter
Supporter
Beiträge: 3318
Registriert: 15.01.2012 20:00
Kontaktdaten:

Re: Fehler beim Upgrade von 3.0.12 auf 3.0.13PL1 mit Sprachd

Beitragvon Lehrling » 17.05.2015 11:36

Welches Upatepaket hast du denn verwendet? Wenn du das Updatepaket von hier heruntergeladen hast, sind die deutschen Sprachdateien enthalten. Ansonsten kannst du mal hier nachschauen: http://downloads.phpbb.de/pakete/deutsc ... .0.13-PL1/
Mir scheint aber, dass eine andere Datei fehlt und zwar diese hier: acp_phpbb_seo.php
Die gehört zu einer Mod. Hast du da Dateien gelöscht?

chris_54
Mitglied
Beiträge: 23
Registriert: 16.04.2015 22:20

Re: Fehler beim Upgrade von 3.0.12 auf 3.0.13PL1 mit Sprachd

Beitragvon chris_54 » 17.05.2015 12:14

Ich habe die Datei unter: http://www.phpbb-seo.com/en/site-announcements/premod-3-0-13-pl1-released-t36221.html heruntergeladen.

Viele Grüße

Chris

Benutzeravatar
Crizzo
Administrator
Administrator
Beiträge: 10256
Registriert: 19.05.2005 21:45
Kontaktdaten:

Re: Fehler beim Upgrade von 3.0.12 auf 3.0.13PL1 mit Sprachd

Beitragvon Crizzo » 17.05.2015 12:17

Ist das Absicht, dass du die SEO premodded nimmst? Oder hast du den SEOMod gar nicht?

chris_54
Mitglied
Beiträge: 23
Registriert: 16.04.2015 22:20

Re: Fehler beim Upgrade von 3.0.12 auf 3.0.13PL1 mit Sprachd

Beitragvon chris_54 » 17.05.2015 12:49

...ja ist Absicht.
Ich habe derzeit die 3.0.12 SEO premod installiert.

Viele Grüße

Chris

Lehrling
Supporter
Supporter
Beiträge: 3318
Registriert: 15.01.2012 20:00
Kontaktdaten:

Re: Fehler beim Upgrade von 3.0.12 auf 3.0.13PL1 mit Sprachd

Beitragvon Lehrling » 17.05.2015 12:53

dann schau doch jetzt einfach mal in den Ordner language/de/mods/ rein und überprüfe, ob diese Datei acp_phpbb_seo.php da drin liegt.
Wenn nicht, dann kopier sie, bzw. alle Dateien, die für diese Mod sind, aus dem englischen Ordner language/en/mods/ und füge sie in den deutschen Ordner ein. Dann läuft die Mod bei dir halt auf Englisch, aber ich habe auf die Schnelle jetzt auch kein deutsches Sprachpaket für diese Mod finden können.

chris_54
Mitglied
Beiträge: 23
Registriert: 16.04.2015 22:20

Re: Fehler beim Upgrade von 3.0.12 auf 3.0.13PL1 mit Sprachd

Beitragvon chris_54 » 17.05.2015 13:17

...d.h. ich kopiere aus dem jetzigen en-Ordner (da sich ja in der 3.0.13PL upgrade Datei im language Folder keine mods Dateien befinden) die Dateien:
acp_phpbb_seo.php
info_acp_gym_sitemaps.php
info_acp_phpbb_seo.php
php_seo_related_install

in den de-Ordner, richtig?

Was mache ich aber mit der index.htm? Belasse ich die index.htm aus dem de-Ordner oder überschreibe ich diese auch mit der index.htm aus dem en-Ordner?

Viele Grüße

Chris

Lehrling
Supporter
Supporter
Beiträge: 3318
Registriert: 15.01.2012 20:00
Kontaktdaten:

Re: Fehler beim Upgrade von 3.0.12 auf 3.0.13PL1 mit Sprachd

Beitragvon Lehrling » 17.05.2015 13:27

Die index.htm kannst du mit übertragen. Es gibt da aber noch im Ordner language/en einen Unterordner für diese Mod namens gym_sitemaps. Den solltest du auch in den deutschen Ordner übertragen, allerdings eine Ebene davor. Der muss im Ordner de liegen. Du kannst dir ja einfach mal die Verzeichnisstruktur im Ordner language/en anschauen und das einfach 1:1 in den Ordner de übertragen (also nur das, was mit der SEO-Mod zusammenhängt natürlich).

chris_54
Mitglied
Beiträge: 23
Registriert: 16.04.2015 22:20

Re: Fehler beim Upgrade von 3.0.12 auf 3.0.13PL1 mit Sprachd

Beitragvon chris_54 » 17.05.2015 13:46

...o.k., mache ich.
Das ist dann alles, oder?
Muß ich neben dem install Ordner auch den docs Ordner aus dem Upgrade Paket auf den Server spielen, oder dient dieser nur zur Info?

Viele Grüße

Chris

Lehrling
Supporter
Supporter
Beiträge: 3318
Registriert: 15.01.2012 20:00
Kontaktdaten:

Re: Fehler beim Upgrade von 3.0.12 auf 3.0.13PL1 mit Sprachd

Beitragvon Lehrling » 17.05.2015 13:48

machst du jetzt ein Update deines Boards oder der Mod?
Allmählich bin ich etwas verwirrt.



Zurück zu „[3.0.x] Mod Support“