#-Tag M0D

Du suchst einen bestimmten Mod, weißt aber nicht genau wo bzw. ob er überhaupt existiert? Wenn dir dieser Artikel nicht weiterhilft, kannst du hier den von dir gewünschten/gesuchten Mod beschreiben ...
Falls ein Mod-Autor eine der Anfragen hier aufnimmt, um einen neuen Mod zu entwickeln, geht's in [3.0.x] Mods in Entwicklung weiter.
Forumsregeln
phpBB 3.0 hat das Ende seiner Lebenszeit überschritten
phpBB 3.0 wird nicht mehr aktiv unterstützt. Insbesondere werden - auch bei Sicherheitslücken - keine Patches mehr bereitgestellt. Der Einsatz von phpBB 3.0 erfolgt daher auf eigene Gefahr. Wir empfehlen einen Umstieg auf phpBB 3.1, welches aktiv weiterentwickelt wird und für welches regelmäßig Updates zur Verfügung gestellt werden.
Benutzeravatar
Miriam
Valued Contributor
Beiträge: 12309
Registriert: 13.10.2004 07:18
Wohnort: Ammerland
Kontaktdaten:

Re: #-Tag M0D

Beitragvon Miriam » 17.08.2013 14:02

LisaserstesForum hat geschrieben:Das einzige Problem ist nur noch, dass das Snippet von AmigoJ nach "Test" sucht, wenn ich "#Test" in einen Beitrag schreibe, es soll dann ja nach Beiträgen mit "#Test" gesucht werden.

Habe ich doch glatt die Hälfte vergessen zu posten? *tsts*

Finde also in AJ's Code:

Code: Alles auswählen

return $aMatch[1]. '<a href="'. append_sid( "{$phpbb_root_path}search.$phpEx", 'keywords='. $aMatch[2] ). '">#'. $aMatch[2]. '</a>';

tausche aus gegen:

Code: Alles auswählen

return $aMatch[1]. '<a href="'. append_sid( "{$phpbb_root_path}search.$phpEx", 'keywords=%23'. $aMatch[2] ). '">#'. $aMatch[2]. '</a>';


Ich hatte mich jetzt schon gewundert, wo das Problem liegt. :-P
Gruss, Miriam.
Ich schmeiß' alles hin und...
... lasse es liegen

LisaserstesForum
Mitglied
Beiträge: 996
Registriert: 28.08.2008 20:20
Wohnort: Kassel

Re: #-Tag M0D

Beitragvon LisaserstesForum » 17.08.2013 14:12

Juhu, es funktioniert! Ich könnte dich knutschen Miriam :D

Benutzeravatar
BNa
Valued Contributor
Beiträge: 2259
Registriert: 12.04.2010 23:51
Kontaktdaten:

Re: #-Tag M0D

Beitragvon BNa » 17.08.2013 14:35

An der gleichen Line war ich auch grad dran. Thx...

LisaserstesForum
Mitglied
Beiträge: 996
Registriert: 28.08.2008 20:20
Wohnort: Kassel

Re: #-Tag M0D

Beitragvon LisaserstesForum » 17.08.2013 14:44

Auch an dich Danke BNa für deine Hilfe :)

Benutzeravatar
BNa
Valued Contributor
Beiträge: 2259
Registriert: 12.04.2010 23:51
Kontaktdaten:

Re: #-Tag M0D

Beitragvon BNa » 17.08.2013 15:10

Hab ja eher schlaue Sprüche gemacht und war daher nicht 100% bei der Sache :oops: :grin:

Again, happy further coding :wink:
Zuletzt geändert von BNa am 17.08.2013 15:20, insgesamt 1-mal geändert.

LisaserstesForum
Mitglied
Beiträge: 996
Registriert: 28.08.2008 20:20
Wohnort: Kassel

Re: #-Tag M0D

Beitragvon LisaserstesForum » 17.08.2013 15:20

Und den Link zu dem Snippet gefunden, ohne das wäre es schwierig geworden. :wink:

Benutzeravatar
BNa
Valued Contributor
Beiträge: 2259
Registriert: 12.04.2010 23:51
Kontaktdaten:

Re: #-Tag M0D

Beitragvon BNa » 17.08.2013 15:21

Achja, stimmt :lol:
Na gut, dann passts scho > :geek:

LisaserstesForum
Mitglied
Beiträge: 996
Registriert: 28.08.2008 20:20
Wohnort: Kassel

Re: #-Tag M0D

Beitragvon LisaserstesForum » 19.08.2013 10:54

Ich habe ein kleines Problem entdeckt.
Wenn ich in einem Beitrag z.B. folgendes schreibe:
So, ich teste jetzt mal was.

#CSI #CriminalMinds

dann wird nur CriminalMinds hinterlegt, CSI nicht.

Wenn man in dem Beitrag nur
#CSI #CriminalMinds
schreibt, dann werden beide Begriffe hinterlegt.
Bei
test
#CSI #CriminalMinds
wieder nur CriminalMinds.
Habt ihr eine Idee, woran das liegen könnte?

Benutzeravatar
Miriam
Valued Contributor
Beiträge: 12309
Registriert: 13.10.2004 07:18
Wohnort: Ammerland
Kontaktdaten:

Re: #-Tag M0D

Beitragvon Miriam » 19.08.2013 20:10

Ich wundere micht, dass Du nicht noch mehr Problemchen herausgefunden hast. :-P

Nun aber erst mal zu diesem ->
finde:

Code: Alles auswählen

    $textpreg_replace_callback'/(^|style="[^"#]+|[^\\s]*[\\s]+|>)#([\\p{Lu}\\p{Ll}\\p{N}\\w\\d]+)\\b/um''hashtag_callback'$text ); 

davor füge ein:

Code: Alles auswählen

    $textstr_replace'<br />''<br /> '$text ); 
Gruss, Miriam.
Ich schmeiß' alles hin und...
... lasse es liegen

LisaserstesForum
Mitglied
Beiträge: 996
Registriert: 28.08.2008 20:20
Wohnort: Kassel

Re: #-Tag M0D

Beitragvon LisaserstesForum » 19.08.2013 20:27

Jetzt machst du mir aber Angst. :o Ist der Code so schlecht?
Danke für deine Hilfe! :)


Zurück zu „[3.0.x] Mod Suche/Anfragen“