[RC] Ad Management 1.0.1

In diesem Forum können Mod-Autoren ihre Mods vorstellen, die sich noch im Entwicklungsstatus befinden. Der Einbau in Foren im produktiven Betrieb wird nicht empfohlen.
Forumsregeln
phpBB 3.0 hat das Ende seiner Lebenszeit überschritten
phpBB 3.0 wird nicht mehr aktiv unterstützt. Insbesondere werden - auch bei Sicherheitslücken - keine Patches mehr bereitgestellt. Der Einsatz von phpBB 3.0 erfolgt daher auf eigene Gefahr. Wir empfehlen einen Umstieg auf phpBB 3.1, welches aktiv weiterentwickelt wird und für welches regelmäßig Updates zur Verfügung gestellt werden.
El Draco
Mitglied
Beiträge: 92
Registriert: 27.11.2007 13:50

Re: [RC] Ad Management 1.0.1

Beitragvon El Draco » 02.02.2012 20:32

Hallo Helmut,

mir ist noch folgender Fehler aufgefallen falls noch jemand das Script installieren möchte:

- SQL Anweisung:
Anstatt
"CREATE TABLE IF NOT EXISTS `phpbb3_ad`"
muss es
"CREATE TABLE IF NOT EXISTS `phpbb_ad`"
Standart Prefix ist "phpbb" bei der Installation.
Genauso bei
"CREATE TABLE IF NOT EXISTS `phpbb3_ad_config`"
muss es
"CREATE TABLE IF NOT EXISTS `phpbb_ad_config`"
heissen.

In der Common.css gibt es kein:
".resultDIV {"

Saludos
El Draco

Helmut
Mitglied
Beiträge: 2047
Registriert: 27.12.2002 20:35
Wohnort: Augsburg
Kontaktdaten:

Re: [RC] Ad Management 1.0.1

Beitragvon Helmut » 02.02.2012 20:55

Hallo El Draco,

ok habs in der install.xml geändert, sagte ja dass ich es nicht geprüft habe.

Aber ansonsten sollte der Mod laufen. Für die Bannerübersicht ads_banner.php müsste vielleicht noch ein Link in die overall_header rein.....

Gruß Helmut :wink:
Zuletzt geändert von Helmut am 02.02.2012 21:02, insgesamt 1-mal geändert.
Ich bin nicht ganz dicht.... na und.

Meine HP

El Draco
Mitglied
Beiträge: 92
Registriert: 27.11.2007 13:50

Re: [RC] Ad Management 1.0.1

Beitragvon El Draco » 02.02.2012 20:59

Hallo Helmut,

ja, das MOD läuft perfekt :-)
Genau das was ich gesucht habe.

Daaaaaaaaanke !!!!!!!!!!!!!!!!

Saludos
El Draco

Manu-Nanu
Mitglied
Beiträge: 21
Registriert: 24.01.2012 19:55

Re: [RC] Ad Management 1.0.1

Beitragvon Manu-Nanu » 05.04.2012 22:37

Hallo,
habe alle 62 Seiten durchgelesen und auch vieles von euren Tipps ausprobiert aber bei mir scheint nichts zu helfen.

ich habe phpbb 3.0.10 und Ad Management 1.0.1 instslliert.
Im Adminzentrum wird der Werbebanner als Vorschau angezeigt und beim "Absenden" erscheint eine Meldung das es erfolgreich war. Es wird im Forum aber keine Werbung angezeigt.

Wenn ich diese vorgegebene Änderung aus der englischen Anleitung in der funktions.php ausführe, dann bekomme ich eine Fehlermeldung das irgendein "parse ' ' ) fehler in einer bestimmten line wäre und wenn es ich es mache wie hier schon empfohlen wurde ( also nicht so wie in der englischen Anleitung, sondern zuerst den einen Teil über dem zu suchenden Satz und den anderen Teil darunter) dann bekonmme ich eine Fehlermeldung über einen T_String in besagter line.
Kann mit beiden aber nichts anfangen.
Was die sql betrifft, so ist diese _ad vorhanden,

Themes, Templates und Grafik habe ich aktualisiert und cache im Forum und auch im Brwoser geleert....trotzdem geht nichts.

Ich weiß nicht mehr weiter was ich ändern soll oder kann, das die Werbung angezeigt wird.

Wäre sehr dankbar für eine ausführliche Hilfe, da ich in solchen Dingen eher Neuling bin.
Dazu käme noch die Frage was man tun muss um Ad Management zu updaten. Habe eine update-Sammlung (von 1.0.0 bis 1.0.12 alle updates vorhanden) runtergeladen, aber weiß nicht wie ich die eingebaut bekomme....wäre aber schon glücklich wenn es mit der 1.01 funktionieren würde.

Falls es hilft, hier mal ein Link zum besagten Forum : http://www.forum.patientenblick.de

Benutzeravatar
redbull254
Valued Contributor
Beiträge: 10362
Registriert: 05.01.2006 13:01
Kontaktdaten:

Re: [RC] Ad Management 1.0.1

Beitragvon redbull254 » 06.04.2012 01:29

Hallo erstmal,

stelle hier bitte die vollständige Fehlermeldung rein. Auf Grund der Fehlermeldung kann man den Fehler oft erkennen oder zumindest einkreisen.

Deine Teil-Fehlermeldung deutet m.E. auf einen falschen Mod-Einbau hin. Eine Klammer vergessen oder ähnliches.

Manu-Nanu
Mitglied
Beiträge: 21
Registriert: 24.01.2012 19:55

Re: [RC] Ad Management 1.0.1

Beitragvon Manu-Nanu » 06.04.2012 02:05

Im adminzentrum zeigt es "erfolgreich" an und den Banner sehe ich auch in der Vorschau ich befürchte das ich in den zu ändernden Dateien etwas falsch gemacht habe. Funktions.php, usw...
hab es auch schon mit dem Tipp hier probiert aber geht nicht,

Diese fehlermeldung kommt.....

Parse error: syntax error, unexpected ';', expecting ')' in /homepages/19/d385288488/htdocs/forum/includes/functions.php on line 4724


Ausserdem nutze ich style subsilver2 doch in der englischen modanleitung wird nur prosilver beschrieben.
Hab das forum aber auch schon auf prosilver umgestellt doch trotzdem ging nichts.

Benutzeravatar
redbull254
Valued Contributor
Beiträge: 10362
Registriert: 05.01.2006 13:01
Kontaktdaten:

Re: [RC] Ad Management 1.0.1

Beitragvon redbull254 » 06.04.2012 02:26

Überprüfe dieincludes/functions.php noch einmal in Ruhe, da hast Du Code falsch gesetzt oder etwas entfernt.

Wenn die Anleitung nur für Prosilver ist, kannst Du die Mod nicht benutzen.

Es gibt aber noch eine ähnliche Mod die m.W. nach auch noch weiter entwickelt wird.

Manu-Nanu
Mitglied
Beiträge: 21
Registriert: 24.01.2012 19:55

Re: [RC] Ad Management 1.0.1

Beitragvon Manu-Nanu » 06.04.2012 02:27

Kann ich denn irgendwie etwas bekommen dass es auch im subsilver2 möglich ist?

Benutzeravatar
redbull254
Valued Contributor
Beiträge: 10362
Registriert: 05.01.2006 13:01
Kontaktdaten:

Re: [RC] Ad Management 1.0.1

Beitragvon redbull254 » 06.04.2012 02:30

Manu-Nanu hat geschrieben:Kann ich denn irgendwie etwas bekommen dass es auch im subsilver2 möglich ist?


Warte man einen Moment, ich schau mal nach, wo die Mod ist die ich meine.

Edit://

Bei Deiner Mod liegt doch eine Installationsanleitung für "Subsilver2" bei, oder ist das nicht diese Mod?

http://www.phpbb-seo.de/downloads/mod-a ... ement.html


Edit 2//

Wie wäre es hier mit?
http://www.lpi-clan.de/viewtopic.php?f=26&t=2609

Manu-Nanu
Mitglied
Beiträge: 21
Registriert: 24.01.2012 19:55

Re: [RC] Ad Management 1.0.1

Beitragvon Manu-Nanu » 06.04.2012 02:35

Doch und ich habe da auch etwas von subsilver dabei, doch ich bekomme es nicht geöffnet, dass ich eine anleitung sehen kann.
Mit welchem Weg kann ich die den öffnen.?

die englische für prosilver konnte ich mit einem online-link öffnen
dieser....gibt es sowas nicht für subsilver?
http://www.phpbb-seo.de/tools/modx/mod-1.html


Zurück zu „[3.0.x] Mods in Entwicklung“