[MODDB] Automatische Sommerzeit

In diesem Forum können Mod-Autoren ihre Mods vorstellen, die sich noch im Entwicklungsstatus befinden. Der Einbau in Foren im produktiven Betrieb wird nicht empfohlen.
Forumsregeln
phpBB 3.0 hat das Ende seiner Lebenszeit überschritten
phpBB 3.0 wird nicht mehr aktiv unterstützt. Insbesondere werden - auch bei Sicherheitslücken - keine Patches mehr bereitgestellt. Der Einsatz von phpBB 3.0 erfolgt daher auf eigene Gefahr. Wir empfehlen einen Umstieg auf phpBB 3.1, welches aktiv weiterentwickelt wird und für welches regelmäßig Updates zur Verfügung gestellt werden.
Benutzeravatar
MartectX
Ehemaliger Übersetzer
Beiträge: 648
Registriert: 10.05.2008 17:08
Wohnort: Marienplatz

Beitrag von MartectX » 20.10.2008 18:10

Version 1.0.2
  • Verbesserter Code
  • Erlaubt es Benutzern, Sommerzeit zu erzwingen
  • Unterstützung von MOD Version Check

Benutzeravatar
friedels-home
Mitglied
Beiträge: 333
Registriert: 19.02.2006 00:59
Wohnort: Weingarten/Pfalz
Kontaktdaten:

Beitrag von friedels-home » 20.10.2008 19:25

Super. Das ist prompter Sevice. :grin:

Benutzeravatar
MartectX
Ehemaliger Übersetzer
Beiträge: 648
Registriert: 10.05.2008 17:08
Wohnort: Marienplatz

Beitrag von MartectX » 20.10.2008 19:29

Ich hatte schon seit Mai nichts mehr mit dem Mod zu tun und musste erstmal auf ModX 1.2.1 updaten. Alles in allem habe ich 3 Stunden gebraucht, um die Installationsanleitung zu erstellen. Das reine modden der Funktionalität war weitaus weniger aufwändig... :(

Benutzeravatar
friedels-home
Mitglied
Beiträge: 333
Registriert: 19.02.2006 00:59
Wohnort: Weingarten/Pfalz
Kontaktdaten:

Beitrag von friedels-home » 21.10.2008 08:14

Ich habe noch einige kleine Fehler gefunden.

In der install.xml:

Bei der language/en/common.php ist sowohl bei dem Text, den man finden soll, als auch bei dem Text, den man einsetzen soll, am Anfang jeweils einTabulator zu viel.

In der de.xml:
Historie des Mods
2008-05-11 - Version1.0.0

en First release

de Erstveröffentlichung
Das ist doch die Version 1.0.2 vom 20.10.2008. Da fehlen wohl ein paar Einträge.

In der language/de/common.php
'AUTH_NO_PROFILE_CREATED' => 'Die Erstellung eines Ingenieursprofils ist gescheitert.',
Die Zeile heißt normalerweise
'AUTH_NO_PROFILE_CREATED' => 'Die Erstellung eines Mitgliederprofils ist gescheitert.',

Benutzeravatar
MartectX
Ehemaliger Übersetzer
Beiträge: 648
Registriert: 10.05.2008 17:08
Wohnort: Marienplatz

Beitrag von MartectX » 21.10.2008 10:32

friedels-home hat geschrieben:In der install.xml:

Bei der language/en/common.php ist sowohl bei dem Text, den man finden soll, als auch bei dem Text, den man einsetzen soll, am Anfang jeweils einTabulator zu viel.
Danke für Deine Rückmeldung; ich konnte alles nachvollziehen außer dem zitierten Teil. Bei mir ist in language/en/common.php ein Tabulator zu Beginn jeder Zeile, genau wie in der ModX-Installationsdatei.

Benutzeravatar
friedels-home
Mitglied
Beiträge: 333
Registriert: 19.02.2006 00:59
Wohnort: Weingarten/Pfalz
Kontaktdaten:

Beitrag von friedels-home » 21.10.2008 12:33

Aha. Dann war das vielleicht die Stelle, wo ich beim Einbau Mist gebaut hab. Mein Board hat nach dem Umbau jedenfalls nicht mehr funktioniert. Ich habe das Backup eingespielt und werde es morgen noch mal probieren. Vielleicht hab ich ja was falsches kopiert oder an die falsche Stelle gebaut. Das würde den falschen Tabulator erklären. Ich habe den Beitrag heute morgen geschrieben, während ich das ganze hochgeladen habe. Hätte ich gewusst, dass es nicht funktioniert, hätte ich mit meiner Rückmeldung gewartet, bis ich den Fehler gefunden habe.

Benutzeravatar
MartectX
Ehemaliger Übersetzer
Beiträge: 648
Registriert: 10.05.2008 17:08
Wohnort: Marienplatz

Beitrag von MartectX » 21.10.2008 12:52

Der falsche Tabulator hätte zumindest keinen Einfluss auf die Funktionsfähigkeit gehabt. Die falsche Datei dagegen natürlich schon. :P

Benutzeravatar
redbull254
Mitglied
Beiträge: 10374
Registriert: 05.01.2006 13:01
Kontaktdaten:

Beitrag von redbull254 » 22.10.2008 02:59

Hallo erstmal,

die Mod ohne Probleme eingebaut bekommen. An dieser Stelle ein großes "Danke" für diese Mod. :grin:

Jetzt kann man nur abwarten, bis die tatsächliche Umstellung erfolgt, um zu schauen, ob alles passt.

Oder gibt es einen Trick zum Testen, die Server-Zeit kann ich nicht verändern.

Edit:

warum auch immer "knallt" es im Forum, wenn ich die Bug-Tracker-Mod auf rufe.
Installierter Bug-Tracker

Code: Alles auswählen

phpBB Debug] PHP Notice: in file /includes/session.php on line 1925: date() expects parameter 2 to be long, string given
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3763: Cannot modify header information - headers already sent by (output started at /includes/functions.php:2994)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3765: Cannot modify header information - headers already sent by (output started at /includes/functions.php:2994)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3766: Cannot modify header information - headers already sent by (output started at /includes/functions.php:2994)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3767: Cannot modify header information - headers already sent by (output started at /includes/functions.php:2994)
Lade ich die "alte" session.php wieder rein, ist die Fehlermeldung weg.

Einfach mal selber probieren und in der oberen Tab-Leiste auf "Bug-Tracker" klicken.
Dazu ist keine Anmeldung erforderlich.

Link siehe Signatur. (Digi-Forum)

Benutzeravatar
MartectX
Ehemaliger Übersetzer
Beiträge: 648
Registriert: 10.05.2008 17:08
Wohnort: Marienplatz

Beitrag von MartectX » 22.10.2008 16:58

redbull254 hat geschrieben:warum auch immer "knallt" es im Forum, wenn ich die Bug-Tracker-Mod auf rufe.
Installierter Bug-Tracker

Code: Alles auswählen

phpBB Debug] PHP Notice: in file /includes/session.php on line 1925: date() expects parameter 2 to be long, string given
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3763: Cannot modify header information - headers already sent by (output started at /includes/functions.php:2994)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3765: Cannot modify header information - headers already sent by (output started at /includes/functions.php:2994)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3766: Cannot modify header information - headers already sent by (output started at /includes/functions.php:2994)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3767: Cannot modify header information - headers already sent by (output started at /includes/functions.php:2994)
Lade ich die "alte" session.php wieder rein, ist die Fehlermeldung weg.
Habe testweise den Bug Tracker installiert sowie Automatische Sommerzeit und konnte den Fehler nicht nachvollziehen. Poste doch mal die Zeilen 2990-3000 von functions.php sowie 1920-1930 von session.php.

Benutzeravatar
redbull254
Mitglied
Beiträge: 10374
Registriert: 05.01.2006 13:01
Kontaktdaten:

Beitrag von redbull254 » 22.10.2008 17:44

Ich denke, besser ich verlinke die Dateien mal hier.

Link entfernt, Fehler wurde von @nickvergessen gefixt.
Zuletzt geändert von redbull254 am 22.10.2008 22:00, insgesamt 1-mal geändert.

Gesperrt

Zurück zu „[3.0.x] Mods in Entwicklung“