[FINAL] Impressum Dinseprinz 0.1.8

In diesem Forum können Mod-Autoren ihre Mods vorstellen, die sich noch im Entwicklungsstatus befinden. Der Einbau in Foren im produktiven Betrieb wird nicht empfohlen.
Forumsregeln
phpBB 3.0 hat das Ende seiner Lebenszeit überschritten
phpBB 3.0 wird nicht mehr aktiv unterstützt. Insbesondere werden - auch bei Sicherheitslücken - keine Patches mehr bereitgestellt. Der Einsatz von phpBB 3.0 erfolgt daher auf eigene Gefahr. Wir empfehlen einen Umstieg auf phpBB 3.1, welches aktiv weiterentwickelt wird und für welches regelmäßig Updates zur Verfügung gestellt werden.
Benutzeravatar
ups
Mitglied
Beiträge: 990
Registriert: 06.12.2006 14:57
Wohnort: Basel/Freiburg Land

[FINAL] Impressum Dinseprinz 0.1.8

Beitragvon ups » 17.05.2008 11:51

MOD Name: phpbb Impressum
Autor: Dinseprinz

MOD Version: 0.1.8
MOD Beschreibung:

    Fügt Deinem phpbb3 Forum ein Impressum hinzu, die Konfiguration erfolgt über das ACP.

    Aktuelle Änderungen:

    [NEU] MOD-Installer - beruhend auf dem board3 Portal-Installer
    [NEU] XML-Dateien auf MODX 1.2.1 aktualisiert
    [NEU] Jumpbox auf der impressum_body.html eingebaut
    [NEU] Die Abfrage der MOD-Version in phpbb_impressum_version.php erfolgt über die Datenbank
    [NEU] Admin-Log hinzugefügt | zeigt in der Übersicht, wenn das Impressum aktualisiert wurde
    [NEU] Die Abfrage der MOD-Version im Konfigurationsmenü erfolgt über die Datenbank
    [NEU] Haftungsausschluss im ACP komplett abschaltbar
    [NEU] icon_disclaimer.gif über *.css eingebunden

    Sprachvariablen für ACP und Installer hinzugefügt
    Letzte Codefehler beseitigt
    Fehler in den Sprachdateien beseitigt

    [ADDON] *Haftungsausschluss auf der Index standardmäßig ausgeblendet - Besucher können ihn ein- und ausblenden
    [ADDON BETA] Besucher können Sprache wechseln

    *Java-Script muss aktiviert sein

Screenshots: 01 02
Unterstützte Styles: prosilver, subsilver2
Unterstützte Sprachpakete: de, en
Downloads: http://arcadewelten.eu/phpBB2/downloads.php?view=detail&df_id=29
Alternativ: http://www.xup.in/dl,78181958/Impressum.rar/






.
Zuletzt geändert von ups am 09.10.2010 05:53, insgesamt 9-mal geändert.

Benutzeravatar
Dr.Death
Moderator
Moderator
Beiträge: 15341
Registriert: 23.04.2003 08:22
Wohnort: Xanten
Kontaktdaten:

Beitragvon Dr.Death » 17.05.2008 12:15

MODs, die auf einen MOD ausgebaut sind, sollten einen eigenen Namen haben damit man sie besser unterscheiden kann.


Bei Impressum 0.1.6 würde ich immer an Tobis MOD denken... nur eine Version höher. ( Ausnahme des ganzen: Tobi stellt die Entwicklung komplett ein und Du hast das MOD übernommen. )

Zweitens: MODs sollten immer im ZIP Format angeboten werden. Nicht jeder hat ein RAR ( WinRar ) installiert.

Benutzeravatar
ups
Mitglied
Beiträge: 990
Registriert: 06.12.2006 14:57
Wohnort: Basel/Freiburg Land

Beitragvon ups » 17.05.2008 12:29

sorry dr.death, du hast vollkommen recht.

da es in den thread impressum immer wieder von versionsvermischungen geht und keiner weiß welche version die user grad instaliert haben und um unnötige nachfragen zu stellen hab ich mir halt gedacht hier nen neuen thread aufzumachen.

vieleicht ändert ja dinseprinz seine version oder er checkt das mal ab mit tobi...keine ahnung.

meine intention ist das ganze ein bischen zu sepparieren...war in guter absicht und guten glauben

hier in zip format: http://www.file-upload.net/download-855 ... 6.zip.html

nicht böse sein, geschah in guter absicht...

ups

Benutzeravatar
djchrisnet
Mitglied
Beiträge: 1275
Registriert: 29.06.2007 15:52
Wohnort: Elmshorn
Kontaktdaten:

Beitragvon djchrisnet » 17.05.2008 13:28

Code: Alles auswählen

$user->setup('mods/impressum');
$user->add_lang('mods/impressum');


Ausserdem habe ich im template folgendes finden müssen:

Code: Alles auswählen

<img src="./styles/prosilver/theme/{T19}" border="0" />


und bin auf jenen Bild und die änderung der templatevariablennamen bzw. nutzung einer anderen templatefunktion kann ich absolut keinen Unterschied erkennen.

MoJoe
Mitglied
Beiträge: 2
Registriert: 17.05.2008 22:16

Beitragvon MoJoe » 17.05.2008 22:28

Hallo zusammen,

erstmal vielen Dank für deinen MOD.

Habe mich strikt an deine Anleitung gehalten sogar mehrfach durchgelesen, aber das Icon neben dem Impressum im Header will nicht erscheinen.

Wie Du aber feststellen wirst, erscheint neben dem Link noch kein Icon.
Du musst erst im ACP unter Styles den Template-Cache, Theme-Cache sowie den Grafiksammlung-Cache leeren (Aktualisieren).


Template Cache habe ich gelöscht (Theme und Grafiksammlung hatten keinen!?)
Unter dem Reiter Allgemein habe ich auch den Haupt-Cache gelöscht.

Irgendwie erscheint das Icon nicht, ja habs dahin kopiert liegt auch da.

Was mir aufgefallen ist unter Styles --> Grafiksammlung --> Ändern lassen sich ja alle Grafiken anzeigen, das Icon fürs Impressum war nicht dabei, muss also doch wohl irgendwo was aktualisiert werden,... nur wo!?

Ich habe kein Standard Style im Einsatz sondern einen modifizierten prosilver.

Was mir dann noch aufgefallen ist wenn ich im Impressum drin bin, holt er sich das Bildchen (Logo) von hier http://xy.de/styles/prosilver/theme/images/logo.gif !?

Aber prosilver nutze ich gar nicht, ist sogar deaktiviert!? hmmm komisch

Vielelicht kann ja wer helfen.

Danke euch,
Mo

Benutzeravatar
djchrisnet
Mitglied
Beiträge: 1275
Registriert: 29.06.2007 15:52
Wohnort: Elmshorn
Kontaktdaten:

Beitragvon djchrisnet » 17.05.2008 22:54

das liegt daran, dass das logo hard programmiert ist!

djchrisnet hat geschrieben:

Code: Alles auswählen

<img src="./styles/prosilver/theme/{T19}" border="0" />

Benutzeravatar
redbull254
Valued Contributor
Beiträge: 10362
Registriert: 05.01.2006 13:01
Kontaktdaten:

Beitragvon redbull254 » 18.05.2008 01:17

Wäre ja schön, wenn es einmal eine wirklich auf Anhieb funktionierende und saubere Impressum Mod geben würde.

Aber das wird wohl "Wunschdenken" bleiben.

Bin froh, das ich eine funktionierende Version im Einsatz habe und keine weiteren Funktionen benötige. :grin:

So lobenswert es ist, einen Versuch zu starten, Ordnung in das Chaos rund um diese Mod zu bringen, aber dann bitte mit einer Fehler-bereinigten Version.
Reicht schon, das der Support beim Mod insgesamt bescheiden ist.
Zuletzt geändert von redbull254 am 18.05.2008 02:14, insgesamt 1-mal geändert.

4seven
Mitglied
Beiträge: 5869
Registriert: 21.04.2007 06:18

Beitragvon 4seven » 18.05.2008 01:43

Über die Anleitung zum hinzufügen eigener Seiten zum phphbb3
(frag mich nach dem Link) kann man das doch ganz easy selbst basteln.

[offtopic]
Verstehe dieses ganze Impressum-Brimborium eh nicht, aber what shells. Kein privates Forum braucht sowas (Rechtslage ist hier völligst ungeklärt) und solange es kein allgemeingültiges Gesetz gibt, was uns dazu zwingt, also klar definiert rechtlich zwingt, brauchts auch kein Impressum. Der einzige Grund für die Angstmache, die viele dazu treibt dort tatsächlich ein Impressum anzubringen, ist Unsicherheit. Es gibt definitiv keinerlei Rechtsgrundlage dafür. Einzig die Rechteinhaber und Abzocker freuen sich, das sie nun nichtmal mehr recherchieren oder gerichtliche Beschlüsse erwirken müssen, um abzukassieren. Das ist der einzige Sinn und Zweck der Übung. In der nächsten Stufe geht es um Redefreiheit und anonyme Meinungsäußerung, die dann nicht mehr existieren wird.
[/offtopic]

Mogwai
Mitglied
Beiträge: 35
Registriert: 12.05.2008 00:25
Wohnort: Berlin
Kontaktdaten:

Beitragvon Mogwai » 18.05.2008 02:17

Alles ist da und sichtbar, aber: wenn ich im ACP die Daten eintrage und auf absenden klicke, verschwinden sie und erscheinen dann auch nicht auf der Impressum-Seite. :cry:

Benutzeravatar
djchrisnet
Mitglied
Beiträge: 1275
Registriert: 29.06.2007 15:52
Wohnort: Elmshorn
Kontaktdaten:

Beitragvon djchrisnet » 18.05.2008 02:20

klingt ja ganz nach erfolgreich durch leere variablen überschrieben xD


Zurück zu „[3.0.x] Mods in Entwicklung“