phpBB 3.2.2 erschienen - Bitte updaten

News zu phpBB.de und phpBB
Bitte dieses Forum immer lesen.
Benutzeravatar
gn#36
Administrator
Administrator
Beiträge: 9204
Registriert: 01.10.2006 16:20
Wohnort: Ganz in der Nähe...
Kontaktdaten:

phpBB 3.2.2 erschienen - Bitte updaten

Beitragvon gn#36 » 07.01.2018 22:51

Hallo zusammen,

das phpBB Team hat phpBB 3.2.2 unter dem Codenamen "Bertis Neujahrsvorsatz" (Bertie’s New Year Resolution) veröffentlicht. Wie alle Releases der 3.2.x Reihe handelt es sich hierbei um einen Maintenance Release. Dieser behebt neben einigen Fehlern eine Sicherheitslücke, bei der es möglich war, Javascript URL Schemata in URL Profilfeldern zu verwenden (also z.B. Website). Es wird daher empfohlen, nicht auf Profilfeldlinks zu klicken, die verdächtig vom üblichen Format (z.B. https://www.phpbb.de) abweichen. Grundsätzlich sind allerdings alle externen Links ein potenzielles Sicherheitsrisiko, so dass es sich empfielt, auch bei korrekt formatierten Links Vorsicht walten zu lassen.

Diese Sicherheitslücke ist auch in älteren phpBB Versionen vorhanden, wird aber im parallel erscheinenden letzten phpBB 3.1.12 Release ebenfalls behoben.

Ebenfalls in beiden Versionen gab es noch ein kleines Feature Update: phpBB unterstützt nun die Nutzung von Memcached als Cache Backend.

Erwähnenswerte Fehlerkorrekturen umfassen unter anderem Fehler bei Updates von phpBB 3.0.5 und älter, Fehlerhaft erkannten Bildabmessungen in Uploads, unscharfen Forum und Themen icons in einigen Browsern und Fehler beim Löschen von verwaisten Dateianhängen, wenn sehr viele verwaiste Dateianhänge existieren.

Ebenfalls erwähnenswert ist, dass aufgrund von Änderungen in den Abhängigkeiten (von phpBB verwendeter Fremdsoftware) die minimale PHP Version für phpBB 3.2.2 nun 5.4.7 ist. Das phpBB Team weist darauf hin, dass phpBB mit PHP Versionen zwischen 5.4.0 und 5.4.6 voraussichtlich auch weiterhin funktionsfähig bleibt, sollten allerdings Probleme auftreten sollte mindestens auf PHP 5.4.7 hochgerüstet werden.

Am anderen Ende des Spektrums unterstützt phpBB nun auch PHP 7.2. Bitte prüft die Funktionsfähigkeit von Erweiterungen vor dem Update auf diese PHP Version.

Eine Liste der übrigen Highlights findet sich im phpBB Wiki, eine vollständige Liste aller Änderungen im Bugtracker.

Die deutschen Sprachpakete sind in Vorbereitung und werden in Kürze hier veröffentlicht.


Fragen und Anregungen könnt ihr wie immer im Diskussions-Thema erstellen.

Edit:
Es sind beim Update zu phpBB 3.2.2 Probleme gefunden worden, die das Update verhindern können. Deshalb bitte das Thema beachten:
viewtopic.php?f=145&t=240809 Im Zweifel mit dem Update auf 3.2.2 warten.
Begegnungen mit dem Chaos sind fast unvermeidlich, Aber nicht katastrophal, solange man den Durchblick behält.
Übertreiben sollte man's im Forum aber nicht mit dem Chaos, denn da sollen ja andere durchblicken und nicht nur man selbst.

Benutzeravatar
gn#36
Administrator
Administrator
Beiträge: 9204
Registriert: 01.10.2006 16:20
Wohnort: Ganz in der Nähe...
Kontaktdaten:

Re: phpBB 3.2.2 erschienen - Bitte updaten

Beitragvon gn#36 » 11.01.2018 23:40

Die deutschen Sprachpakete sind nun in unserem Downloadbereich verfügbar.

Bei einigen Foren kann es beim Update zu Fehlern kommen.

Bitte beachtet daher vor dem Update diese Hinweise zu bekannten Problemen beim Update.
Begegnungen mit dem Chaos sind fast unvermeidlich, Aber nicht katastrophal, solange man den Durchblick behält.
Übertreiben sollte man's im Forum aber nicht mit dem Chaos, denn da sollen ja andere durchblicken und nicht nur man selbst.


Zurück zu „Ankündigungen und Neuigkeiten“