[3.2]Stylesheet läd nicht nach Logout

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.1.x und höher und die Konvertierung zu phpBB 3.2.x.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.1.x] oder [3.2.x] angeben.
Kaho
Mitglied
Beiträge: 9
Registriert: 30.09.2017 17:18

[3.2]Stylesheet läd nicht nach Logout

Beitragvon Kaho » 30.09.2017 17:21

Hallo zusammen,

ich habe gestern das 3.2 Board installiert auf unserem Webspace.
Nun habe ich folgendes Problem:

Wenn sich jemand Ausloggt (ab und zu auch beim Einloggen) läd das Forum den Stylesheet nicht mehr.
Das ganze sieht dann für einige Zeit so aus:

[ externes Bild ]

Auch bei allen Usern.

Kann mir dabei einer helfen? :(

Benutzeravatar
Crizzo
Administrator
Administrator
Beiträge: 9250
Registriert: 19.05.2005 21:45
Kontaktdaten:

Re: [3.2]Stylesheet läd nicht nach Logout

Beitragvon Crizzo » 30.09.2017 18:24

Hi,

stell mal bitte Zugangsdaten für einen Testaccount hier rein inkl. Link zum Forum. Das will ich gerne mal in AKtion sehen.

Grüße
phpBB Translations & International Support Teams Manager

Kaho
Mitglied
Beiträge: 9
Registriert: 30.09.2017 17:18

Re: [3.2]Stylesheet läd nicht nach Logout

Beitragvon Kaho » 30.09.2017 18:41

Hey Crizzo,

danke für deine schnelle antwort.

Login: testacc
pw: testacc
Url: http://braindead-zombies.org/forum/


konnte das ganze nun ein paar mal schon reproduzieren.
Das Forum scheint nach dem Logout nicht auf /forum/ zu linken sondern auf die Seite ohne Endung.

Wenn der Style Fehler Auftritt und ich auf "Control Panel" gehe linkt er nur auf http://braindead-zombies.org/ucp.php und nicht auf http://braindead-zombies.org/forum/ucp.php

Im Interface ist allerdings alles mit /forum/ angegeben...

Vllt. hilft das weiter.

Danke dir schon mal!

Grüße

Kaho

Benutzeravatar
Crizzo
Administrator
Administrator
Beiträge: 9250
Registriert: 19.05.2005 21:45
Kontaktdaten:

Re: [3.2]Stylesheet läd nicht nach Logout

Beitragvon Crizzo » 30.09.2017 18:47

Hi,

ich kann das jetzt in mehrfachen Versuchen überhaupt nicht reproduzieren. Siehst du irgendwie, wie genau das passiert oder einfach immer? Hast du das Problem mit einem anderen Browser und nach dem Leeren des Browser-Caches immer noch?

Hast du eigentlich irgendwelche Server-Einstellungen erzwungen?

Grüße
phpBB Translations & International Support Teams Manager

Kaho
Mitglied
Beiträge: 9
Registriert: 30.09.2017 17:18

Re: [3.2]Stylesheet läd nicht nach Logout

Beitragvon Kaho » 30.09.2017 18:50

Hey,

ja das Problem hab ich mit allen Browsern.

Der Fehler Tritt nicht auf wenn ich nach dem Logout auf "Forum" klicke.
Wenn ich allerdings nach dem Logout oben auf das Headerlogo klicke, kommt das Problem bei mir dauerhaft.

Edit: Hmm... Auch im Eingeloggten zustand wenn ich das Headerbild nach dem Login nutze..

Grüße

Benutzeravatar
Crizzo
Administrator
Administrator
Beiträge: 9250
Registriert: 19.05.2005 21:45
Kontaktdaten:

Re: [3.2]Stylesheet läd nicht nach Logout

Beitragvon Crizzo » 30.09.2017 19:02

Hi,

ah, jetzt hab ich es auch hinbekommen.

Dann sehen deine Bezüge zu CSS-Dateien oder JS so aus:

Code: Alles auswählen

<link href="./../../assets/css/font-awesome.min.css?assets_version=10" rel="stylesheet">
<link href="./../../styles/simplicity/theme/stylesheet.css?assets_version=10" rel="stylesheet">
<link href="./../../styles/simplicity/theme/icons.css" rel="stylesheet">
<link href="./../../styles/simplicity/theme/utilities.css" rel="stylesheet">


Du hast ein 3.2.0 oder 3.2.1 installiert? Dein Style ist dafür korrekt? Zeig mir mal deine Overall_header.html in der PasteBin: pastebin/

Grüße

PS: Ich erinnere nochmal an:
Crizzo hat geschrieben:Hast du eigentlich irgendwelche Server-Einstellungen erzwungen?
phpBB Translations & International Support Teams Manager

Kaho
Mitglied
Beiträge: 9
Registriert: 30.09.2017 17:18

Re: [3.2]Stylesheet läd nicht nach Logout

Beitragvon Kaho » 30.09.2017 22:26

Hey,

Version des Boards: 3.2.1
Theme: simplicity_3.2.1


An den Servereinstellungen ist nichts geändert. Die .htaccess datei hat auch keine rewrite Rule aktiv.

.htaccess
# e.g.: if your domain is test.com and you installed phpBB
# in http://www.test.com/phpBB/index.php you have to set
# the statement RewriteBase /phpBB/
#
#RewriteBase /forum/

selbst wenn ich die rewrite rule anmache geht das leider nicht... :(
Hatte den Fehler gestern schon, hab das Forum neu aufgesetzt aber leider tut sich nichts... :-/

Talk19zehn
Ehemaliger
Beiträge: 4284
Registriert: 08.06.2009 12:03

Re: [3.2]Stylesheet lädt nicht nach Logout

Beitragvon Talk19zehn » 30.09.2017 22:39

Hi, und woher stammt jener Eintrag: <style>#page-body form {display: none;}</style>
Welche Zusammenhänge gäbe es? W3C schimpft und ich kann mir keinen Reim drauf machen. :oops:
:-? Grüße
Zuletzt geändert von Talk19zehn am 30.09.2017 22:46, insgesamt 1-mal geändert.
Angaben ohne Gewähr, da von zahlreichen Komponenten abhängig. 8)

Kaho
Mitglied
Beiträge: 9
Registriert: 30.09.2017 17:18

Re: [3.2]Stylesheet läd nicht nach Logout

Beitragvon Kaho » 30.09.2017 22:46

Hm...

Bei diesem Mod im ordner styles > all > template > event steht nur
<style>#page-body form {display: none;}</style>

drin... Hatte es zum testen deaktiviert... Wird das der fehler sein?

https://bitbucket.org/snitchashor/php-ext-authevesso

Talk19zehn
Ehemaliger
Beiträge: 4284
Registriert: 08.06.2009 12:03

Re: [3.2]Stylesheet läd nicht nach Logout

Beitragvon Talk19zehn » 30.09.2017 22:50

Hi, und ich habe keine Ahnung, habe das *Teilchen nie gesehen oder gar getestet. Mir erschließt sich der Sinn auch wirklich nicht.
Deine Fehlermeldung: Möglichkeiten sind daher u.U. immens.
Insofern ist´s auch durchaus möglich, dass sich etwas in die *DB eingegraben hat.

LG

Edit:
Arty´s Styles benötigen: Sass compiler for phpBB 3.1
https://www.artodia.com/threads/sass-co ... -3-1.2186/

Aber das weißt du sicher! :)

Ratlose Grüße
Zuletzt geändert von Talk19zehn am 30.09.2017 22:55, insgesamt 1-mal geändert.
Angaben ohne Gewähr, da von zahlreichen Komponenten abhängig. 8)


Zurück zu „Support-Forum“