Ext. Link Extender - brauche Anpassung von Php 7.4 auf 8.0..

In diesem Forum gibt es Starthilfe zum neuen Extension-System von phpBB 3.1/3.2. Fragen zur Entwicklung von Extensions und zur Konvertierung von phpBB 3.0.x MODs sind ebenfalls willkommen.
Antworten
doelle4
Mitglied
Beiträge: 66
Registriert: 05.11.2015 01:07

Ext. Link Extender - brauche Anpassung von Php 7.4 auf 8.0..

Beitrag von doelle4 »

Hallo brauche Hilfe, ich habe eine Link Extender Extension mal erstellen lassen von Tas2580 , diese lief bis Php Version 7.3
Leider muss ich nun das Forum auf neue Version umstellen und unter Php 8.0 gibt bei der Extension nur Fehler.

Kann man sowas umändern und anpassen?
Die Extension prüft eine Url im Beitrag und ergänzt den Link mit einem einstellbaren Affliliate Url Code , z.b. ?&p=J802191191640201502F
Bitte um Hilfe wenn wer mit sowas Erfahrung hat, Preis für den Aufwand handeln wird aus.

Hier die Fehlermeldung der Extension unter PHP 8.0 bei aktivieren

Code: Alles auswählen

The file "/customers/9/a/5/kopterforum.at/httpd.www/ext/tas2580/affililink/config/services.yml" does not contain valid YAML: The reserved indicator "@" cannot start a plain scalar; you need to quote the scalar at line 8 (near "- @dbal.conn").

#0 /customers/9/a/5/kopterforum.at/httpd.www/vendor/symfony/dependency-injection/Loader/YamlFileLoader.php(117): Symfony\Component\DependencyInjection\Loader\YamlFileLoader->loadFile('/customers/9/a/...')
#1 /customers/9/a/5/kopterforum.at/httpd.www/phpbb/extension/di/extension_base.php(99): Symfony\Component\DependencyInjection\Loader\YamlFileLoader->load('services.yml')
#2 /customers/9/a/5/kopterforum.at/httpd.www/phpbb/extension/di/extension_base.php(63): phpbb\extension\di\extension_base->load_services(Object(Symfony\Component\DependencyInjection\Compiler\MergeExtensionConfigurationContainerBuilder))
#3 /customers/9/a/5/kopterforum.at/httpd.www/vendor/symfony/dependency-injection/Compiler/MergeExtensionConfigurationPass.php(71): phpbb\extension\di\extension_base->load(Array, Object(Symfony\Component\DependencyInjection\Compiler\MergeExtensionConfigurationContainerBuilder))
#4 /customers/9/a/5/kopterforum.at/httpd.www/vendor/symfony/http-kernel/DependencyInjection/MergeExtensionConfigurationPass.php(39): Symfony\Component\DependencyInjection\Compiler\MergeExtensionConfigurationPass->process(Object(Symfony\Component\DependencyInjection\ContainerBuilder))
#5 /customers/9/a/5/kopterforum.at/httpd.www/vendor/symfony/dependency-injection/Compiler/Compiler.php(140): Symfony\Component\HttpKernel\DependencyInjection\MergeExtensionConfigurationPass->process(Object(Symfony\Component\DependencyInjection\ContainerBuilder))
#6 /customers/9/a/5/kopterforum.at/httpd.www/vendor/symfony/dependency-injection/ContainerBuilder.php(789): Symfony\Component\DependencyInjection\Compiler\Compiler->compile(Object(Symfony\Component\DependencyInjection\ContainerBuilder))
#7 /customers/9/a/5/kopterforum.at/httpd.www/phpbb/di/container_builder.php(223): Symfony\Component\DependencyInjection\ContainerBuilder->compile()
#8 /customers/9/a/5/kopterforum.at/httpd.www/common.php(115): phpbb\di\container_builder->get_container()
#9 /customers/9/a/5/kopterforum.at/httpd.www/adm/index.php(23): require('/customers/9/a/...')
Benutzeravatar
chris1278
Mitglied
Beiträge: 2625
Registriert: 12.11.2007 06:20
Wohnort: Euskirchen
Kontaktdaten:

Re: Ext. Link Extender - brauche Anpassung von Php 7.4 auf 8.0..

Beitrag von chris1278 »

Poste mal hier den Inhgalt der datei service.yml der extension. Diese befindet sich im verzeichniss config.
doelle4
Mitglied
Beiträge: 66
Registriert: 05.11.2015 01:07

Re: Ext. Link Extender - brauche Anpassung von Php 7.4 auf 8.0..

Beitrag von doelle4 »

Danke für deine Antwort ,ist echt prima nicht allein dazustehen..

Service.yml

Code: Alles auswählen

parameters:
    tables.affililink.url: %core.table_prefix%affililink_url

services:
    tas2580.affililink.listener:
        class: tas2580\affililink\event\listener
        arguments:
            - @dbal.conn
            - %tables.affililink.url%
        tags:
            - { name: event.listener }
doelle4
Mitglied
Beiträge: 66
Registriert: 05.11.2015 01:07

Re: Ext. Link Extender - brauche Anpassung von Php 7.4 auf 8.0..

Beitrag von doelle4 »

Die definierten Linkzusätze sind in Eingabefeldern zum eingeben mit dem Schema:Prüf Url , Link Zusatz , und Zusatz vor oder nach Url drannhängen.
Werden in der Datenbank gespeichert und bei Bedarf passend ausgelesen und zugefügt.
Lg Hans
Zuletzt geändert von doelle4 am 25.11.2021 22:44, insgesamt 1-mal geändert.
Benutzeravatar
chris1278
Mitglied
Beiträge: 2625
Registriert: 12.11.2007 06:20
Wohnort: Euskirchen
Kontaktdaten:

Re: Ext. Link Extender - brauche Anpassung von Php 7.4 auf 8.0..

Beitrag von chris1278 »

Ersetze mal den Inhgalt der service.yml mit diesem hier:

Code: Alles auswählen

parameters:
    tables.affililink.url: '%core.table_prefix%affililink_url'

services:
    tas2580.affililink.listener:
        class: tas2580\affililink\event\listener
        arguments:
            - '@dbal.conn'
            - '%tables.affililink.url%'
        tags:
            - { name: event.listener }
doelle4
Mitglied
Beiträge: 66
Registriert: 05.11.2015 01:07

Re: Ext. Link Extender - brauche Anpassung von Php 7.4 auf 8.0..

Beitrag von doelle4 »

Ich kann dir gar nicht sagen wie glücklich ich bin, es funktioniert !!! :D :D :D
Hab schon überlegt alles einzumotten als der Zwang zu php 8.0 kam , aber nun ist mir wieder viel leichter das wieder Licht für den Fortbestand da ist.
Was bin ich Schuldig? Du hast mir viel geholfen...
Lg Hans
Benutzeravatar
chris1278
Mitglied
Beiträge: 2625
Registriert: 12.11.2007 06:20
Wohnort: Euskirchen
Kontaktdaten:

Re: Ext. Link Extender - brauche Anpassung von Php 7.4 auf 8.0..

Beitrag von chris1278 »

Also lass mich das so sagen, dein Problem bestand nicht wegen der php Version. Das lag daran das sich die Verarbeitung von .yml Dateien geändert haben. Ob die Ext. mit php8 oder später noch geht kann ich dir nicht sagen. Dazu müssten dann aber beizeiten andere Fehlermeldungen auftauchen.

PS: Du bist mir gar nichts schuldig. Wenn du hier im Forum nach does not contain valid YAML: oder ähnlichem gesucht hättest, wärst du wahrscheinlich auch irgendwann selbst drauf gekommen.
doelle4
Mitglied
Beiträge: 66
Registriert: 05.11.2015 01:07

Re: Ext. Link Extender - brauche Anpassung von Php 7.4 auf 8.0..

Beitrag von doelle4 »

Danke vielmals !! Toll
Könnte man auch mit so einer Modifikation auch die Tas2580 Usermap unter der neuest Phpbb Version beleben?
Sieht danach aus..

https://tas2580.net/downloads/phpbb-usermap/

Code: Alles auswählen

Beim Aufbau des Containers durch phpBB ist wegen einer installierten Erweiterung ein Fehler aufgetreten. Aus diesem Grund wurden alle Erweiterungen vorrübergehend deaktiviert. Bitte versuche das Problem zu beheben, in dem du den Cache des Boards leerst. Alle Erweiterungen werden automatisch wieder aktiviert, sobald der Container-Fehler behoben ist. Wenn das Problem dauerhaft auftritt, besuche bitte phpBB.com (englisch) für Support (deutschsprachiger Support auf phpBB.de).


Fehler: The file "/customers/9/a/5/kopterforum.at/httpd.www/ext/tas2580/usermap/config/services.yml" does not contain valid YAML: The reserved indicator "@" cannot start a plain scalar; you need to quote the scalar at line 10 (near "- @auth").

#0 /customers/9/a/5/kopterforum.at/httpd.www/vendor/symfony/dependency-injection/Loader/YamlFileLoader.php(117): Symfony\Component\DependencyInjection\Loader\YamlFileLoader->loadFile('/customers/9/a/...')
#1 /customers/9/a/5/kopterforum.at/httpd.www/phpbb/extension/di/extension_base.php(99): Symfony\Component\DependencyInjection\Loader\YamlFileLoader->load('services.yml')
#2 /customers/9/a/5/kopterforum.at/httpd.www/phpbb/extension/di/extension_base.php(63): phpbb\extension\di\extension_base->load_services(Object(Symfony\Component\DependencyInjection\Compiler\MergeExtensionConfigurationContainerBuilder))
#3 /customers/9/a/5/kopterforum.at/httpd.www/vendor/symfony/dependency-injection/Compiler/MergeExtensionConfigurationPass.php(71): phpbb\extension\di\extension_base->load(Array, Object(Symfony\Component\DependencyInjection\Compiler\MergeExtensionConfigurationContainerBuilder))
#4 /customers/9/a/5/kopterforum.at/httpd.www/vendor/symfony/http-kernel/DependencyInjection/MergeExtensionConfigurationPass.php(39): Symfony\Component\DependencyInjection\Compiler\MergeExtensionConfigurationPass->process(Object(Symfony\Component\DependencyInjection\ContainerBuilder))
#5 /customers/9/a/5/kopterforum.at/httpd.www/vendor/symfony/dependency-injection/Compiler/Compiler.php(140): Symfony\Component\HttpKernel\DependencyInjection\MergeExtensionConfigurationPass->process(Object(Symfony\Component\DependencyInjection\ContainerBuilder))
#6 /customers/9/a/5/kopterforum.at/httpd.www/vendor/symfony/dependency-injection/ContainerBuilder.php(789): Symfony\Component\DependencyInjection\Compiler\Compiler->compile(Object(Symfony\Component\DependencyInjection\ContainerBuilder))
#7 /customers/9/a/5/kopterforum.at/httpd.www/phpbb/di/container_builder.php(223): Symfony\Component\DependencyInjection\ContainerBuilder->compile()
#8 /customers/9/a/5/kopterforum.at/httpd.www/common.php(115): phpbb\di\container_builder->get_container()
#9 /customers/9/a/5/kopterforum.at/httpd.www/adm/index.php(23): require('/customers/9/a/...')
#10 {main}

Ist wohl selbes Problem oder?
Benutzeravatar
chris1278
Mitglied
Beiträge: 2625
Registriert: 12.11.2007 06:20
Wohnort: Euskirchen
Kontaktdaten:

Re: Ext. Link Extender - brauche Anpassung von Php 7.4 auf 8.0..

Beitrag von chris1278 »

Nun ja möglich. Wenn es nur die .yml datei ist.


Schau dir das an was ich dir geschikt habe dann solltest du das nachvolziehen was ich geändert habe. es fehlen lediglich die Hochkommas '.
doelle4
Mitglied
Beiträge: 66
Registriert: 05.11.2015 01:07

Re: Ext. Link Extender - brauche Anpassung von Php 7.4 auf 8.0..

Beitrag von doelle4 »

Habe damit nun inkompatible yml Files umändern können damit 2 andere Extensions auch laufen.
War ein guter Tipp. Danke nochmals.
Lg Hans
Antworten

Zurück zu „Extension Bastelstube“