[3.2] keine E-Mail Funktion

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.1.x und höher und die Konvertierung zu phpBB 3.2.x.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.1.x] oder [3.2.x] angeben.
Benutzeravatar
sepp71
Mitglied
Beiträge: 860
Registriert: 23.12.2006 00:03

Re: [3.2] keine E-Mail Funktion

Beitragvon sepp71 » 10.12.2018 22:40

Hallo Canonknipser,

danke für die schnelle Antwort!
Ich habe es probiert - immerhin variiert jetzt die Fehlermeldung, aber es will noch nicht. Die geänderten SMTP-Daten (neu ionos statt früher 1und1.de) habe ich aus der Dokumentation von 1&1, die sich ja jetzt Ionos nennen
1.
E-Mail-Fehler
» EMAIL/SMTP
/adm/index.php

Verbindung zum SMTP-Server kann nicht hergestellt werden: 0 : .

Errno 2: stream_socket_client(): SSL operation failed with code 1. OpenSSL Error messages:
error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number at [ROOT]/includes/functions_messenger.php line 1188<br />
Errno 2: stream_socket_client(): Failed to enable crypto at [ROOT]/includes/functions_messenger.php line 1188<br />
Errno 2: stream_socket_client(): unable to connect to tls://smtp.ionos.de:25 (Unknown error) at [ROOT]/includes/functions_messenger.php line 1188

2.
10.12.2018, 22:36 E-Mail-Fehler
» EMAIL/SMTP
/adm/index.php

Verbindung zum SMTP-Server kann nicht hergestellt werden: 110 : Connection timed out.

Errno 2: stream_socket_client(): unable to connect to tls://smtp.ionos.de:587 (Connection timed out) at [ROOT]/includes/functions_messenger.php line 1188

Port 25 aus dem ersten Versuch wird von Ionos/1&1 nicht empfohlen, in deren Hilfe steht immer nur 587 (was aber auch nicht geht...)

Das Passwort habe ich in der DB nachgesehen, es steht korrekt drin.
Sepp

Edit 22:46 h:
Ich hatte noch eine falsche Fehlermeldung kopiert. Die aktuellere (mit SSL statt TLS und empfohlenem Port) ist:
E-Mail-Fehler
» EMAIL/SMTP
/adm/index.php

Verbindung zum SMTP-Server kann nicht hergestellt werden: 110 : Connection timed out.

Errno 2: stream_socket_client(): unable to connect to ssl://smtp.1und1.de:587 (Connection timed out) at [ROOT]/includes/functions_messenger.php line 1188

Edit 23:13:
Ich habe noch diverse weitere Kombinationen ausprobiert, die Fehlermeldung bleibt aber im Kern "Connection timed out". Ich habe den Verdacht, dass 1&1 bzw. Ionos den Zugriff vom Webspace auf das SMTP-Konto einfach gar nicht erlaubt.
Oder hat das schon jemand auf 1&1 Webspace / mit1&1 E-Mail-Account zum Laufen bekommen?
phpBB 3.2.4 mit About us, Advertisement Management, Delete my registration, Precise Similar Topics, Privacy protection, Recent Topics, Thanks for posts

Benutzeravatar
sepp71
Mitglied
Beiträge: 860
Registriert: 23.12.2006 00:03

Gelöst: [3.2] keine E-Mail Funktion bei 1&1 ionos?!

Beitragvon sepp71 » 17.12.2018 20:13

So, nach einer Anfrage beim Support von 1&1 (jetzt IONOS) habe ich eine Antwort bekommen, mit der mir der Versand einer Test-E-Mail via SMTP gelungen ist.
Falls das hier noch andere interessiert, bei mir hat es mit folgenden Angaben geklappt:

Größe von E-Mail-Paketen: 0
SMTP-Server für E-Mail nutzen: JA
SMTP-Server-Adresse und -Protokoll: smtp.ionos.de (keine weitere Angabe!)
SMTP-Server-Port: 25 (laut Ionos der einzige unterstützte Port)
Authentifizierungsmethode für SMTP: PLAIN
SMTP-Benutzername: deinemailadresse@deinedomain.de
SMTP-Passwort: deinpasswort [ich habe es vorsichtshalber mal auf 8 Zeichen, ohne Sonderzeichen begrenzt, weil das später im Formular auch angezeigt wird, alles andere nicht geprüft)
Die drei weiteren Angaben alle NEIN.

Anschließend Formular absenden nicht vergessen!
Zum Versand der Testmail nicht über den Button auf dieser Einstellungsseite, sondern über System / Massen-E-Mail und dann den zum Testen gewünschten Usernamen, Betreff und Mailtext eintragen, Formular abschicken.
Mit den o.a. Angaben war hier das Ergebnisfeld dann auch grün unterlegt (E-Mail wurde versandt).

Viel Erfolg - und Canonknipser nochmal herzlichen Dank für Deine Bemühungen!

Sepp
phpBB 3.2.4 mit About us, Advertisement Management, Delete my registration, Precise Similar Topics, Privacy protection, Recent Topics, Thanks for posts

Thomas W.
Mitglied
Beiträge: 116
Registriert: 01.01.2006 22:32
Kontaktdaten:

Bedankt [3.2] keine E-Mail Funktion

Beitragvon Thomas W. » 13.01.2019 22:39

@ Sepp71 und Canonknipser

Danke danke danke.... :grin:

Das habe ich gefühlte 3 Jahre in einem Forum hinter einer Fritzbox nicht zum laufen gebracht, jetzt geht es endlich

Gruß
Thomas


Zurück zu „Support-Forum“