[3.2] [3.2.3] Login wird nicht richtig gespeichert

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.1.x und höher und die Konvertierung zu phpBB 3.2.x.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.1.x] oder [3.2.x] angeben.
Benutzeravatar
Doppelvergaser_2
Mitglied
Beiträge: 43
Registriert: 20.04.2017 09:02
Wohnort: nähe Hannover
Kontaktdaten:

[3.2] [3.2.3] Login wird nicht richtig gespeichert

Beitragvon Doppelvergaser_2 » 09.11.2018 20:19

Bin mir nicht ganz im Klaren, woran das liegen kann.

Im ACP ist eingestellt, dass die Sitzungen niemals ablaufen. Demnach müsste ein gespeicherter Login so lange bestehen bleiben, bis die Sitzungsdaten im ACP oder bei den Benutzern der Browserverlauf nebst gespeicherten Logins gelöscht werden. Oder sehe ich das falsch?

Bei den Benutzern und auch bei mir sind aber ganz unterschiedliche Login-Dauern festzustellen. Manchmal werden User nach dem zweiten Klick rausgeworfen, manchmal auch erheblich später. Der eine meint, am PC hat er keine Probleme, am Handy aber schon.
Buch selber benutze ein iPad mini, mit iOS 9.3.irgendwas. Morgens im Zug zur Arbeit bin ich im Forum, abends auf dem Heimweg ist der Login manchmal noch da, manchmal ist er weg.

Habe über die Suche schon mal was zu Cookies gefunden, und die Cookie-Einstellungen entsprechend neu gemacht, damit jeder User auch neue Cookies bekommt.

Das Forum läuft über SSL, auch die Einstellungen musste ich nach Tipps von hier anpassen. Es ist auch besser geworden, aber noch nicht gut.

Was könnt ihr mir empfehlen, was für Infos braucht ihr noch?

Danke.

Benutzeravatar
canonknipser
Supporter
Supporter
Beiträge: 1641
Registriert: 10.09.2011 11:14
Kontaktdaten:

Re: [3.2] [3.2.3] Login wird nicht richtig gespeichert

Beitragvon canonknipser » 09.11.2018 21:08

Wie ist deine IP-Überprüfung im ACP eingestellt?
Mobile Datennutzung bedeutet oft einen häufigen IP-Wechsel., also eventuell die IP-Prüfung ein wenig abschwächen:
Screenshot_20181109_210452.png

Ggf. auch die Browserprüfung deaktivieren, aber das muss normalerweise nicht sein.
Grüße, canonknipser
"there are only 10 types of people: those, who understand binary and those, who don't"
just arrived ;) - Bilder
Kein Support via PN, nur im Board und (manchmal) im IRC

Benutzeravatar
Doppelvergaser_2
Mitglied
Beiträge: 43
Registriert: 20.04.2017 09:02
Wohnort: nähe Hannover
Kontaktdaten:

Re: [3.2] [3.2.3] Login wird nicht richtig gespeichert

Beitragvon Doppelvergaser_2 » 09.11.2018 22:36

Ah... Okay. Danke.

Es war auf ABC gestellt, habe jetzt AB genommen.

Ich werde berichten. :wink:

Benutzeravatar
Doppelvergaser_2
Mitglied
Beiträge: 43
Registriert: 20.04.2017 09:02
Wohnort: nähe Hannover
Kontaktdaten:

Re: [3.2] [3.2.3] Login wird nicht richtig gespeichert

Beitragvon Doppelvergaser_2 » 10.11.2018 17:43

Hm. Leider keine Verbesserung.

Was ist die Browserprüfung? Was macht die, und warum kann das zu Problemen führen?

Benutzeravatar
Doppelvergaser_2
Mitglied
Beiträge: 43
Registriert: 20.04.2017 09:02
Wohnort: nähe Hannover
Kontaktdaten:

Re: [3.2] [3.2.3] Login wird nicht richtig gespeicher

Beitragvon Doppelvergaser_2 » 14.11.2018 05:20

So. Weiter geht's:

Die Browserüberprüfung ist auch abgestellt. Ein User sagt, ist besser, der nächste sagt, dass sich nix geändert hat.

Weitere Ideen?

Ich könnte mir vorstellen, dass es was mit der SSL zu tun haben muss, denn mein Testforum läuft nicht über SSL und da lüpft es einwandfrei. Es sind aber die selben Daten, nur mit einer etwas älteren Datenbank.

Benutzeravatar
chris1278
Mitglied
Beiträge: 1092
Registriert: 12.11.2007 06:20
Kontaktdaten:

Re: [3.2] [3.2.3] Login wird nicht richtig gespeichert

Beitragvon chris1278 » 14.11.2018 07:00

Ist das portal aktiv bei dir?

Benutzeravatar
Dr.Death
Moderator
Moderator
Beiträge: 15449
Registriert: 23.04.2003 08:22
Wohnort: Xanten
Kontaktdaten:

Re: [3.2] [3.2.3] Login wird nicht richtig gespeichert

Beitragvon Dr.Death » 14.11.2018 07:18

Überprüfung der IP auf "keine" setzen.

Benutzeravatar
Doppelvergaser_2
Mitglied
Beiträge: 43
Registriert: 20.04.2017 09:02
Wohnort: nähe Hannover
Kontaktdaten:

Re: [3.2] [3.2.3] Login wird nicht richtig gespeichert

Beitragvon Doppelvergaser_2 » 14.11.2018 14:39

chris1278 hat geschrieben:Ist das portal aktiv bei dir?

Nein. Nicht mal installiert.


Dr.Death hat geschrieben:Überprüfung der IP auf "keine" setzen.

Ok. Ich melde mich.

Benutzeravatar
Doppelvergaser_2
Mitglied
Beiträge: 43
Registriert: 20.04.2017 09:02
Wohnort: nähe Hannover
Kontaktdaten:

Re: [3.2] [3.2.3] Login wird nicht richtig gespeichert

Beitragvon Doppelvergaser_2 » 15.11.2018 21:44

So. Auch ohne IP-Prüfung keine wirkliche Besserung. :(

Benutzeravatar
canonknipser
Supporter
Supporter
Beiträge: 1641
Registriert: 10.09.2011 11:14
Kontaktdaten:

Re: [3.2] [3.2.3] Login wird nicht richtig gespeichert

Beitragvon canonknipser » 15.11.2018 22:23

Hmmm, dann poste doch mal einen Screenshot deiner Sicherheits-Einstellungen

Edit: Deine Seite wird über die alten Links, die ich in deinem Bord gefunden habe (.de resp. -forum.de) auf deine .com umgeleitet, aber als http und nicht als https. Dann passen natülich die secure-Cookies nicht. Also musst du http-Aufrufe auf https umleiten
Grüße, canonknipser
"there are only 10 types of people: those, who understand binary and those, who don't"
just arrived ;) - Bilder
Kein Support via PN, nur im Board und (manchmal) im IRC


Zurück zu „Support-Forum“