[3.2] Fehlermeldung nach Update

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.1.x und höher und die Konvertierung zu phpBB 3.2.x.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.1.x] oder [3.2.x] angeben.
wakeme
Mitglied
Beiträge: 22
Registriert: 20.12.2017 23:47

[3.2] Fehlermeldung nach Update

Beitragvon wakeme » 10.11.2018 23:06

Das Problem wurde soweit gelöst.

Wenn ich in auf meiner Seite ein bestimmtes Forum anklicke, erscheint diese Fehlermeldung ;

Code: Alles auswählen

SQL ERROR [ mysqli ]

[0]

SQL

No values specified for SQL IN comparison

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 997
CALL: trigger_error()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 547
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/phpbb/db/driver/factory.php
LINE: 441
CALL: phpbb\db\driver\driver->sql_in_set()

FILE: [ROOT]/ext/amalfra/topicprefixes/event/listener.php
LINE: 295
CALL: phpbb\db\driver\factory->sql_in_set()

FILE: (not given by php)
LINE: (not given by php)
CALL: amalfra\topicprefixes\event\listener->viewforum_modify_topics_data()

FILE: [ROOT]/vendor/symfony/event-dispatcher/EventDispatcher.php
LINE: 184
CALL: call_user_func()

FILE: [ROOT]/vendor/symfony/event-dispatcher/EventDispatcher.php
LINE: 46
CALL: Symfony\Component\EventDispatcher\EventDispatcher->doDispatch()

FILE: [ROOT]/phpbb/event/dispatcher.php
LINE: 62
CALL: Symfony\Component\EventDispatcher\EventDispatcher->dispatch()

FILE: [ROOT]/phpbb/event/dispatcher.php
LINE: 46
CALL: phpbb\event\dispatcher->dispatch()

FILE: [ROOT]/viewforum.php
LINE: 809
CALL: phpbb\event\dispatcher->trigger_event()


Manchmal auch ;

Code: Alles auswählen

Allgemeiner Fehler
SQL ERROR [ mysqli ]

[0]



Wie kann ich das beheben ?
Zuletzt geändert von wakeme am 11.11.2018 19:21, insgesamt 1-mal geändert.

Benutzeravatar
vfrblue
Junior Supporter
Beiträge: 1250
Registriert: 22.11.2016 18:46
Wohnort: Niedersachsen-West
Kontaktdaten:

Re: [3.2] Fehlermeldung nach Update

Beitragvon vfrblue » 11.11.2018 00:33

Von welcher phpBB-Version hast du denn das Update ausgeführt und auf welche Version hast du aktualisiert? Nach welcher Methode bist du vorgegangen? Welche Erweiterungen hast du installiert? Welche PHP-Version verwendest du?
Wie du siehst fehlen einige Informationen. Ein Link zu deinem Forum wäre auch hilfreich.
Gruß Hermann

Forum VFR-OC

wakeme
Mitglied
Beiträge: 22
Registriert: 20.12.2017 23:47

Re: [3.2] Fehlermeldung nach Update

Beitragvon wakeme » 11.11.2018 01:31

von 3.2.2 auf 3.2.3, manuell :)

ext ;

Advertisement Management
Ajax Shoutbox
Board Announcements
Collapsible Forum Categories
Google Analytics
phpBB Topic Prefixes
Ravaio Configuration
s9e/mediaembed
Zuletzt geändert von wakeme am 11.11.2018 19:15, insgesamt 1-mal geändert.

Benutzeravatar
Kirk
Supporter
Supporter
Beiträge: 5926
Registriert: 24.05.2010 08:31
Kontaktdaten:

[3.2] Fehlermeldung nach Update

Beitragvon Kirk » 11.11.2018 08:27

@wakeme

  • Weist ein von dir im Beitrag, im Weblink oder in der Signatur verlinktes Forum kein phpBB Copyright auf, erhältst du auf phpBB.de keinerlei Support.
    Bitte ändere dein Thema entsprechend ab, lies die Knigge und beachte sie in Zukunft.

Mit freundlichen Grüßen,
dein phpBB.de-Team

wakeme
Mitglied
Beiträge: 22
Registriert: 20.12.2017 23:47

Re: [3.2] Fehlermeldung nach Update

Beitragvon wakeme » 11.11.2018 14:12

Normalerweise habe ich die Erweiterung “Systeminformationen“ installiert. Aufgrund der Fehlermeldung habe ich jedoch darauf verzichtet vorerst weitere Erweiterungen aufzuspielen.
Die oben genannten Erweiterungen sind diejenigen die nach dem Update installiert wurden.

Ich habe das Copyright hinzufügt.
Trotzdem würde ich darum bitten mir bei dem Fehler zu helfen. Vor dem Update hat nämlich alles funktioniert.
Zuletzt geändert von wakeme am 11.11.2018 19:35, insgesamt 1-mal geändert.

Benutzeravatar
vfrblue
Junior Supporter
Beiträge: 1250
Registriert: 22.11.2016 18:46
Wohnort: Niedersachsen-West
Kontaktdaten:

Re: [3.2] Fehlermeldung nach Update

Beitragvon vfrblue » 11.11.2018 14:38

Tritt der Fehler auch auf, wenn du "prosilver" aktiviert hast?
Gruß Hermann

Forum VFR-OC

Benutzeravatar
Joyce&Luna
Mitglied
Beiträge: 2009
Registriert: 24.11.2013 18:14
Wohnort: NRW
Kontaktdaten:

Re: [3.2] Fehlermeldung nach Update

Beitragvon Joyce&Luna » 11.11.2018 15:16

Das kann an der Extension topicprefixes liegen, deaktiviere diese mal.
Leere auch Cache.
phpBB-Style-Design.de

Keine Antwort ist die eindeutigste Antwort, die man kriegen kann.
Bitte stellt die Fragen im Forum und nicht per PN. Danke!

wakeme
Mitglied
Beiträge: 22
Registriert: 20.12.2017 23:47

Re: [3.2] Fehlermeldung nach Update

Beitragvon wakeme » 11.11.2018 16:24

Tatsächlich, es liegt an der Erweiterung topicprefixes.
Dabei handelt es sich um eine erweiterte Version, welche neue Funktionen beinhaltet.

Normalerweise funktioniert sie gut. Komischerweise tritt dieser Fehler nur in dem Forum auf in welcher noch keinerlei Beiträge vorhanden sind.
In allen anderen Bereichen funktioniert sie problemlos.
Zuletzt geändert von wakeme am 11.11.2018 19:15, insgesamt 1-mal geändert.

Benutzeravatar
Mahony
Ehemaliger
Beiträge: 11526
Registriert: 17.11.2005 22:33
Wohnort: Esslingen (Neckar)
Kontaktdaten:

Re: [3.2] Fehlermeldung nach Update

Beitragvon Mahony » 11.11.2018 18:57

Hallo
Hast du mal bitte einen Link zu der Extension?

Grüße: Mahony
Taekwondo in Berlin
Wer fragt, ist ein Narr für fünf Minuten, wer nicht fragt, ist ein Narr für immer.

wakeme
Mitglied
Beiträge: 22
Registriert: 20.12.2017 23:47

Re: [3.2] Fehlermeldung nach Update

Beitragvon wakeme » 11.11.2018 19:19

Vielen Dank für eure Antworten :)
Mitterweile habe ich den Fehler anderweitig lösen können.

Es gibt keinen Link, da es sich um eine eigene Modifizierung handelt.
Auf Basis der Erweiterung topicprefixes von VSEphpbb.

https://github.com/phpbb-extensions/topicprefixes


Zurück zu „Support-Forum“