[3.2] Forumsurl in Boardnachrichten korrekt angeben

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.1.x und höher und die Konvertierung zu phpBB 3.2.x.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.1.x] oder [3.2.x] angeben.
MDuss
Mitglied
Beiträge: 215
Registriert: 06.02.2008 10:21

Re: [3.2] Forumsurl in Boardnachrichten korrekt angeben

Beitragvon MDuss » 14.01.2019 08:16

HI Nochmal.

Also das mit dem weglassen von www. bei dem Cookie hat aber einen sehr unangenehmen Nebeneffekt.

Wenn ich als Cookie-Domain eingebe .deineurl.de
dann hat das folgenden Effekt.
Wenn ich meine Webseite jetzt mit https://www.deineurl.de/forum/ aufrufe, dann kann ich zwar meine Login Daten eingeben, aber ich bin dennoch nicht eingeloggt.
Also ich gebe meine Login Daten ein, bestätige diese, und ich bin wieder auf der Startseite des Forums aber dennoch NICHT eingeloggt.

Wenn ich über https://deineurl.de/forum/ auf das Forum gehe, und meine Login Daten eingebe, dann werde ich ganz normal eingeloggt ohne Probleme.

Umgekehrt, wenn ich als Cookie-Domain http://www.deineurl.de eingebe, dann kann ich mich ganz normal einloggen und bleibe auch eingeloggt wenn ich als URL https://www.deineurl.de/forum/ verwende.
Wenn ich aber jetzt über https://deineurl.de/forum/ auf mein Forum gehe und meine Daten eingebe, dann werde ich wiederum nicht eingeloggt.

Einer meiner User hatte auch mal dieses Problem. Zu diesem Zeitpunkt war als Cookie-Domain http://www.deineurl.de eingetragen.
Er hatte aber einen Link ohne www. vor der URL verwenden, wahrscheinlich aus einer solchen Boardnachricht.
Somit konnte er sich auch nicht mehr einloggen analog zu dem obigen Fall.
Erst als ich ihm den Hinweis gab, das www. vor die URL zu setzen hatte es wieder funktioniert mit dem einloggen.

Ich hatte gestern mal in meinem Testforum die Cookie-Domain auf .deineurl.de geändert und mir selbst eine PM geschickt. In der Bordnachricht war die URL jetzt korrekt mit www. davor.
Aber das nutzt mich wenig, wenn ich das so lasse, denn wenn ich die Cookie-Domain auf .deineurl.de einstelle und die Boardnachricht erstellt eine URL mit www. davor, kann mich aber nicht einloggen.

Und umgekehrt, wenn ich die Cookie-Domain auf http://www.deineurl.de einstelle, bekomme ich eine URL ohne www. davor und kann mich auch nicht einloggen.

Daher ja meine Frage, wie ich das einstellen muss, damit die Boardnachricht Links mit dem www. vor der URL enthält. Oder könnte ich durch Manipulation der Sprachdateiten das www. manuell in den String eintragen, und wenn ja, welche der Sprachdateien muss ich wie bearbeiten?

MfG
MDuss
Zuletzt geändert von MDuss am 14.01.2019 08:27, insgesamt 2-mal geändert.

Benutzeravatar
Dr.Death
Moderator
Moderator
Beiträge: 15531
Registriert: 23.04.2003 08:22
Wohnort: Xanten
Kontaktdaten:

Re: [3.2] Forumsurl in Boardnachrichten korrekt angeben

Beitragvon Dr.Death » 14.01.2019 08:18

Naja, dir muss man ggf. alle Würmer einzeln aus der Nase ziehen....

Du hattest vorher ja auch nicht erwähnt, das dein Forum unterhalb der Domain betrieben wird.

Wie wäre es, wenn Du mal dein realen Link zu deinem Forum posten würdest ?

MDuss
Mitglied
Beiträge: 215
Registriert: 06.02.2008 10:21

Re: [3.2] Forumsurl in Boardnachrichten korrekt angeben

Beitragvon MDuss » 14.01.2019 08:29

Bitte entschuldige, ich dachte das dieser Umstand nicht so wichtig wäre.

Die komplette URL zu dem Forum lautet:

https:// www . nudefix . de / forum /

Es ist halt nur so, dass sich diese Seite mit Nudepatches beschäftigt, und nicht jedes andere Forum unter umständen solche Links mag, daher habe ich halt nicht die echte URL hier angegeben, sorry. Wollte unnötigen ärger vermeiden.

MFG
MDuss
Zuletzt geändert von Dr.Death am 14.01.2019 09:14, insgesamt 1-mal geändert.
Grund: Link für Suchmaschinen entschärft - Dr.Death

Benutzeravatar
Dr.Death
Moderator
Moderator
Beiträge: 15531
Registriert: 23.04.2003 08:22
Wohnort: Xanten
Kontaktdaten:

Re: [3.2] Forumsurl in Boardnachrichten korrekt angeben

Beitragvon Dr.Death » 14.01.2019 09:19

Deine Server Einstellungen lauten also:



Server-Protokoll: https://
Domain-Name: www . nudefix . de
Scriptpfad: /forum

Cookie-Domain: . nudefix . de
Cookie Pfad: /
Sicherer Server: aktivert

MDuss
Mitglied
Beiträge: 215
Registriert: 06.02.2008 10:21

Re: [3.2] Forumsurl in Boardnachrichten korrekt angeben

Beitragvon MDuss » 14.01.2019 09:32

Hi Dr.Death.

Aktuell sieht es bei mir so aus:

Server und Domain:
Erzwinge Server-URL-Einstellungen: Nein
Server-Protokoll: https://
Domain-Name: www . nudefix . de
Server-Port: 443
Scriptpfad: /forum

Cookies:
Cookie-Domain: www .nudefix . de (www. deshalb, da ich mich ansonsten mit www. in der URL ja nicht anmelden kann, aber dann fehlt mir das www. in den Bordnachrichten mit den oben erwähnten Problem mit dem Login.)
Cookie-Name: phpbb3_bfof6
Cookie-Pfad: /
Sicherer Server: aktiviert
Cookie-Hinweis: deaktiviert

Das heißt der einzige Unterschied zwischen deinen und meinen Angaben ist das www. bei der Cookie-Domain. Aber mit dem hab ich ja meine liebe Müh und Not.

MfG
MDuss

Benutzeravatar
vfrblue
Junior Supporter
Beiträge: 1379
Registriert: 22.11.2016 18:46
Wohnort: Niedersachsen-West
Kontaktdaten:

Re: [3.2] Forumsurl in Boardnachrichten korrekt angeben

Beitragvon vfrblue » 14.01.2019 16:38

Nimm die vorgeschlagenen Einstellungen von Dr.Death und ändere den Cookie-Namen zusätzlich (z.B. die "6" in "a"). Dadurch werden für alle User neue Cookies gesetzt und die Einstellungen, die in den "alten" Cookies hinterlegt sind, unwirksam.
Dazu noch den Foren- und Browser-Cache leeren.
Gruß Hermann

Forum VFR-OC

MDuss
Mitglied
Beiträge: 215
Registriert: 06.02.2008 10:21

Re: [3.2] Forumsurl in Boardnachrichten korrekt angeben

Beitragvon MDuss » 15.01.2019 07:51

Hi vfrblue und Dr.Death

Habe jetzt die Einstellungen nochmal geändert und im Browser getestet.
Jetzt scheint es zu funktionieren mit dem Login und dem eingeloggt bleiben, egal ob ich das www. vor die Adresse setzte oder nicht.

Mal schauen, wie es dann in den Bordnachrichten ausschaut. Habe mal mit einem Testaccount eine PM an mich geschickt, müsste dann ja bald ne Email bekommen dass ich Post im Forum habe.
Da sollte ja dann die URL mit www. davor drinnen sein.

MfG
MDuss

MDuss
Mitglied
Beiträge: 215
Registriert: 06.02.2008 10:21

Re: [3.2] Forumsurl in Boardnachrichten korrekt angeben

Beitragvon MDuss » 15.01.2019 12:20

HI.

Wollte nur mal kurz bescheid geben, wie es ausschaut.
Also im Moment scheint das mit dem www. in der URl der Forumsnachricht wieder richtig zu laufen.
Mal schauen, ob es so bleibt.

MfG
MDuss


Zurück zu „Support-Forum“