SSL mit lets encrypt...

Der Offtopic-Treff auf phpBB.de - Hier ist (unter Beachtung des phpBB.de-Knigges) fast alles erlaubt :-)
Benutzeravatar
yks
Mitglied
Beiträge: 1291
Registriert: 10.07.2004 02:31

Re: SSL mit lets encrypt...

Beitragvon yks » 05.02.2019 23:57

Danke dir Mahony !

Umso mehr, da ich dich verstehe, dass du mein Herumeiern nicht verstehst - genau das dachte ich heute Mittag nämlich auch: dass sich hier sicher manche wundern, warum ich es nicht schon längst habe...
Es gibt einfach bestimmte Dinge, die mich sehr verunsichern, wo mir das Vertrauen in zB eine fremde Seite und Angaben etc fehlt, weil ich zu wenig verstehe, wie es richtig sein muss und nicht mal weiß, ob ich merken würde, wenn ich einen großen Fehler mache. (Abgesehen davon war ich schlicht und einfach krank und kam auch deswegen mit vielem nicht weiter.)
Aber mit euren Antworten bin ich nun optimistisch, dass ich es noch hinbekomme und ohne dass etwas dabei ganz schief läuft ;)
Ihr werdet den Freudenschrei dann auch lesen *versprochen !

Viele Grüße
yks
Mit subsilver2 macht es noch viel mehr Spaß ! :)

Benutzeravatar
yks
Mitglied
Beiträge: 1291
Registriert: 10.07.2004 02:31

Re: SSL mit lets encrypt...

Beitragvon yks » 06.02.2019 01:02

3/4 HEUREKA ! :))

dennoch Fragen:
Kann ich die 2 Dateien in dem Verzeichnis webroot/.well-known/acme-challenge/ mitsamt diesem Verzeichnis wieder entfernen ? Denke, sie dienten ja nur der Verifizierung, oder ?

Die Änderungen in den Foren nach dem Link phpBB richtig auf HTTPS umstellen sind mir zwar klar, nur frage ich mich, WANN ich sie vornehme damit die Änderungen übernommen werden: ob vor oder nach dem SSL-Zertifikat hochladen.
Vorher ist das Forum dann nicht mehr erreichbar und nachher doch auch nicht ?

Die .htaccess-Datei im webroot mit dem Inhalt:

Code: Alles auswählen

RewriteEngine On
RewriteCond %{HTTPS} !on
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}

muss prinzipiell nicht mehr beinhalten, oder ?
(Habe noch andere htaccess in Verzeichnissen, evtl muss ich da noch mal nachhaken)

Viele Grüße
yks
Mit subsilver2 macht es noch viel mehr Spaß ! :)

Benutzeravatar
yks
Mitglied
Beiträge: 1291
Registriert: 10.07.2004 02:31

Re: SSL mit lets encrypt...

Beitragvon yks » 07.02.2019 19:21

Die htaccess ist anscheinend falsch, lenkt jedenfalls nicht um.
Der Aufruf würde auch weiter über http funktionieren.
Mit subsilver2 macht es noch viel mehr Spaß ! :)

MeinBenutzername
Mitglied
Beiträge: 143
Registriert: 04.08.2016 19:32

Re: SSL mit lets encrypt...

Beitragvon MeinBenutzername » 11.04.2019 22:51

Hat dein Hoster kein CPanel im Einsatz?

Benutzeravatar
vfrblue
Junior Supporter
Beiträge: 1452
Registriert: 22.11.2016 18:46
Wohnort: Niedersachsen-West
Kontaktdaten:

Re: SSL mit lets encrypt...

Beitragvon vfrblue » 12.04.2019 14:31

Versuche es mal hiermit:

Code: Alles auswählen

RewriteEngine On
RewriteCond %{SERVER_PORT} !^443$
RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
Gruß Hermann

Forum VFR-OC


Zurück zu „Smalltalk“