[3.1] Probleme bei der Neuinstallation von PHPBB3.1.2

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.1.x und höher und die Konvertierung zu phpBB 3.2.x.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.1.x] oder [3.2.x] angeben.
phpbbtroubletoday
Mitglied
Beiträge: 1
Registriert: 12.09.2019 14:33

[3.1] Probleme bei der Neuinstallation von PHPBB3.1.2

Beitragvon phpbbtroubletoday » 12.09.2019 14:49

Aufgrund einer älteren PHP-Version auf dem Server ist keine neuere Version installierbar. Leider habe ich mit durch einen Aufspielversucht von der aktuellen Version, die Installation zerschossen. In der Folge ist die DB gesichert und mehrfach gelöscht worden.

Denn im Installationsprozess er ständig mit folgender Fehlermeldung ab:

Code: Alles auswählen

General Error
SQL ERROR [ mysqli ]

Duplicate entry 'rand_seed_last_update' for key 'PRIMARY' [1062]

SQL

INSERT INTO phpbb_config (config_name, config_value, is_dynamic) VALUES ('rand_seed_last_update', '0', 1)

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 855
CALL: trigger_error()

FILE: [ROOT]/phpbb/db/driver/mysqli.php
LINE: 193
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/install/install_install.php
LINE: 1253
CALL: phpbb\db\driver\mysqli->sql_query()

FILE: [ROOT]/install/install_install.php
LINE: 99
CALL: install_install->load_schema()

FILE: [ROOT]/install/index.php
LINE: 409
CALL: install_install->main()

FILE: [ROOT]/install/index.php
LINE: 289
CALL: module->load()


Folgender Zustand:
DB: Leer (gelöscht und neu angelegt), Verwaltung/Erstellung erfolgte über ISPCONFIG

Alle Dateien sind ordnungsgemäß über FTP ins Installationsverzeichnis geladen und mit entsprechenden Rechten versehen. "alles grün".

Er bricht jedoch immer wieder ab.

Installationsschritte:

Voraussetzung — Du musst mindestens PHP-Version 5.3.3 verwenden (PHP 7 wird nicht unterstützt), um phpBB installieren zu können. Falls unten Safe Mode angezeigt wird, läuft deine PHP-Installation in diesem Modus. Dies wird manche Funktionen des Administrations-Bereichs einschränken.

PHP-Version >= 5.3.3, < 7.0.0-dev:
Ja

PHP-Einstellung allow_url_fopen ist erlaubt:
Optional — Diese Einstellung ist optional, jedoch werden bestimmt phpBB-Funktionen wie extern verlinkte Avatare ohne sie nicht richtig funktionieren.
Ja

PHP-Funktion getimagesize() ist verfügbar:
Voraussetzung — Damit phpBB richtig funktioniert, muss die Funktion getimagesize() verfügbar sein.
Ja

PCRE UTF-8-Unterstützung:
phpBB wird nicht funktionieren, wenn deine PHP-Installation ohne UTF-8-Unterstützung in der PCRE-Erweiterung kompiliert wurde.
Ja

PHP JSON-Unterstützung:
Voraussetzung — Damit phpBB richtig funktioniert, muss die PHP JSON-Erweiterung verfügbar sein.
Ja

Prüfung der mbstring-Erweiterung

Erforderlich – mbstring ist eine PHP-Erweiterung, die Unterstützung für Multibyte-Zeichenketten zur Verfügung stellt. Bestimmte Funktionen von mbstring sind nicht mit phpBB kompatibel und müssen deaktiviert werden.

Überladen von Funktionen:
mbstring.func_overload muss entweder 0 oder 4 sein.
Ja

Transparente Zeichenkodierung:
mbstring.encoding_translation muss 0 sein.
Ja

HTTP-Eingabe-Kodierung:
mbstring.http_input muss auf pass eingestellt sein.
Ja

HTTP-Ausgabe-Kodierung:
mbstring.http_output muss auf pass eingestellt sein.
Ja

Unterstützte Datenbanken

Voraussetzung — Du musst Unterstützung für mindestens eine kompatible Datenbank in PHP bereitstellen. Falls keine Datenbank-Module als verfügbar angezeigt werden, solltest du deinen Webhosting-Provider kontaktieren oder die entsprechende PHP-Dokumentation zu Rate ziehen.

MySQL mit MySQLi-Erweiterung:
Verfügbar

MySQL:
Verfügbar

MSSQL Server 2000+:
Nicht verfügbar

MSSQL Server 2000+ über ODBC:



Nicht verfügbar

MSSQL Server 2005+ [ Nativ ]:
Nicht verfügbar

Oracle:
Nicht verfügbar

PostgreSQL:
Nicht verfügbar

SQLite 2:
Nicht verfügbar

SQLite 3:
Verfügbar

Optionale Module

Optional — Diese Module oder Applikationen sind optional. Sollten sie verfügbar sein, so ermöglichen sie zusätzliche Funktionen.

zlib Kompressions-Unterstützung [ gz, .tar.gz, .zip ]:
Verfügbar

Remote FTP Unterstützung [ Installation ]:
Verfügbar

GD Grafik-Unterstützung [ Visuelle Bestätigung ]:
Verfügbar

XML Unterstützung [ Jabber ]:
Verfügbar

Unterstützung von ImageMagick [ Dateianhänge ]:
Kann den Pfad nicht ermitteln. Wenn du weißt, dass ImageMagick installiert ist, kannst du den Pfad auch später noch im Administrations-Bereich angeben.

Dateien und Verzeichnisse

Voraussetzung — phpBB muss auf diverse Dateien und Verzeichnisse zugreifen oder diese beschreiben können, um reibungslos zu funktionieren. Wenn „Nicht gefunden“ angezeigt wird, musst du die entsprechende Datei oder das Verzeichnis erstellen. Wenn „Nicht beschreibbar“ angezeigt wird, musst du die Berechtigungen für die Datei oder das Verzeichnis so ändern, dass phpBB darauf schreiben kann.

cache/:
Gefunden, Beschreibbar

files/:
Gefunden, Beschreibbar

store/:
Gefunden, Beschreibbar

Optionale Dateien und Verzeichnisse

Optional — Diese Dateien, Verzeichnisse oder Rechte-Einstellungen sind keine Voraussetzung für die Installation. Das Installationssystem wird versuchen, diese auf verschiedene Weisen zu erstellen, falls sie nicht existieren oder nicht beschreibbar sind. Wenn sie vorhanden und beschreibbar sind, wird allerdings die Installation vereinfacht.

config.php:
Gefunden, Beschreibbar

images/avatars/upload/:
Gefunden, Beschreibbar


..............................:


Administrator-Einstellungen prüfen:
Tests bestanden

.....................................


Die Konfigurationsdatei wurde geschrieben. Du kannst nun zum nächsten Schritt der Installation gehen.


......................................:

beim nächsten Schritt bricht er mit der vorgenannten Fehlermeldung nach einer Minute Wartezeit ab... Unschön.

Benutzeravatar
chris1278
Mitglied
Beiträge: 1464
Registriert: 12.11.2007 06:20
Wohnort: Euskirchen
Kontaktdaten:

Re: [3.1] Probleme bei der Neuinstallation von PHPBB3.1.2

Beitragvon chris1278 » 12.09.2019 20:55

Ja da würd ich dir empfehlen das Forum direkt mit 3.2.7 zu machen. Weil die meisten Hoster php 5.x nicht mehr unterstützen. und die phpbb Version 3.1.x nicht mit php 7.x kompatibeel ist.

Benutzeravatar
vfrblue
Supporter
Supporter
Beiträge: 1584
Registriert: 22.11.2016 18:46
Wohnort: Niedersachsen-West
Kontaktdaten:

Re: [3.1] Probleme bei der Neuinstallation von PHPBB3.1.2

Beitragvon vfrblue » 12.09.2019 21:54

Welche PHP-Version verwendest du?
Gruß Hermann

phpBB-Styles, Skins, Themes by VT-Theme
Forum VFR-OC


Zurück zu „Support-Forum“