Systemanforderungen für phpBB

Systemanforderungen


Damit phpBB auf einem Server installiert werden kann, müssen verschiedene Voraussetzungen erfüllt werden:

phpBB 3.1


  • SQL Datenbank:
    • MySQL 3.23 oder höher (MySQLi wird unterstützt)
    • MariaDB 5.1 oder höher
    • PostgreSQL 8.3+
    • SQLite 2.8.2+
    • SQLite 3.6.15+
    • MS SQL Server 2000 oder höher (direkt oder vie ODBC oder mit dem nativem Adapter)
    • Oracle
  • PHP 5.3.3 oder höher; kleiner als PHP 7.0 (PHP 7.0 wird nicht unterstützt)
  • PHP memory_limit ab 12 MiB (geändert von 8 MiB für phpBB 3.0.x). (Empfohlen mind. 16 MiB)
  • mit folgenden PHP Modulen:
    • json
  • Die Funktion getimagesize() muss aktiviert sein
  • Folgende PHP-Module werden nicht zwingend benötigt, ergänzen allerdings verschiedene Funktionen:
    • zlib Kompression
    • Remote FTP Unterstützung
    • XML Unterstützung
    • Imagemagick Unterstützung
    • GD Unterstützung

phpBB 3.2


  • SQL Datenbank:
    • MySQL 3.23 oder höher (MySQLi wird unterstützt)
    • MariaDB 5.1 oder höher
    • PostgreSQL 8.3+
    • SQLite 2.8.2+
    • SQLite 3.6.15+
    • MS SQL Server 2000 oder höher (direkt oder vie ODBC oder mit dem nativem Adapter)
    • Oracle
  • PHP 5.4.0 oder höher und niedriger als PHP 7.1
  • mit folgenden PHP Modulen:
    • json
  • Die Funktion getimagesize() muss aktiviert sein
  • Folgende PHP-Module werden nicht zwingend benötigt, ergänzen allerdings verschiedene Funktionen:
    • zlib Kompression
    • Remote FTP Unterstützung
    • XML Unterstützung
    • Imagemagick Unterstützung
    • GD Unterstützung

Zuletzt bearbeitet: 21.01.2017 10:41 von • Der Artikel wurde 6629 mal angeschaut.