Extension installieren schlägt fehl: acp_cat_dot_mods

Kurzbeschreibung:
Was zu tun ist, wenn bei der Installation einer Extension die Fehlermeldung "Ein erforderliches Modul existiert nicht: ACP_CAT_DOT_MODS" angezeigt wird

Gilt für phpBB-Version:
phpBB 3.1
Tags:
Häufige Fehler, QS_2014
Keywords:
acp_cat_dot_mods,, Erweiterung, extension,
Beim Installieren einer Extension kann folgender Fehler auftreten:
Code: Alles auswählen
    Während der Anpassung der Datenbank ist etwas falsch gelaufen und ein Fehler aufgetreten. Die Änderungen, die vor dem Fehler durchgeführt wurden, wurden so weit wie möglich rückgängig gemacht. Du solltest jedoch prüfen, ob dein Board fehlerfrei funktioniert.

    Ein erforderliches Modul existiert nicht: ACP_CAT_DOT_MODS


Die Extension wird in diesem Fall nicht installiert und lässt sich nicht nutzen.

Das liegt, wie die Fehlermeldung schon sagt, daran, dass ein Modul im Admin-Bereich fehlt. In der Regel tritt dieses Problem nur bei Boards auf, die von phpBB 3.0 aktualisiert werden.

Der Fehler lässt sich leicht korrigieren:
Im Admin-Bereich bitte navigieren zu:
System > Modul-Konfiguration > Administrations-Bereich

Dort sollte normalerweise als letztes Modul in der Liste der Eintrag "Erweiterungen" stehen.

Laut der Fehlermeldung fehlt dieses aber, also legen wir es neu an (links unten "ACP_CAT_DOT_MODS" eintragen und "Neues Modul erstellen" auswählen):
  • Name des Moduls: ACP_CAT_DOT_MODS
  • Modul-Typ: Kategorie
  • Übergeordnet: Kein übergeordnetes Modul
  • Aktiviert: JA

Nach dem Anlegen des Moduls sollte die Installation der Erweiterung problemlos funktionieren. Die gleiche Strategie (mit anderen Modulnamen) kann ggf. funktionieren, wenn für eine Erweiterung ein anderes Modul fehlt.

Es ist wichtig, dass das Modul ACP_CAT_DOT_MODS heißt, sonst schlägt die Extension Installation auch weiterhin fehl! Bezeichnungen wie "Erweiterungen" oder "Extensions" o.ä. funktionieren nicht!


  • Ähnliche Artikel
    Relevanz
    Zugriffe
    Zuletzt bearbeitet