Pastebin

phpBB Standard-.htaccess

von vfrblue

Dein Code:
  1. <IfModule mod_rewrite.c>
  2. RewriteEngine on
  3.  
  4. #
  5. # Uncomment the statement below if URL rewriting doesn't
  6. # work properly. If you installed phpBB in a subdirectory
  7. # of your site, properly set the argument for the statement.
  8. # e.g.: if your domain is test.com and you installed phpBB
  9. # in http://www.test.com/phpBB/index.php you have to set
  10. # the statement RewriteBase /phpBB/
  11. #
  12. #RewriteBase /
  13.  
  14. #
  15. # Uncomment the statement below if you want to make use of
  16. # HTTP authentication and it does not already work.
  17. # This could be required if you are for example using PHP via Apache CGI.
  18. #
  19. #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
  20.  
  21. #
  22. # The following 3 lines will rewrite URLs passed through the front controller
  23. # to not require app.php in the actual URL. In other words, a controller is
  24. # by default accessed at /app.php/my/controller, but can also be accessed at
  25. # /my/controller
  26. #
  27. RewriteCond %{REQUEST_FILENAME} !-f
  28. RewriteCond %{REQUEST_FILENAME} !-d
  29. RewriteRule ^(.*)$ app.php [QSA,L]
  30.  
  31. #
  32. # If symbolic links are not already being followed,
  33. # uncomment the line below.
  34. # http://anothersysadmin.wordpress.com/2008/06/10/mod_rewrite-forbidden-403-with-apache-228/
  35. #
  36. #Options +FollowSymLinks
  37. </IfModule>
  38.  
  39. # Apache content negotation tries to interpret non-existent paths as files if
  40. # MultiViews is enabled. This will however cause issues with paths containg
  41. # dots, e.g. for the cron tasks
  42. <IfModule mod_negotiation.c>
  43.         Options -MultiViews
  44. </IfModule>
  45.  
  46. # With Apache 2.4 the "Order, Deny" syntax has been deprecated and moved from
  47. # module mod_authz_host to a new module called mod_access_compat (which may be
  48. # disabled) and a new "Require" syntax has been introduced to mod_authz_host.
  49. # We could just conditionally provide both versions, but unfortunately Apache
  50. # does not explicitly tell us its version if the module mod_version is not
  51. # available. In this case, we check for the availability of module
  52. # mod_authz_core (which should be on 2.4 or higher only) as a best guess.
  53. <IfModule mod_version.c>
  54.         <IfVersion < 2.4>
  55.                 <Files "config.php">
  56.                         Order Allow,Deny
  57.                         Deny from All
  58.                 </Files>
  59.                 <Files "common.php">
  60.                         Order Allow,Deny
  61.                         Deny from All
  62.                 </Files>
  63.         </IfVersion>
  64.         <IfVersion >= 2.4>
  65.                 <Files "config.php">
  66.                         Require all denied
  67.                 </Files>
  68.                 <Files "common.php">
  69.                         Require all denied
  70.                 </Files>
  71.         </IfVersion>
  72. </IfModule>
  73. <IfModule !mod_version.c>
  74.         <IfModule !mod_authz_core.c>
  75.                 <Files "config.php">
  76.                         Order Allow,Deny
  77.                         Deny from All
  78.                 </Files>
  79.                 <Files "common.php">
  80.                         Order Allow,Deny
  81.                         Deny from All
  82.                 </Files>
  83.         </IfModule>
  84.         <IfModule mod_authz_core.c>
  85.                 <Files "config.php">
  86.                         Require all denied
  87.                 </Files>
  88.                 <Files "common.php">
  89.                         Require all denied
  90.                 </Files>
  91.         </IfModule>
  92. </IfModule>

Quellcode

Hier kannst du den Code kopieren und ihn in deinen bevorzugten Editor einfügen. Alternativ kannst du den gesamten Eintrag auch als Datei herunterladen.