XAMPP 1.4.1x + phpBB 2.0.11 + EMC beta1 (0.1.13) Installer

Eine Neuinstallation von phpBB 2.0 wird auf phpBB.de nicht mehr unterstützt.
Siehe auch Entwicklungs-Ende von phpBB 2.0 - Auswirkungen auf phpBB.de
Forumsregeln
phpBB 2.0 hat das Ende seiner Lebenszeit überschritten
phpBB 2.0 wird nicht mehr aktiv unterstützt. Insbesondere werden - auch bei Sicherheitslücken - keine Patches mehr bereitgestellt. Der Einsatz von phpBB 2.0 erfolgt daher auf eigene Gefahr. Wir empfehlen einen Umstieg auf phpBB 3.1, welches aktiv weiterentwickelt wird und für welches regelmäßig Updates zur Verfügung gestellt werden.

Eine Neuinstallation von phpBB 2.0 wird auf phpBB.de nicht mehr unterstützt.
Siehe auch Entwicklungs-Ende von phpBB 2.0 - Auswirkungen auf phpBB.de
Gesperrt
Benutzeravatar
gloriosa
Mitglied
Beiträge: 13770
Registriert: 04.01.2005 20:23
Wohnort: Landeshauptstadt Erfurt

XAMPP 1.4.1x + phpBB 2.0.11 + EMC beta1 (0.1.13) Installer

Beitrag von gloriosa »

Hallo,
um eine neue lokale Testumgebung zu nutzen habe ich auf einem P4/1,7GHz mit WXP Prof. SP2 den XAMPP für Windows 1.4.10 und phpBB 2.0.11 installiert. Als nächstes war der EasyMOD (0.1.13) Installer dran. Dieser läßt sich installieren legt jedoch in der Datenbank nicht die Tabelle phpbb_easymod an. Nach einigen Varitionen der Installation habe ich aufgegeben ..... Gestern habe ich dann die neue Version XAMPP für Windows 1.4.11 mit phpbb 2.0.11 auf einem Notebook Centrino/1,5GHz WXP Prof. SP2 installiert und das gleiche Ergebnis erhalten. Während der Installation wird dieser Kommentar ausgegeben :

Code: Alles auswählen

Error :: Invalid default value for 'mod_id'

SQL   :: CREATE TABLE phpbb_easymod ( mod_id mediumint(8) NOT NULL DEFAULT '0' auto_increment, mod_title varchar(50) NULL DEFAULT '', mod_file varchar(255) NULL DEFAULT '', mod_version varchar(15) NULL DEFAULT '', mod_author_handle varchar(25) NULL DEFAULT '', mod_author_email varchar(100) NULL DEFAULT '', mod_author_name varchar(100) NULL DEFAULT '', mod_author_url varchar(100) NULL DEFAULT '', mod_description text NULL DEFAULT '', mod_process_date int(11) NULL DEFAULT '0', mod_phpBB_version varchar(15) NULL DEFAULT '', mod_processed_themes varchar(200) NULL DEFAULT '', mod_processed_langs varchar(200) NULL DEFAULT '', mod_files_edited mediumint(8) NULL DEFAULT '0', mod_tables_added mediumint(8) NULL DEFAULT '0', mod_tables_altered mediumint(8) NULL DEFAULT '0', mod_rows_inserted mediumint(8) NULL DEFAULT '0', PRIMARY KEY (mod_id))
Wenn ich den SQL-Befehl händisch im XAMPP ausführe wird folgendes Ergebnis präsentiert :

Code: Alles auswählen

Fehler

SQL-Befehl:

CREATE TABLE phpbb_easymod(
mod_id mediumint( 8 ) NOT NULL DEFAULT '0' AUTO_INCREMENT ,
mod_title varchar( 50 ) NULL DEFAULT '',
mod_file varchar( 255 ) NULL DEFAULT '',
mod_version varchar( 15 ) NULL DEFAULT '',
mod_author_handle varchar( 25 ) NULL DEFAULT '',
mod_author_email varchar( 100 ) NULL DEFAULT '',
mod_author_name varchar( 100 ) NULL DEFAULT '',
mod_author_url varchar( 100 ) NULL DEFAULT '',
mod_description text NULL DEFAULT '',
mod_process_date int( 11 ) NULL DEFAULT '0',
mod_phpBB_version varchar( 15 ) NULL DEFAULT '',
mod_processed_themes varchar( 200 ) NULL DEFAULT '',
mod_processed_langs varchar( 200 ) NULL DEFAULT '',
mod_files_edited mediumint( 8 ) NULL DEFAULT '0',
mod_tables_added mediumint( 8 ) NULL DEFAULT '0',
mod_tables_altered mediumint( 8 ) NULL DEFAULT '0',
mod_rows_inserted mediumint( 8 ) NULL DEFAULT '0',
PRIMARY KEY ( mod_id )
)

MySQL meldet: Dokumentation
#1067 - Invalid default value for 'mod_id'
Was ist Lösung ? Auf dem identischen Notebook meines Sohnes ist ein XAMPP für Windows 1.3.x installiert, da trat das Ganze nicht auf :( .

Vielen Dank im Voraus.

Herzliche Grüße aus Erfurt

gloriosa :

Einste1n
Mitglied
Beiträge: 520
Registriert: 09.06.2004 18:54

Beitrag von Einste1n »

ich nutze auch xamp aber noch die alte version ... benutzt du php5 oder php4 ? es gibt doch nen switcher ... versuch mal die version zu switchen :)

Benutzeravatar
gloriosa
Mitglied
Beiträge: 13770
Registriert: 04.01.2005 20:23
Wohnort: Landeshauptstadt Erfurt

php 4

Beitrag von gloriosa »

Hallo,
Danke für die schnelle Antwort. Aber auch das Umswitchen auf php 4 bringt kein anderes Ergebnis nach der Installation des EasyMOD :cry: !

Viele Grüße

gloriosa

Einste1n
Mitglied
Beiträge: 520
Registriert: 09.06.2004 18:54

Beitrag von Einste1n »

gut, der nächste logische schritt, wäre es ne alte version zu installieren um zu sehen ob es ein allgemeines problem ist oder ein Versions problem.
Eine andere Idee hab ich im moment auch nicht ;-)
Vieleicht noch im Xamp Forum direkt suchen und nachfragen

Benutzeravatar
gloriosa
Mitglied
Beiträge: 13770
Registriert: 04.01.2005 20:23
Wohnort: Landeshauptstadt Erfurt

Beitrag von gloriosa »

Einste1n hat geschrieben:Vieleicht noch im Xamp Forum direkt suchen und nachfragen
Hallo Einste1n,
vielen Dank für obigen Tip. Dort erhielt ich prompt folgende Antwort :
Wiedmann hat geschrieben:Hallo gloriosa,

das/dein Problem ist die nicht korrekte Definition der Spalte `mod_id`. Ältere MySQL-Versionen scheinen diesen Fehler wohl, im Gegensatz zur aktuellen Version, noch zu tolerieren.
--> Spalten mit AUTO_INCREMENT dürfen kein DEFAULT value haben.

Mit folgendem SQL kannst du diese Tabelle in phpMyAdmin anlegen:

Code: Alles auswählen

CREATE TABLE `phpbb_easymod` (
`mod_id` MEDIUMINT( 8 ) NOT NULL AUTO_INCREMENT ,
`mod_title` VARCHAR( 50 ) DEFAULT '',
`mod_file` VARCHAR( 255 ) DEFAULT '',
`mod_version` VARCHAR( 15 ) DEFAULT '',
`mod_author_handle` VARCHAR( 25 ) DEFAULT '',
`mod_author_email` VARCHAR( 100 ) DEFAULT '',
`mod_author_name` VARCHAR( 100 ) DEFAULT '',
`mod_author_url` VARCHAR( 100 ) DEFAULT '',
`mod_description` TEXT,
`mod_process_date` INT( 11 ) DEFAULT '0',
`mod_phpBB_version` VARCHAR( 15 ) DEFAULT '',
`mod_processed_themes` VARCHAR( 200 ) DEFAULT '',
`mod_processed_langs` VARCHAR( 200 ) DEFAULT '',
`mod_files_edited` MEDIUMINT( 8 ) DEFAULT '0',
`mod_tables_added` MEDIUMINT( 8 ) DEFAULT '0',
`mod_tables_altered` MEDIUMINT( 8 ) DEFAULT '0',
`mod_rows_inserted` MEDIUMINT( 8 ) DEFAULT '0',
PRIMARY KEY ( `mod_id` )
) ENGINE = MYISAM
Viele Grüße

gloriosa
Viele Grüße - gloriosa :D
Die einen schützen sich vor frischem Wind, während die anderen ihn nutzen.
Kein kostenloser MOD-Einbau usw. bzw. Support via PN, Email oder IRC !

Gesperrt

Zurück zu „phpBB 2.0: Installation und Update“