Kompatibilität bei IE 8.0 mit textarea

Probleme bei der regulären Arbeiten mit phpBB, Fragen zu Vorgehensweisen oder Funktionsweise sowie sonstige Fragen zu phpBB im Allgemeinen.
Forumsregeln
phpBB 2.0 hat das Ende seiner Lebenszeit überschritten
phpBB 2.0 wird nicht mehr aktiv unterstützt. Insbesondere werden - auch bei Sicherheitslücken - keine Patches mehr bereitgestellt. Der Einsatz von phpBB 2.0 erfolgt daher auf eigene Gefahr. Wir empfehlen einen Umstieg auf phpBB 3.1, welches aktiv weiterentwickelt wird und für welches regelmäßig Updates zur Verfügung gestellt werden.
Antworten
Elektron
Mitglied
Beiträge: 128
Registriert: 10.01.2005 21:42

Kompatibilität bei IE 8.0 mit textarea

Beitrag von Elektron »

Hallo,
aus dem Bereich phpBB3 gibt es folgendes Problem:

http://www.phpbb.de/community/viewtopic ... 20&start=0
highwaycop hat geschrieben:Zur Berücksichtigung für die Entwickler:

Ich habe z.Zt. installiert die Forenversion phpbb3.0.4 (incl. versch. Mods), unter IE8.0 gibt es jetzt folgendes (kleines) Problem:

Bei Erstellung eines Beitrages "springt" der Cursor im Beitragsfeld "hin und her", wenn sich die Beitragslänge über das "normale Eingabefeld" hinaus fortsetzt und der Scrollbalken rechts erscheint.

Ist einen Lösung mit dem nächsten Forenupdate in Aussicht?
Dies IE-Bug oder wie man es auch immer nennen mag, wiederspiegelt sich leider auch im phpBB2.
Im phpBB3 wurde wohl Bugfix angekündigt.

Kennt jemand einen Bugfix oder ein workaround für phpBB2?

Gruß Elektron
Benutzeravatar
Dr.Death
Moderator
Moderator
Beiträge: 16453
Registriert: 23.04.2003 08:22
Wohnort: Xanten
Kontaktdaten:

Re: Kompatibilität bei IE 8.0 mit textarea

Beitrag von Dr.Death »

Hallo,

der "Fix" besteht momentan einfach darin, den IE8 in den IE7 Modus zu zwingen:

ÖFFNE: overall_header.tpl

SUCHE:

Code: Alles auswählen

<meta http-equiv="Content-Style-Type" content="text/css">
DANACH EINFÜGEN:

Code: Alles auswählen

<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />
Benutzeravatar
Kendoo
Mitglied
Beiträge: 125
Registriert: 29.09.2007 03:44

Re: Kompatibilität bei IE 8.0 mit textarea

Beitrag von Kendoo »

Dr.Death hat geschrieben:Hallo,

der "Fix" besteht momentan einfach darin, den IE8 in den IE7 Modus zu zwingen:

ÖFFNE: overall_header.tpl

SUCHE:

Code: Alles auswählen

<meta http-equiv="Content-Style-Type" content="text/css">
DANACH EINFÜGEN:

Code: Alles auswählen

<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />
was allerdings auch nicht wirklich hilft, bzw. eigentlich gar nicht
Maxe
Mitglied
Beiträge: 154
Registriert: 15.07.2006 00:17

Re: Kompatibilität bei IE 8.0 mit textarea

Beitrag von Maxe »

Hallo zusammen,

gibt es zwischenzeitlich für phpBB2 schon eine andere Abhilfe für das Problem?

Ich bin ebenfalls daran interessiert.

Danke Maxe
Benutzeravatar
Mahony
Ehemaliges Teammitglied
Beiträge: 12086
Registriert: 17.11.2005 22:33
Wohnort: Esslingen (Neckar)
Kontaktdaten:

Re: Kompatibilität bei IE 8.0 mit textarea

Beitrag von Mahony »

Hallo Maxe
Forumsregeln hat geschrieben:phpBB 2.0 hat das Ende seiner Lebenszeit überschritten
phpBB 2.0 wird nicht mehr aktiv unterstützt.
Hast du mal den Tipp von Dr.Death versucht?


Grüße: Mahony
Taekwondo in Berlin
Wer fragt, ist ein Narr für fünf Minuten, wer nicht fragt, ist ein Narr für immer.
Maxe
Mitglied
Beiträge: 154
Registriert: 15.07.2006 00:17

Re: Kompatibilität bei IE 8.0 mit textarea

Beitrag von Maxe »

Hallo Mahony,
Mahony hat geschrieben:Hast du mal den Tipp von Dr.Death versucht?
der Tipp funktioniert.
Jedoch hätte ich gern noch eine andere Lösung als diese Art Emulator. Ist schließlich nicht Sinn und Zweck einen Browser eine Version runter zu "drosseln".

Danke und viele Grüße
Maxe
Benutzeravatar
Dungeonwatcher
Mitglied
Beiträge: 635
Registriert: 11.07.2004 10:04
Wohnort: Berlin

Re: Kompatibilität bei IE 8.0 mit textarea

Beitrag von Dungeonwatcher »

'n Abend! 8)
Maxe hat geschrieben:
Mahony hat geschrieben:Hast du mal den Tipp von Dr.Death versucht?
der Tipp funktioniert.
Naja, nicht wirklich. Alle IE Versionen nach IE7 kommen, auch mit diesem Tipp, auf meinem Forum mit einem kleinen Javascript nicht klar. Alle nicht eingeloggten Besucher bekommen den aktuellen Innenminister zu sehen wie er sich umschaut. Wenn man hierbei die Seite hoch und runter scrollt wandert der Kopf mit und bleibt nicht wie bei allen anderen Browsern am unteren Rand des Browser. Der IE ist auch in der aktuellen Version einfach nur Pfusch.
Jedoch hätte ich gern noch eine andere Lösung als diese Art Emulator. Ist schließlich nicht Sinn und Zweck einen Browser eine Version runter zu "drosseln".
Hmmm, einen Browserfilter einbauen und die User mit IE vor diesem Schrottbrowser warnen. :wink:
So ähnlich habe ich es getan. Ich warne die IE Nutzer schon auf dem Portal, das einiges nicht wie vorgesehen funktionieren wird.

Bye
Antworten

Zurück zu „phpBB 2.0: Administration, Benutzung und Betrieb“