[3.2] Fehler bei Upgrade von 3.0.14

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.1.x und höher und die Konvertierung zu phpBB 3.2.x.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.1.x] oder [3.2.x] angeben.
lurapag
Mitglied
Beiträge: 2
Registriert: 27.10.2017 09:02

[3.2] Fehler bei Upgrade von 3.0.14

Beitragvon lurapag » 27.10.2017 09:07

Hello,
I'm telling you that I'm using Google Translator from Italian to English.
Having the PHPBB 3.0.14 version yet, I decided to go to 3.2.1 and before I did it remotely I downloaded XAMPP to test locally by configuring the required files, both the database and the local ones.
Then I executed in the letter the following procedure here
But when you need to point it all up to http://www.example.com/yourforum/install (entering forum data locally) just launch the installation will cause this error:

Code: Alles auswählen

Fatal error: Uncaught Twig_Error_Loader: Unable to find template "message_body.html" (looked into: C:\xampp\htdocs\locale\styles\all\template). in C:\xampp\htdocs\locale\vendor\twig\twig\lib\Twig\Loader\Filesystem.php:232 Stack trace: #0 C:\xampp\htdocs\locale\phpbb\template\twig\loader.php(135): Twig_Loader_Filesystem->findTemplate('message_body.ht...') #1 C:\xampp\htdocs\locale\vendor\twig\twig\lib\Twig\Loader\Filesystem.php(150): phpbb\template\twig\loader->findTemplate('message_body.ht...') #2 C:\xampp\htdocs\locale\vendor\twig\twig\lib\Twig\Environment.php(329): Twig_Loader_Filesystem->getCacheKey('message_body.ht...') #3 C:\xampp\htdocs\locale\vendor\twig\twig\lib\Twig\Environment.php(419): Twig_Environment->getTemplateClass('message_body.ht...') #4 C:\xampp\htdocs\locale\phpbb\template\twig\environment.php(277): Twig_Environment->loadTemplate('message_body.ht...', NULL) #5 C:\xampp\htdocs\locale\vendor\twig\twig\lib\Twig\Environment.php(362): phpbb\template\twig\environment->loadTemplate('message_body.ht...') #6 C: in C:\xampp\htdocs\locale\vendor\twig\twig\lib\Twig\Loader\Filesystem.php on line 232


I also downloaded one at a time the files from the styles / prosperity / template folder to the "all" folder in the styles / prosliver / template folder and updated every page ...

At a certain point, the attached screen appeared.
I also attach the online forum screen.

[ externes Bild ]
[ externes Bild ]
[ externes Bild ]

Empty the cache but the result is always this ... and it also happens with other browsers.
Where am I wrong?
Thank you.
Zuletzt geändert von Melmac am 28.10.2017 00:23, insgesamt 2-mal geändert.
Grund: Titel ergänzt

Benutzeravatar
Melmac
Supporter
Supporter
Beiträge: 2055
Registriert: 15.10.2012 03:27

Re: [3.2]

Beitragvon Melmac » 27.10.2017 14:58

Hi,

there are a few things you have to consider first when it comes to an upgrade from phpBB 3.0.14 to 3.2.1:
  • phpBB 3.2.x requires PHP 5.4 or above
  • phpBB versions prior to 3.2.0 are not compatible with PHP 7.x
  • Neither Styles nor MODs designed for 3.0.x are any longer compatible with 3.2 and therefore will have to be removed prior to upgrading
  • During the upgrade almost all of the existing 3.0.14 files will have to be replaced anyway so using the corresponding automated updater package doesn't really make sense: it's easier to do a manual upgrade (complete file replacement plus database update).
The first two points affect both the PHP version your live server is currently running and the one shipped with your XAMPP installation. Taking care of the last one is part of the preparatory measures you have to take before starting "the real thing".
Please check whether you server meets the requirements to run phpBB 3.2 first.

Are there any MODs installed you really need their "working data" saved and/or "re-used" in 3.2.1? You may then check whether there are any extensions avilable which provide the same functionality and/or are able to migrate the "old" MODs data stored in the database.
Everything you don't really need should be removed later on.

As you already have decided to test-run the upgrade procedure in a local environment, may I suggest the following approach:
Start with a clean/fresh local phpBB 3.0.14 installation as it is much easier to remove the "old" MODs and styles at the beginning of the upgrade process. To do so

  1. Preparations
    • Locally install a XAMPP version that supports phpBB 3.0.14 as well as 3.2:
      As the current XAMPP versions ship with PHP 7.x you need to download and install a release that ships with e.g. PHP 5.6 (which is perfectly okay with both 3.0.14 and 3.2.1)
    • In phpMyAdmin create a new database user - preferably with the same name und password used in/for your live board's DB
    • Create a new database and name it in accordance to the one your live board uses
    • Install a fresh/unmodified 3.0.14 locally
      [You may want to download the /files, /images, /download and /store folders of your live board and insert them in the local installation]
    • Install the corresponding STK => download can be found here
    • Restore a complete backup of your live board's DB into the one used by your local installation
    • Run the STK:
      - have your styles be set back to prosilver as standard for all users
      - run the database clean-up and remove all entries related to old MODs from the database (except for those that can be migrated by extensions and which you really need to keep) and have the modules system rebuilt to the original configuration as of a fresh install (=> getting rid of all modules added during the installation of MODs)
  2. Upgrade
    • Delete all files/folders in your local installation except for config.php, /files, /images, /download and /store
    • Copy all files and folders of a localized full phpBB 3.2.1 package into the installation directory except for config.php (make sure you don't overwrite the existing one!)
    • Start the database upgrade routine by calling <path_to_installation>/install (or, if this doesn't work: <path_to_installation>/install/app.php.
      Choose the tab labeled "Update" and, from there, proceed with the option database update only.
      Let this routine run to its completion.
    • If done and no error messages have been shown: delete the install folder, log into your local board and test for flawless operation

A more detailed tutorial of how to upgrade from 3.0 to 3.2 could be found here (though in German) - maybe Google Translator can do an acceptable job on this as well :wink:
Handle nur nach derjenigen Maxime, durch die du zugleich wollen kannst, dass sie ein allgemeines Gesetz werde.
(Immanuel Kant)

lurapag
Mitglied
Beiträge: 2
Registriert: 27.10.2017 09:02

Re: [3.2] Fehler bei Upgrade von 3.0.14

Beitragvon lurapag » 28.10.2017 05:57

Thanks.


Zurück zu „Support-Forum“