Update, aber wo anfangen?

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.2 und höher und die Konvertierung zu phpBB 3.3.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.3] oder [3.2] angeben
Antworten
Benutzeravatar
willi2010
Mitglied
Beiträge: 144
Registriert: 09.05.2010 19:22
Kontaktdaten:

Update, aber wo anfangen?

Beitrag von willi2010 »

Ja, ich habe viel zu lange an dem gut funktionierendem System nichts gemacht,
aber jetzt muss es wohl sein...

PHP 5.5
Board phpBB 3.0.12
Portal 2.0.2

Bevor das Board aktualisiert wird, müsste ich wohl das Portal und alle anderen Module entfernen.
Dann Update für´s Board und neues Portal einbauen.

Mein Anstoss alles zu aktualisieren ist PHP 7.0, aber damit scheint weder die neue Bord-Version noch das Portal zu funktionieren.
Im Moment habe ich noch PHP 5.5, welches von 1&1 kostenpflichtig unterstüzt wird.

Wann wird es eine phpBB-Version für PHP 7.0 geben?
Sollte man bis dahin warten, dann alles komplett neu installieren und kann man dann eventuell die Daten von der alten MySQL auf die neue portieren?

Danke für euren Rat
Viele Grüße
Klaus KF2, das Forum für Kreuzfahrt-Freunde
Versionen: phpBB 3.0.12 / board3_portal_2.0.1 / prosilver / phpbb_gallery_1_1_6 / Kalender alightner 0_1_0 / Tapatalk_pb30_4_2_0

Benutzeravatar
Kirk
Supporter
Supporter
Beiträge: 6717
Registriert: 24.05.2010 08:31
Kontaktdaten:

Re: Update, aber wo anfangen?

Beitrag von Kirk »

Hallo
Die Version 3.2 funktioniert unter php7
Wie du das Update machst kannst du hier nachlesen KB:phpBB32_upgrade_from_30
Was das Portal angeht, ich nehme mal an das du das Board3 Portal meinst, es gibt eine angepasste Version
http://reyno41.bplaced.net/phpbb/viewto ... f=33&t=228 bei manchen gibt es aber unter php7 Probleme.

Benutzeravatar
willi2010
Mitglied
Beiträge: 144
Registriert: 09.05.2010 19:22
Kontaktdaten:

Re: Update, aber wo anfangen?

Beitrag von willi2010 »

Danke für die Info.
Mit meinem Testboard werde ich dann anfangen und erstmal alle Einbauten entfernen.
Viele Grüße
Klaus KF2, das Forum für Kreuzfahrt-Freunde
Versionen: phpBB 3.0.12 / board3_portal_2.0.1 / prosilver / phpbb_gallery_1_1_6 / Kalender alightner 0_1_0 / Tapatalk_pb30_4_2_0

Benutzeravatar
willi2010
Mitglied
Beiträge: 144
Registriert: 09.05.2010 19:22
Kontaktdaten:

Re: Update, aber wo anfangen?

Beitrag von willi2010 »

Ich muss ja vor der Installation des Upgrades alle alten Mods entfernen.

Ich habe auch ein phpGallerie-Mod mit ca. 2.000 Bildern.

Sind die dann auch alle weg??

Vielen Danke für euren Rat.
Viele Grüße
Klaus KF2, das Forum für Kreuzfahrt-Freunde
Versionen: phpBB 3.0.12 / board3_portal_2.0.1 / prosilver / phpbb_gallery_1_1_6 / Kalender alightner 0_1_0 / Tapatalk_pb30_4_2_0

Benutzeravatar
vfrblue
Supporter
Supporter
Beiträge: 1784
Registriert: 22.11.2016 18:46
Wohnort: Niedersachsen-West
Kontaktdaten:

Re: Update, aber wo anfangen?

Beitrag von vfrblue »

Hallo, wenn du diese phpBB Gallery von "nickvergessen" hast, solltest du erst auf phpBB 3.1.11 updaten, damit du die Gallery nach dieser Anleitung übernehmen kannst. Danach kann man auf die aktuelle Gallery für phpBB 3.2.1 updaten. Diese Version ist aber noch nicht validiert und deswegen ist der Einsatz in einem Liveboard auf eigene Gefahr.
Gruß Hermann

phpBB-Styles, Skins, Themes by VT-Theme
Forum VFR-OC

Benutzeravatar
willi2010
Mitglied
Beiträge: 144
Registriert: 09.05.2010 19:22
Kontaktdaten:

Re: Update, aber wo anfangen?

Beitrag von willi2010 »

Danke für die schnelle Antwort.

Also alles etwas langsam angehen lassen....
Viele Grüße
Klaus KF2, das Forum für Kreuzfahrt-Freunde
Versionen: phpBB 3.0.12 / board3_portal_2.0.1 / prosilver / phpbb_gallery_1_1_6 / Kalender alightner 0_1_0 / Tapatalk_pb30_4_2_0

Benutzeravatar
vfrblue
Supporter
Supporter
Beiträge: 1784
Registriert: 22.11.2016 18:46
Wohnort: Niedersachsen-West
Kontaktdaten:

Re: Update, aber wo anfangen?

Beitrag von vfrblue »

Auf phpBB 3.1.11 kann man allemal updaten. Die Gallery-Version ist validiert und man kann dann ausgiebig testen, ob alles übernommen wurde. Auch der Schritt von 3.1.11 auf 3.2.1 ist dann nicht mehr so groß.
Gruß Hermann

phpBB-Styles, Skins, Themes by VT-Theme
Forum VFR-OC

Antworten

Zurück zu „Support-Forum“