[3.3] Mod kompatibilität

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.2 und höher und die Konvertierung zu phpBB 3.3.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.3] oder [3.2] angeben
MDuss
Mitglied
Beiträge: 231
Registriert: 06.02.2008 10:21

[3.3] Mod kompatibilität

Beitrag von MDuss »

Hallo.

Ich habe da eine kleine Frage.
Wie sieht es mit der Modkompatibilität allgemein aus?
Sind die Mods aus der Version 3.2.X kompatibel zu Version 3.3.x oder nicht?

Mache gerade noch ein Update auf Version 3.2.9.

Allerdings sehe ich hier auch, dass es noch etliche Probleme zu geben scheint mit Version 3.3.0, so dass ich eventuell noch warte, bis Version 3.3.1 oder so draußen ist, bisa ich auf 3.3.x update.

MfG
MDuss

Benutzeravatar
Kirk
Supporter
Supporter
Beiträge: 6790
Registriert: 24.05.2010 08:31
Kontaktdaten:

Re: [3.3] Mod kompatibilität

Beitrag von Kirk »

Hallo
Nur so am Rande seit 3.1 gibt kein Mod mehr sondern Erweiterungen.
Zu deiner Frage, das lässt sich pauschal nicht beantworten es kommt auf die Erweiterung an, meistens gibt es bei den .yml Dateien Probleme, diese kannst du mit damit testen.

MDuss
Mitglied
Beiträge: 231
Registriert: 06.02.2008 10:21

Re: [3.3] Mod kompatibilität

Beitrag von MDuss »

Danke dir Kirk.

Dann werde ich mir diese Erweiterung mal näher ansehen und testen.

MfG
MDuss

Benutzeravatar
-motte-
Mitglied
Beiträge: 236
Registriert: 22.08.2006 18:36
Wohnort: Lüdinghausen
Kontaktdaten:

Re: [3.3] Mod kompatibilität

Beitrag von -motte- »

Ich hab das Update gestern gemacht, läuft alles, auch meine genutzten Extensions laufen soweit. Sollte was nicht passen, bekommt du beim aktivieren im ACP einen Hinweis.

Aus meinen geringen Erfahrungen kann ich dir dann aber sagen, sollte eine Extension was "sagen" solltest du in der entsprechenden Extension in dem Ordner /config die services.yml bearbiten. Mir ist aufgefallen, das einige Schreiber dort die ' ' für die Argumente weglassen, siehe folgende

Alt:

Code: Alles auswählen

        arguments:
            - @config
            - @request
            - @template
            - @user
            -
            -
            -


Neu:

Code: Alles auswählen

        arguments:
            - '@config'
            - '@request'
            - '@template'
            - '@user'
            - ' '
            - ' '
            - ' '


Nach dem Anpassen ließen sich entsprechende Extensions dann aktivieren und fehlerfrei nutzen ...
Hoffe das hilft dir und war soweit korrekt beobachtet.

LG Ralph
Zonderling ...

MDuss
Mitglied
Beiträge: 231
Registriert: 06.02.2008 10:21

Re: [3.3] Mod kompatibilität

Beitrag von MDuss »

Danke -motte-

Ich werde das dann mal am Wochenende mit meinem Testforum versuchen.

MfG
MDuss

MDuss
Mitglied
Beiträge: 231
Registriert: 06.02.2008 10:21

Re: [3.3] Mod kompatibilität

Beitrag von MDuss »

Hi.

Wollte nur mal kurz Rückmeldung geben, dass alles funktioniert hat, und alle Erweiterungen weiter laufen.
Mit dem Tool das Kirk verlinkt hat, konnte ich schnell die fehlerhaften Stellen der .yml Dateien finden und korrigieren.

Wie -motte- schon beschrieben hatte waren es nur die fehlenden '' bei den Argumenten.
Bis auf einmal, wo ich pattern durch path ersetzen musste.

Ansonsten hat alles gepasst. phpbb 3.3.0 läuft, die Erweiterungen laufen auch, also alles paletti. :grin:

MfG
MDuss

thera-pi
Mitglied
Beiträge: 11
Registriert: 17.01.2020 21:29

Re: [3.3] Mod kompatibilität

Beitrag von thera-pi »

Von David Wood gibt es eine sehr hilfreiche ext zur Anpassung vorhandener ext unter 3.3

Mal nach extservicescheck googlen - damit konnte ich im Handumdrehen 5-6 ext auf 3.3 anpassen.

Das Teil war mir sogar eine Spende wert! :wink:

MDuss
Mitglied
Beiträge: 231
Registriert: 06.02.2008 10:21

Re: [3.3] Mod kompatibilität

Beitrag von MDuss »

thera-pi hat geschrieben:
19.01.2020 12:06
Von David Wood gibt es eine sehr hilfreiche ext zur Anpassung vorhandener ext unter 3.3

Mal nach extservicescheck googlen - damit konnte ich im Handumdrehen 5-6 ext auf 3.3 anpassen.

Das Teil war mir sogar eine Spende wert! :wink:
Ich denke mal das ist die hier? https://www.phpbb.com/community/viewtop ... &t=2528456
Die habe ich auch verwendet, ist die, welche Kirk oben verlinkt hat.

Was mich allerdings etwas wundert:
Wenn ich eine Extension jetzt aktiviere oder deaktiviere, dann lande ich nach der Aktivierung bzw. Deaktivierung wieder auf der Hauptseite des Forums selbst.
Wenn ich bisher eine Extension aktiviert oder deaktiviert habe, dann landete ich aber immer im ACP auf dem Register "Anpassen", also dort, von wo ich die Erweiterung aktiviert bzw. deaktiviert habe.

MfG
MDuss

thera-pi
Mitglied
Beiträge: 11
Registriert: 17.01.2020 21:29

Re: [3.3] Mod kompatibilität

Beitrag von thera-pi »

MDuss hat geschrieben:
19.01.2020 13:03

Ich denke mal das ist die hier? https://www.phpbb.com/community/viewtop ... &t=2528456
Die habe ich auch verwendet, ist die, welche Kirk oben verlinkt hat.

MfG
MDuss
Upps, hatte ich übersehen...

MDuss
Mitglied
Beiträge: 231
Registriert: 06.02.2008 10:21

Re: [3.3] Mod kompatibilität

Beitrag von MDuss »

Kein Problem.

Hauptsache es funktioniert jetzt.
Das einzige was mir noch etwas komisch vorkommt ist die Sache dass ich nach Aktivierung bzw. Deaktivierung einer bel. Erweiterung nicht mehr im ACP auf dem Register "Anpassen" bin, sondern direkt ins normale Forum komme. Also ich bin ganz aus dem ACP draußen, und lande auf der Hauptseite des Forums.

Aber bis aus diese eine Sache läuft soweit alles OK. Zumindest was ich bisher so getestet und gesehen habe.

MfG
MDuss

Antworten

Zurück zu „Support-Forum“