[3.3] Probleme beim Update auf und mit 3.3.1

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.2 und höher und die Konvertierung zu phpBB 3.3.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.3] oder [3.2] angeben
Gesperrt
Benutzeravatar
Dr.Death
Moderator
Moderator
Beiträge: 16439
Registriert: 23.04.2003 08:22
Wohnort: Xanten
Kontaktdaten:

[3.3] Probleme beim Update auf und mit 3.3.1

Beitrag von Dr.Death »

1. Probleme mit Beitragsfunktionen (Löschen, Melden, Ändern etc.) in Mobiler Ansicht und anderer Mobile-Dropdown-Menüs
Nach dem Update auf phpBB 3.3.1 kann auf manchen Endgeräten im Admin-Bereich oder in der Themenansicht das DropDown-Menü fehlerhaft sein. Schuld ist ein Fehler im JavaScript-Code der forum_fn.js und admin.js, der durch das Update auf jQuery 3.5.1 ausgelöst wurde. Sieht ungefähr so aus:
IMG_20200809_212652.jpg

Lösung:
Es gibt einen ersten Patch: https://github.com/phpbb/phpbb/pull/6033/files

2. HTTP 500 Fehler beim Update auf 3.3.1, wenn mChat und Advanced Code Box 3 aktiv sind
Im Moment kommt es einem Fehler mit einer "kreisabhängigkeit", wenn der ein CronJob an dem Controller-Helper-Service hängt. Bisher ist das nur als Problem aufgefallen, wenn im Board sowohl mChat und die Advanced Code Box 3 aktiv waren.
Der Fehler sieht z. B. so aus:

Code: Alles auswählen

PHP Fatal error:  Uncaught Symfony\Component\DependencyInjection\Exception\ServiceCircularReferenceException: Circular reference detected for service "dmzx.mchat.cron.task.mchat_prune", path: "dmzx.mchat.cron.task.mchat_prune -> dmzx.mchat.cron.task.mchat_prune". in /vendor/symfony/dependency-injection/Container.php:297
Lösung:
Bisher bleibt dir nichts anderes übrig, als eine von beiden Extensions zu deaktivieren.

3. Problem: Nicht unterstützte PHP Version

Wenn Deine PHP-Version kleiner als PHP 7.1.3 ist, kannst Du phpBB 3.3.1 nicht installieren und benutzen.
Wenn Du eine nicht unterstützte PHP Version verwendest, erhält du folgende Fehlermeldung:

Code: Alles auswählen

You are running an unsupported PHP version. Please upgrade to PHP 7.1.3 or higher before trying to install or update to phpBB 3.3
Lösung:
Aktualisiere Deine PHP-Version auf 7.1.3 oder höher. Möglicherweise musst Du Deinen Hoster dazu auffordern oder einfach eine Einstellung im Steuerungsfeld Ihrer Website ändern. Beachte bitte, dass PHP-Versionen manchmal für einzelne Verzeichnisse unterschiedlich eingestellt werden können. Wenn Du diese Fehlermeldung erhältst, wird in diesem Ordner noch eine alte Version ausgeführt. Um dies zu testen, erstelle eine PHP-Datei mit den folgenden Inhalten, um Deine Version anzuzeigen: <?php phpinfo();


4. Problem: Inkompatible Extension / Erweiterung

Wenn Du die folgende Fehlermeldung erhältst, bedeutet dies, dass eine Erweiterung eine veraltete Service Konfiguration verwendet:

Code: Alles auswählen

Exception: The file "/path/to/forum/ext/<author>/<extension name>/config/services.yml" does not contain valid YAML: The reserved indicator "@" cannot start a plain scalar; you need to quote the scalar at line <number> (near "- @config").
Dieser Definitionsstil war in phpBB 3.2.0 bereits veraltet, aber noch zulässig und wird ab phpBB 3.3.0 nicht mehr unterstützt.

Lösung:
Beziehe eine aktualisierte Version der Extension / Erweiterung vom Autor. Poste NICHT im Support-Forum über dieses Problem.


5. Problem: Das Installationsprogramm hat eine Zeitüberschreitung festgestellt.
Wenn Du diese Meldung nach wenigen Sekunden erhältst, überprüfe das Fehlerprotokoll Deines Servers (nicht das von phpBB), um festzustellen, ob ein unterdrückter PHP-Fehler vorliegt der behoben werden muss.
Wenn dies nach ungefähr 30 Sekunden auftritt, müsstest Du möglicherweise den PHP-Timeout-Wert erhöhen oder die Befehlszeilenmethode zum Aktualisieren verwenden.


6. Problem: Veraltetes Sprachpaket
Auf einigen Seiten wird oben der folgende Fehler angezeigt:

Code: Alles auswählen

[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/language/language.php on line <number>: vsprintf(): Too few arguments
Lösung:
Aktualisiere Dein Sprachpaket auf eines, das mit phpBB 3.3.1 kompatibel ist.
Zuletzt geändert von Crizzo am 09.08.2020 22:44, insgesamt 1-mal geändert.
Benutzeravatar
Dr.Death
Moderator
Moderator
Beiträge: 16439
Registriert: 23.04.2003 08:22
Wohnort: Xanten
Kontaktdaten:

Re: [3.3] Häufige Probleme beim Update auf 3.3.0

Beitrag von Dr.Death »

Problem: Failure while aqcuiring locks (Strato-Webhost)
Es wurde berichtet, dass Benutzer des Webhosts Strato die folgende Fehlermeldung erhalten:

Code: Alles auswählen

PHP Fatal error:  Uncaught phpbb\\exception\\http_exception: Failure while aqcuiring locks.
Dieser Webhost hat mehrere Behauptungen aufgestellt, warum dies auftritt:
  • Die Argon2 PHP-Erweiterung fehlt
  • Es ist ein Datenbankproblem
Keines von diesen verursacht das Problem.

Lösung:
Update auf phpBB 3.3.1.
Benutzeravatar
Crizzo
Administrator
Administrator
Beiträge: 10992
Registriert: 19.05.2005 21:45
Kontaktdaten:

Re: [3.3] Probleme beim Update auf und mit 3.3.1

Beitrag von Crizzo »

Update 09.08.2020:
  • Probleme mit mChat und Advanced BBCode Box 3
  • Probleme mit Mobile Dropdowns
Gesperrt

Zurück zu „Support-Forum“