[3.3] Suche will nicht?

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.2 und höher und die Konvertierung zu phpBB 3.3.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.3] oder [3.2] angeben
Benutzeravatar
BNa
Valued Contributor
Beiträge: 2702
Registriert: 12.04.2010 23:51
Kontaktdaten:

Re: [3.3] Suche will nicht?

Beitrag von BNa »

Brender hat geschrieben:
08.11.2020 21:26
Das habe ich probiert aber das funktioniert nicht. Jetzt geht es ja ums löschen und nicht ums erstellen. Welcher Wert ist in der Datenbank für's löschen zuständig? Der search_indexing_state scheint nur für das erstellen zuständig zu sein?
Leere (nicht lösche) die relevanten 3 Tabellen manuell via phpmyadmin....

phpbb_search_wordlist
phpbb_search_wordmatch
phpbb_search_results

Info: https://www.phpbb.com/community/viewtop ... &t=2170630

...und dann versuche es nochmal.
Brender
Mitglied
Beiträge: 153
Registriert: 02.02.2015 18:33

Re: [3.3] Suche will nicht?

Beitrag von Brender »

Habe ich gemacht. Danach habe ich bei search_indexing_state die 0 gesetzt und ich konnte wieder auf die MySQL Indexierung gehen. Leider kommt sofort wieder ein Fehler. Nur nochmal zu meinem Verständnis: In der config.php sollte man nur das "i" ergänzen oder? Nicht das ich was übersehen oder nicht richtig verstanden habe?

Code: Alles auswählen

Allgemeiner Fehler
SQL ERROR [ mysqli ]

Duplicate entry 'search_indexing_state' for key 'PRIMARY' [1062]

SQL

INSERT INTO phpbb3_config (config_name, config_value, is_dynamic) VALUES ('search_indexing_state', '\\phpbb\\search\\fulltext_mysql,create,0', 0)

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 1023
CALL: trigger_error()

FILE: [ROOT]/phpbb/db/driver/mysqli.php
LINE: 195
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/phpbb/db/driver/factory.php
LINE: 345
CALL: phpbb\db\driver\mysqli->sql_query()

FILE: [ROOT]/phpbb/config/db.php
LINE: 161
CALL: phpbb\db\driver\factory->sql_query()

FILE: [ROOT]/phpbb/config/db.php
LINE: 122
CALL: phpbb\config\db->set_atomic()

FILE: [ROOT]/includes/acp/acp_search.php
LINE: 602
CALL: phpbb\config\db->set()

FILE: [ROOT]/includes/acp/acp_search.php
LINE: 302
CALL: acp_search->save_state()

FILE: [ROOT]/includes/acp/acp_search.php
LINE: 46
CALL: acp_search->index()

FILE: [ROOT]/includes/functions_module.php
LINE: 676
CALL: acp_search->main()

FILE: [ROOT]/adm/index.php
LINE: 81
CALL: p_master->load_active()
Benutzeravatar
BNa
Valued Contributor
Beiträge: 2702
Registriert: 12.04.2010 23:51
Kontaktdaten:

Re: [3.3] Suche will nicht?

Beitrag von BNa »

Soweit wie ich das verstanden habe, das i wegnehmen.
Da es aber scheinbar bei Dir ein "Special-Problem" gibt,
empfehle ich die Jobbbörse
, falls das hier nicht weiter fruchtet...
Benutzeravatar
Dr.Death
Moderator
Moderator
Beiträge: 16476
Registriert: 23.04.2003 08:22
Wohnort: Xanten
Kontaktdaten:

Re: [3.3] Suche will nicht?

Beitrag von Dr.Death »

Zu allererst:
Ein Datenbank Backup erstellen.

Ins Blaue geschossen (nicht getestet):
In der Tabelle phpbb3_config die Zeile mit search_indexing_state löschen.

Code: Alles auswählen

DELETE FROM phpbb3_config where config_name=search_indexing_state
Die im vorherigen Beitrag genannten Schritte wiederholen.
Brender
Mitglied
Beiträge: 153
Registriert: 02.02.2015 18:33

Re: [3.3] Suche will nicht?

Beitrag von Brender »

Also, hab mir das nochmal durchgelesen. Natürlich muss das "i" weg, nicht hin :roll: . Hab ich sofort wieder abgeändert. Dann den Befehl vom Doc ausgeführt und alles nochmal gelöscht.

Die Indizierung lief dann an. Nach etwa 1ner Minute bekam ich erneut nen SQL Fehler. Post Text Dublicate. Warum issn da alles irgendwie doppelt?!

Code: Alles auswählen

Allgemeiner Fehler
SQL ERROR [ mysqli ]

Duplicate key name 'post_text' [1061]

SQL

ALTER TABLE phpbb3_posts ADD FULLTEXT post_text (post_text)

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 1023
CALL: trigger_error()

FILE: [ROOT]/phpbb/db/driver/mysqli.php
LINE: 195
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/phpbb/db/driver/factory.php
LINE: 345
CALL: phpbb\db\driver\mysqli->sql_query()

FILE: [ROOT]/phpbb/search/fulltext_mysql.php
LINE: 1052
CALL: phpbb\db\driver\factory->sql_query()

FILE: [ROOT]/includes/acp/acp_search.php
LINE: 371
CALL: phpbb\search\fulltext_mysql->create_index()

FILE: [ROOT]/includes/acp/acp_search.php
LINE: 46
CALL: acp_search->index()

FILE: [ROOT]/includes/functions_module.php
LINE: 676
CALL: acp_search->main()

FILE: [ROOT]/adm/index.php
LINE: 81
CALL: p_master->load_active()
Brender
Mitglied
Beiträge: 153
Registriert: 02.02.2015 18:33

Re: [3.3] Suche will nicht?

Beitrag von Brender »

So, nachdem ich das auch gelöscht hatte ist es erstmal weiter durchgelaufen. Dann kam ein 500er Server Fehler wegen Zeitüberschreitung. Nachdem ich das aktualisiert hatte stand dann dort das alle Beiträge Indiziert wurden.

Könnte auch hinkommen: MySQL Fulltext Statistik Insgesamt indizierte Beiträge: 164738
Sind ja jetzt nicht gerade wenig Beiträge. Also könnte es durchgelaufen sein?
In der Board Statistik steht auch eine Anzahl von Beiträge: 164068

Allerdings steht jetzt bei "phpBB Native Fulltext (aktiv)" immer noch das "aktiv". Könnte also sein das es doch nicht komplett durchgelaufen ist?

Edit: Ah sorry, ich wusste nicht das man das manuell umstellen muss. Jetzt ist MySQL aktiv...
Benutzeravatar
BNa
Valued Contributor
Beiträge: 2702
Registriert: 12.04.2010 23:51
Kontaktdaten:

Re: [3.3] Suche will nicht?

Beitrag von BNa »

Also, können wir jetzt davon ausgehen, das Dein Problem gelöst ist ? :geek:
Brender
Mitglied
Beiträge: 153
Registriert: 02.02.2015 18:33

Re: [3.3] Suche will nicht?

Beitrag von Brender »

Nach jetzt mehreren testen könnt ihr davon ausgehen.

Ich danke euch!!!! :grin:
Antworten

Zurück zu „Support-Forum“