[3.3] Problem beim Update 3.3.2 auf 3.3.3

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.2 und höher und die Konvertierung zu phpBB 3.3.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.3] oder [3.2] angeben
Dler
Mitglied
Beiträge: 98
Registriert: 28.10.2018 10:49

[3.3] Problem beim Update 3.3.2 auf 3.3.3

Beitrag von Dler »

Hi,

Ich wollte in meinem Testforum 3.3.2 auf 3.3.3 updaten.

Habe das englische Komplett Paket runtergeladen, alle dateien laut anleitung auf dem FTP gelöscht und dann das Paket hochgeladen.

Update wurde ohne fehler beendet.

Jetzt erhalte ich allerdings im ACP diese meldung.

Default charset is improperly configured
default_charset must be set to UTF-8. You can check the current value on the PHP information page.

Ich hoffe ihr könnt mir weiterhelfen wo es genau hakt.

Vielen dank.
Benutzeravatar
BNa
Valued Contributor
Beiträge: 2750
Registriert: 12.04.2010 23:51
Kontaktdaten:

Re: [3.3] Problem beim Update 3.3.2 auf 3.3.3

Beitrag von BNa »

Stelle das Charset all Deiner phpbb-Tabellen in Deinem phpMyAdmin auf utf8-bin um.
Vorher aber ein Backup deiner Datenbank machen :geek:
Dler
Mitglied
Beiträge: 98
Registriert: 28.10.2018 10:49

Re: [3.3] Problem beim Update 3.3.2 auf 3.3.3

Beitrag von Dler »

Das war aber vorher nicht. Warum jetzt aufeinmal.

Meinst du die Kollation ?

Die stehen bei mir alle auf utf8_bin

[ externes Bild ]
Dler
Mitglied
Beiträge: 98
Registriert: 28.10.2018 10:49

Re: [3.3] Problem beim Update 3.3.2 auf 3.3.3

Beitrag von Dler »

Was muss ich jetzt bitte machen damit der Fehler weg ist?
Benutzeravatar
Mike-on-Tour
Junior Supporter
Beiträge: 332
Registriert: 13.01.2020 21:09

Re: [3.3] Problem beim Update 3.3.2 auf 3.3.3

Beitrag von Mike-on-Tour »

Ist die Datenbank selbst auch auf diese Kollation eingestellt? Oder hat die was anderes?
(Kannst du sehen, wenn du dir in phpMyAdmin die Datenbanken anzeigen lässt)
Dler
Mitglied
Beiträge: 98
Registriert: 28.10.2018 10:49

Re: [3.3] Problem beim Update 3.3.2 auf 3.3.3

Beitrag von Dler »

Wo genau sehe ich das in der Datenbank ?

Meinst du das hier?

[ externes Bild ]
Benutzeravatar
Mike-on-Tour
Junior Supporter
Beiträge: 332
Registriert: 13.01.2020 21:09

Re: [3.3] Problem beim Update 3.3.2 auf 3.3.3

Beitrag von Mike-on-Tour »

Ja, das Dropdown-Feld im Bild rechts oben.
Da müsste auch UTF-8 auswählbar sein, aber nicht vergessen, vorher ein Backup der Datenbank zu machen.
Dler
Mitglied
Beiträge: 98
Registriert: 28.10.2018 10:49

Re: [3.3] Problem beim Update 3.3.2 auf 3.3.3

Beitrag von Dler »

Dadurch hat sich leider nichts geändert nach umstellung.
Benutzeravatar
Crizzo
Administrator
Administrator
Beiträge: 11219
Registriert: 19.05.2005 21:45
Kontaktdaten:

Re: [3.3] Problem beim Update 3.3.2 auf 3.3.3

Beitrag von Crizzo »

Hi,

was ist denn in deiner php.ini unter diesem Punkt:

Code: Alles auswählen

; PHP's default character set is set to UTF-8.
; http://php.net/default-charset
default_charset="UTF-8"
eingestellt?

Wenn du keinen Zugriff auf die php.ini hast, rufe folgende Datei auf (per Browser): www.example.org/install/phpinfo.php und schaue nach diesem Eintrag: default_charset
Sieht z.B. so aus:

Code: Alles auswählen

default_charset	no value	UTF-8
Grüße
Dler
Mitglied
Beiträge: 98
Registriert: 28.10.2018 10:49

Re: [3.3] Problem beim Update 3.3.2 auf 3.3.3

Beitrag von Dler »

Danke. Habe phpinfo.php aufgerufen da ich nur webhosting habe und keinen eigenen Server.

Wenn ich default_charset suche, dann kommt dies

Code: Alles auswählen

default_charset	no value	no value
Antworten

Zurück zu „Support-Forum“