[3.2] Gründe für das Update auf 3.3

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.2 und höher und die Konvertierung zu phpBB 3.3.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.3] oder [3.2] angeben
Antworten
stefan-franz
Mitglied
Beiträge: 321
Registriert: 24.02.2019 13:22

[3.2] Gründe für das Update auf 3.3

Beitrag von stefan-franz »

Hallo allerseits,

mein Board läuft derzeit unter 3.2.8
Welchen Vorteil hätte ich bei einem Update auf die 3.3.3?
Lg Stefan Franz
Benutzeravatar
Mike-on-Tour
Junior Supporter
Beiträge: 434
Registriert: 13.01.2020 21:09
Kontaktdaten:

Re: [3.2] Gründe für das Update auf 3.3

Beitrag von Mike-on-Tour »

Zum Beispiel wärst du mit phpBB 3.3.x auf der sicheren Seite, wenn dein Hoster die installierte PHP-Version von 7.1 oder 7.2 (das ist die höchstmögliche Version für phpBB 3.2.x) auf 7.3 oder (eher wahrscheinlich) 7.4 updatet.
PHP 7.1 ist bereits veraltet, und für 7.2 läuft der Support (momentan nur noch Sicherheits-Updates) zum Jahresende aus.

Mit der aktuellen Version wärest du zukunftsorientiert sogar in der Lage das neueste PHP 8.0.5 zu nutzen, da würde ich aber erstmal testen, was die installierten Erweiterungen sagen, nicht alle sind schon PHP 8 tauglich.
stefan-franz
Mitglied
Beiträge: 321
Registriert: 24.02.2019 13:22

Re: [3.2] Gründe für das Update auf 3.3

Beitrag von stefan-franz »

PHP 7.4 läuft bei mir momentan auf der 3.2.8
Lg Stefan Franz
Benutzeravatar
Mike-on-Tour
Junior Supporter
Beiträge: 434
Registriert: 13.01.2020 21:09
Kontaktdaten:

Re: [3.2] Gründe für das Update auf 3.3

Beitrag von Mike-on-Tour »

Dann freue dich, da habe ich auch schon anderes gelesen.
Benutzeravatar
HaioPaio
Mitglied
Beiträge: 164
Registriert: 05.11.2017 21:42

Re: [3.2] Gründe für das Update auf 3.3

Beitrag von HaioPaio »

Stefan-Franz
Ich verwende die neuesten Updates da die alten Versionen keine Sicherheitsupdates bekommen und es bereits einige bekannte Schwachstellen gibt die in der neuesten Version behoben sind. Als Datenverarbeiter bin ich gesetzlich verpflichtet die Daten der User sorgfältig zu schützen.
Zum anderen gibt es keinen Support für Probleme mit alten Versionen die Über die Hilfe beim Upgrade auf die aktuelle Version benötigt wird.

Deine beschränkte Erfahrung steht gegen die Aussage der Entwickler dass 3.2.8 nicht mit php7.4 vollständig kompatibel ist.
Es gibt die realistische Gefahr dass dein Forum von heute auf morgen Probleme bekommt.
So etwas wollte ich mir und den Usern nicht antun.

Das waren nun meine Gründe für meinen Upgrade auf 3.3
www.der-räuchertreff.de phpbb 3.3.3 php 7.4.15
Passat
Mitglied
Beiträge: 565
Registriert: 26.03.2008 17:50

Re: [3.2] Gründe für das Update auf 3.3

Beitrag von Passat »

Bei mir waren die Gründe ähnlich:
- keine Sicherheitsupdates mehr für phpbb 3.2
- kein offizieller Support von phpbb 3.2 für php 7.3/7.4/8.0, der Support von php 7.2 endete schon im November 2020, seit dem gibt es keine Sicherheitsupdates mehr für php 7.2.
D.H., sowohl phpbb also die offiziell maximal unterstützte php-Version bekommen keine Sicherheitsupdates mehr.
- alle meine installierten Extensions laufen auch mit phpbb 3.3
- Irgendwann muß man eh auf eine höhere phpbb-Version updaten, warum nicht gleich?
- und lt. DSGVO ist man eh gezwungen, Software, die personenbezogene Daten verarbeitet, sicherheitstechnisch aktuell zu halten.
Ein Betrieb von phpbb kleiner 3.3.2 (3.3.3/3.3.4 bringen keine Sicherheitsupdates) und php kleiner 7.3.28 ist daher ein Verstoß gegen die DSGVO.
stefan-franz
Mitglied
Beiträge: 321
Registriert: 24.02.2019 13:22

Re: [3.2] Gründe für das Update auf 3.3

Beitrag von stefan-franz »

Hab mittlerweile auf die 3.3.4 upgedated.

Alle läuft auf Strato wenn man eine php.ini im root Verzeichnis erstellt mit dem Eintrag:

; PHP's default character set is set to UTF-8.
; http://php.net/default-charset
default_charset="UTF-8"

Lg Stefan
Lg Stefan Franz
Antworten

Zurück zu „Support-Forum“