phpbb-ext-gallery von nickvergessen

Du hast Probleme beim Installieren oder bei der Benutzung einer Extension? In diesem Forum bist du richtig.
Forumsregeln
Bei Fragen zu einer bestimmten Extension sind Extension-Name und die Downloadquelle der Extension erforderlich. Letztere in Form der URL zum Download. Hiervon kann lediglich bei sehr bekannten und verbreiteten Extensions abgesehen werden, soweit eindeutig ist, um welche Extension es sich handelt. Es liegt allerdings im Ermessen der Moderatoren, das Thema ggf. zu schließen, daher sollte im Zweifel der Link angegeben werden.
pitter46
Mitglied
Beiträge: 106
Registriert: 16.06.2012 13:33

phpbb-ext-gallery von nickvergessen

Beitragvon pitter46 » 26.10.2014 11:28

Hallo,

ich habe zur Zeit phpbb 3.1 RC6 installiert und schon einige Extensionen eingefügt.
Nun würde ich auch gerne die Extension von nickvergessen: "phpbb-ext-Gallery" dazu nutzen.
Leider bekomme ich es nicht hin.
Ich habe von: https://github.com/nickvergessen/phpbb-ext-gallery die Extension geladen und auf meinen Server ins dir "ext" kopiert.
Bei dem Versuch die Extension zu aktivieren sehe ich im Administrationsbereich unter Anpassen-Erweiterungen verwalten bereits diese Meldung:

"Die Erweiterung „phpbbgallery/core“ ist ungültig.
Erforderliches Meta-Feld license wurde nicht angegeben."

und kann dadurch die Extension nicht aktivieren.

Hat vielleicht schon jemand Erfahrung mit der Gallery-Installation?
Vielleicht hat jemand einen Tipp für mich?

Meine bisherige Installation von phpbb 3.1 RC6 Demo: http://www.klein-leverkusen.de/forumphpbb31/portal

Vielen Dank im voraus
Pitter46

Benutzeravatar
Kirk
Supporter
Supporter
Beiträge: 6348
Registriert: 24.05.2010 08:31
Kontaktdaten:

Re: phpbb-ext-gallery von nickvergessen

Beitragvon Kirk » 26.10.2014 12:36

Hallo
Ändere Mal in der composer.json das hier:

Code: Alles auswählen

licence

in:

Code: Alles auswählen

license

um.

pitter46
Mitglied
Beiträge: 106
Registriert: 16.06.2012 13:33

Re: phpbb-ext-gallery von nickvergessen

Beitragvon pitter46 » 26.10.2014 13:13

Vielen Dank,
das hat geholfen. Die Meldung ist fort. Trotzdem kann ich es nicht aktivieren.
Es erscheint folgende Fehlermeldung:

Information
Die ausgewählte Erweiterung ist nicht mit deinem Board kompatibel. Bitte prüfe auf der Details-Seite, ob deine phpBB- und PHP-Version unterstützt werden.
« Zurück zur vorherigen Seite

Die Detailseite zeigt folgende Information:


Keine Informationen zur Abfrage der neuesten Version vorhanden.
Informationen zur Erweiterung
Angezeigter Name:
phpBB Gallery Core
Technischer Name:
phpbbgallery/core
Beschreibung:
Experimental version of phpBB Gallery for phpBB 3.1
Version:
0.1.0

Homepage:
https://github.com/nickvergessen/phpbb-ext-gallery

Veröffentlichungszeitpunkt:
2013-03-27

Lizenz:
GPL-2.0

Voraussetzungen

PHP-Version: (Hier fehlt vielleicht ein Eintrag zur PHP Version: "phpbb/phpbb": "3.1.*@dev" ???
>=5.3.3 <-- ist auf Server vorhanden

Informationen zum Autor

Name:
Joas Schilling

E-Mail:
nickvergessen@gmx.de

Homepage:
https://github.com/nickvergessen/

Rolle:
Lead Developer


Gruß
Pitter46

Benutzeravatar
Kirk
Supporter
Supporter
Beiträge: 6348
Registriert: 24.05.2010 08:31
Kontaktdaten:

Re: phpbb-ext-gallery von nickvergessen

Beitragvon Kirk » 26.10.2014 13:53

Ersetze mal den gesamten Inhalt der composer.json durch diesen hier:

Code: Alles auswählen

{
   "name": "phpbbgallery/core",
   "type": "phpbb-extension",
   "description": "Experimental version of phpBB Gallery for phpBB 3.1",
   "homepage": "https://github.com/nickvergessen/phpbb-ext-gallery",
   "version": "0.1.0",
   "time": "2013-03-27",
   "licence": "GPL-2.0",
   "authors": [{
         "name": "Joas Schilling",
         "username": "nickvergessen",
         "email": "nickvergessen@gmx.de",
         "homepage": "https://github.com/nickvergessen/",
         "role": "Lead Developer"
        }
    ],
   "require": {
      "php": ">=5.3.3",
   },
   "extra": {
      "display-name": "phpBB Gallery Core"
            "soft-require": {
                     "phpbb/phpbb": "3.1.*@dev"
            }
    }
}

pitter46
Mitglied
Beiträge: 106
Registriert: 16.06.2012 13:33

Re: phpbb-ext-gallery von nickvergessen

Beitragvon pitter46 » 26.10.2014 14:15

Hat leider nicht funktioniert.
Folgende Fehlermeldung: JSON-Datei konnte nicht dekodiert werden: ./../ext/phpbbgallery/core/composer.json

Gruß
Pitter

Gast234254
Gesperrt
Beiträge: 1999
Registriert: 08.02.2009 22:58

Re: phpbb-ext-gallery von nickvergessen

Beitragvon Gast234254 » 26.10.2014 16:06

An dieser wird zur Zeit aktuell gearbeitet https://github.com/lucifer4o/phpbbgallery/tree/master/core. Letzte Bearbeitung vor 12h.

pitter46
Mitglied
Beiträge: 106
Registriert: 16.06.2012 13:33

Re: phpbb-ext-gallery von nickvergessen

Beitragvon pitter46 » 26.10.2014 16:34

Vielen Dank für den Hinweis.
Habe mir das zip mal runtergeladen.
Installation hat geklappt. Nun kann ich mich auch gedulden.
Auf diese Extension freue ich mich.
Nochmals allen die helfen vielen Dank

Gruß Pitter

Benutzeravatar
schaumi
Mitglied
Beiträge: 104
Registriert: 10.04.2010 17:04
Kontaktdaten:

Re: phpbb-ext-gallery von nickvergessen

Beitragvon schaumi » 03.11.2014 18:52

Ich lese gerade den Thread, da ich unter 3.0.12 die Galerie 1.1.6 von "Nickvergessen" einsetze.
Verstehe ich das nun richtig, das diese Mod in dieser Version nicht mehr unter 3.1.1 einsetzbar ist und nun in das Verzeichnis "ext" eingespielt werden muss.
Da ich viele Bilder in meiner Galerie habe, würde ich auch gerne diese nach 3.1.1 übernehmen.
Wo kann ich entsprechendes nachlesen, habe leider nichts entsprechendes gefunden.
Vielen Dank für eine Aufklärung.
You think you’re safe. You are not.

HJW
Mitglied
Beiträge: 1036
Registriert: 20.04.2007 20:48
Wohnort: 45481 Mülheim an der Ruhr
Kontaktdaten:

Re: phpbb-ext-gallery von nickvergessen

Beitragvon HJW » 03.11.2014 19:07

wintstar hat geschrieben:An dieser wird zur Zeit aktuell gearbeitet https://github.com/lucifer4o/phpbbgallery/tree/master/core. Letzte Bearbeitung vor 12h.

Mehr gibt es davon m.E. nicht. Ich bin überzeugt, dass du deine Bilder übernehmen kannst. Wirst dich allerdings noch ein paar Minuten gedulden müssen. :D

Benutzeravatar
schaumi
Mitglied
Beiträge: 104
Registriert: 10.04.2010 17:04
Kontaktdaten:

Re: phpbb-ext-gallery von nickvergessen

Beitragvon schaumi » 03.11.2014 19:36

HJW hat geschrieben:
wintstar hat geschrieben:An dieser wird zur Zeit aktuell gearbeitet https://github.com/lucifer4o/phpbbgallery/tree/master/core. Letzte Bearbeitung vor 12h.

Mehr gibt es davon m.E. nicht. Ich bin überzeugt, dass du deine Bilder übernehmen kannst. Wirst dich allerdings noch ein paar Minuten gedulden müssen. :D


Vielen Dank für die schnelle Antwort.
Ein neues Update für das Forum aufzusetzen, ohne der Galerie, erscheint mir zu diesem Zeitpunkt nicht sinnvoll, unser Forum braucht die Galerie.
Ich habe mir das Video von "apprentice" von 3.0.x nach 3.1 angeschaut (hier), ging leider nicht auf Mods-Übernahme ein.
Also Gedulden, bis es fertig ist.
You think you’re safe. You are not.


Zurück zu „Extension Support“