SEO Urls V2

In diesem Forum können Mod-Autoren ihre Mods vorstellen, die sich noch im Entwicklungsstatus befinden. Der Einbau in Foren im produktiven Betrieb wird nicht empfohlen.
Forumsregeln
phpBB 2.0 hat das Ende seiner Lebenszeit überschritten
phpBB 2.0 wird nicht mehr aktiv unterstützt. Insbesondere werden - auch bei Sicherheitslücken - keine Patches mehr bereitgestellt. Der Einsatz von phpBB 2.0 erfolgt daher auf eigene Gefahr. Wir empfehlen einen Umstieg auf phpBB 3.0, welches aktiv weiterentwickelt wird und für welches regelmäßig Updates zur Verfügung gestellt werden.
Benutzeravatar
baerenwurm
Mitglied
Beiträge: 285
Registriert: 06.11.2002 16:29
Kontaktdaten:

Beitragvon baerenwurm » 29.05.2008 02:17

Hallo!

Hab eben die Topic Calendar 1.2.2 Mod installiert. Leider zeigt er mir in der overall_header.tpl noch einen calendar.php-Link an - weiß wer, wie ich daraus ein calendar.html machen kann?

Düssi
Mitglied
Beiträge: 367
Registriert: 05.08.2006 16:46
Wohnort: in NRW

Beitragvon Düssi » 02.06.2008 19:20

Ich bräuchte nochmal eure Hilfe:
SEO klappt soweit so gut - jedoch bei einem Thread mit mehreren Seiten kann ich nicht auf die nächste Seite Blättern.

Erste Seite vom Thread heißt sinngemäß:

forum/thread-thema--t1544.html

Möchte ich nun die zweite Seite öffnen (meist unten auf "weiter" kommt der Fehler:

Not Found

The requested URL forum/thread-thema--t1544-50.html was not found on this server.

Eine Dritte Seite wird mit der Endung -100 aufgemacht aber auch nicht gefunden.
Jemand einen Tip für mich ?

Düssi
Mitglied
Beiträge: 367
Registriert: 05.08.2006 16:46
Wohnort: in NRW

Beitragvon Düssi » 09.06.2008 20:18

Hi Folks,

dieser Fehler ist nun behoben.
Kann mir einer einen Tip geben, wo ich die Einstellung für die Anzeige "letzten Beitrag" anpassen kann ?

Wenn ich da auf den letzten Beitrag auf der STartseite klicke und dieser Beitrag liegt im Thread bereits auf der zweiten Seite, fehlt in der Adresse das "-s" ; es wird leider nur mit -50 pder -100 anstatt "-s" ausgegeben.

lirumlarum
Mitglied
Beiträge: 135
Registriert: 21.01.2008 19:10

Beitragvon lirumlarum » 20.07.2008 19:56

Hallo mgutt,

ich verwende die "Add-Ons for SEO URLs V2". Bei der Anzeige des Titel des letzten Themas wird die URL des Beitrags in der Form viewtopic.php?t=68#115 wiedergegeben.

Die korrekte Umschreibung sollte jedoch so ausschauen: ftopic68.html

Die Beitragsseite ist also unter 2 verschiedenen URL's erreichbar. Zur Vermeidung von Duplicate Content möchte ich dieses Problem jedoch umgehen.

Ich verwende folgende htacess: http://www.phpbb.de/viewtopic.php?t=743 ... short+urls

Über Hilfe würde ich mich sehr freuen :grin:

Benutzeravatar
Stemmi
Mitglied
Beiträge: 258
Registriert: 06.07.2001 02:00
Wohnort: Mendig
Kontaktdaten:

Beitragvon Stemmi » 09.08.2008 10:07

Bei mir wird bei dem Mod:
LastTopicOnIndex

Noch immer: http://www.cineglobe.de/forum/viewtopic ... html#14733
Anstatt: http://www.cineglobe.de/forum/watchmen-2009-t1298.html angezeigt.

Jemand eine Idee wie ich das SEO tauglich in die "Titel in der Url" ändern kann?

Vielen Dank!
Bald im Kino
"Brüder, in der Ewigkeit wird man sich eurer Taten erinnern! "

Janer
Mitglied
Beiträge: 8
Registriert: 10.08.2008 15:47

Beitragvon Janer » 10.08.2008 15:57

Hallo zusammen,

ich suche jemanden der mir hilft, vielleicht auch gegen ein kleines Entgeld, den mod rewrite und die Add-Ons for SEO URLs V2 auf mein Forum zu integrieren. Über Hilfe würde ich mich sehr freuen.
Das Forum: Hobby Forum - my hobby auf www hobby community de

Gruß Janer

manne35
Mitglied
Beiträge: 26
Registriert: 13.02.2005 23:38
Kontaktdaten:

Beitragvon manne35 » 20.08.2008 15:54

Hallo Janner,
Du hast doch php Version 3 installert un das franzoesische seo dazu phpBB SEO.com ??

Wird es eigentlich eine version dieses Mods hier geben, fuer phpbb3 bei dem die alten URLs bleiben oder eher nicht ?

gruss manne
Schoene Gruesse manne
Heilstein Informationen. Edelsteine Grosshandel http://www.edelsteine.de/shop/index.php und Versand. http://www.heilsteine.info

kriko
Mitglied
Beiträge: 66
Registriert: 22.02.2008 04:29

Beitragvon kriko » 25.08.2008 03:37

hab da ein etwas kleines problem

egal welches forum ich aufmachen will, bekomme ich "The requested document was not found on this server."

und mein 2tes anliegen, wie kann ich den mod "lexicon 2.0.4" in seo v2 einbinden

Benutzeravatar
baerenwurm
Mitglied
Beiträge: 285
Registriert: 06.11.2002 16:29
Kontaktdaten:

Beitragvon baerenwurm » 04.10.2008 23:47

Hallo!

Hat jemand eine Ahnung, wie ich mit der recent.php (Recent Topics Extended MOD) double content vermeiden kann, d.h. solche URLs:
http://www.xyz.de/viewtopic,p,124983.html#124983
wenn man zum neuesten Beitrag des jeweiligen Themas springt?

recent.php:

Code: Alles auswählen

// Zeile 577
$last_url = '<a href="'. append_sid("viewtopic.$phpEx?". POST_POST_URL .'='. $line[$i]['topic_last_post_id']) .'#'. $line[$i]['topic_last_post_id'] .'"><img src="'. $images['icon_latest_reply'] .'" alt="'. $lang['View_latest_post'] .'" title="'. $lang['View_latest_post'] .'" border="0" /></a>';

// und

// Zeile 255
$line = array();

while( $row = $db->sql_fetchrow($result) )

{
   $line[] = $row;
}

$db->sql_freeresult($result);

$template->set_filenames(array('body' => 'recent_body.tpl'));

Benutzeravatar
baerenwurm
Mitglied
Beiträge: 285
Registriert: 06.11.2002 16:29
Kontaktdaten:

Beitragvon baerenwurm » 05.10.2008 19:33

Stimmt das so?

Code: Alles auswählen

$total_pages_topic = ($replies + 1) / $board_config['posts_per_page'] <= 1 ? '' : '&amp;start=' . floor($replies / $board_config['posts_per_page']) * intval($board_config['posts_per_page']);

$last_url = '<a href="' . append_sid("viewtopic.$phpEx?"  . POST_TOPIC_URL . "=$topic_id" . $total_pages_topic) . '#' . $line[$i]['topic_last_post_id'] . '"><img src="' . $images['icon_latest_reply'] . '" alt="' . $lang['View_latest_post'] . '" title="' . $lang['View_latest_post'] . '" border="0" /></a>';


statt

Code: Alles auswählen

$last_url = '<a href="'. append_sid("viewtopic.$phpEx?". POST_POST_URL .'='. $line[$i]['topic_last_post_id']) .'#'. $line[$i]['topic_last_post_id'] .'"><img src="'. $images['icon_latest_reply'] .'" alt="'. $lang['View_latest_post'] .'" title="'. $lang['View_latest_post'] .'" border="0" /></a>';


und für die Foren-Links das:

Code: Alles auswählen

$forum_url = append_sid("viewforum.$phpEx?" . POST_FORUM_URL . "=" . $line[$i]['forum_id'], '', $line[$i]['forum_name']);


statt

Code: Alles auswählen

$forum_url = append_sid("viewforum.$phpEx?". POST_FORUM_URL ."=$forum_id");
?


Zurück zu „phpBB 2.0: Mods in Entwicklung“