phpbb3 V3.0.14 "The /e modifier is no longer supported"

Fragen zur Bedienung von phpBB 3.0.x, Probleme bei der Benutzung und alle weiteren Fragen inkl. Update auf die neuste phpBB 3.0.14 Version
Forumsregeln
phpBB 3.0 hat das Ende seiner Lebenszeit überschritten
phpBB 3.0 wird nicht mehr aktiv unterstützt. Insbesondere werden - auch bei Sicherheitslücken - keine Patches mehr bereitgestellt. Der Einsatz von phpBB 3.0 erfolgt daher auf eigene Gefahr. Wir empfehlen einen Umstieg auf phpBB 3.1, welches aktiv weiterentwickelt wird und für welches regelmäßig Updates zur Verfügung gestellt werden.
Antworten
Roelli
Mitglied
Beiträge: 36
Registriert: 19.03.2006 00:14

phpbb3 V3.0.14 "The /e modifier is no longer supported"

Beitrag von Roelli » 17.10.2019 23:50

Hallo.

Ich habe phpbb3 Version 3.0.14 und da bekomme ich immer folgenden Fehler angezeigt wenn ich auf einen Beitrag klicke:

Code: Alles auswählen

[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[ externes Bild ]

Hat jemand einen Tip wie ich das fixen kann?

Danke!

Roelli.

Benutzeravatar
BNa
Valued Contributor
Beiträge: 2549
Registriert: 12.04.2010 23:51
Kontaktdaten:

Re: phpbb3 V3.0.14 "The /e modifier is no longer supported"

Beitrag von BNa » 18.10.2019 08:31

https://www.phpbb.com/community/viewtop ... #p14314601

Downgrade die php-Version auf Deinem(!) Server auf z.B. 5.6.4.
phpBB 3.0.* läuft nicht mit php 7.*+

Roelli
Mitglied
Beiträge: 36
Registriert: 19.03.2006 00:14

Re: phpbb3 V3.0.14 "The /e modifier is no longer supported"

Beitrag von Roelli » 18.10.2019 15:09

Hmm... das steht schon auf MySQL-Version: "5.6.42".

(die Datenbank liegt bei Strato)
Wenn ich dort auf "PHP-Version einstellen klicken, dann steht da allerdings wieder "Sie verwenden zur Zeit folgende PHP-Version: PHP 7.1"

und einstellen kann ich nur 7.1, 7.2 oder 7.3

Und nun? :oops:

Benutzeravatar
Crizzo
Administrator
Administrator
Beiträge: 10386
Registriert: 19.05.2005 21:45
Kontaktdaten:

Re: phpbb3 V3.0.14 "The /e modifier is no longer supported"

Beitrag von Crizzo » 18.10.2019 15:39

MySQL =deine Datenbank

PHP war gemeint. Wenn du nur 7.1 bis 7.3 zur Auswahl hast, dann stelle es auf 7.2 und mach ein Update auf phpBB3.2.8: https://www.phpbb.de/kb/phpBB32_upgrade_from_30

Antworten

Zurück zu „[3.0.x] Administration, Benutzung und Betrieb“