PHP Version 5 zu klein für Upgrade

Fragen zur Bedienung von phpBB 3.0.x, Probleme bei der Benutzung und alle weiteren Fragen inkl. Update auf die neuste phpBB 3.0.14 Version
Forumsregeln
phpBB 3.0 hat das Ende seiner Lebenszeit überschritten
phpBB 3.0 wird nicht mehr aktiv unterstützt. Insbesondere werden - auch bei Sicherheitslücken - keine Patches mehr bereitgestellt. Der Einsatz von phpBB 3.0 erfolgt daher auf eigene Gefahr. Wir empfehlen einen Umstieg auf phpBB 3.1, welches aktiv weiterentwickelt wird und für welches regelmäßig Updates zur Verfügung gestellt werden.
Sabam
Mitglied
Beiträge: 6
Registriert: 02.03.2019 16:56

PHP Version 5 zu klein für Upgrade

Beitragvon Sabam » 17.04.2019 16:42

Hallo,
ich habe trotz Angst es könnte was schief gehen jetzt versucht auf erstmal phpBB 3.1 zu upgraden.
Ich bekomme aber immer die Fehlermeldung das meine php Version 5.3.3 zu klein sei.
Ich weiß als Laie nicht was ich jetzt machen soll der muss?
Kann mir da wer helfen?

Gruß
Sabam

Benutzeravatar
Kirk
Supporter
Supporter
Beiträge: 6375
Registriert: 24.05.2010 08:31
Kontaktdaten:

Re: PHP Version 5 zu klein für Upgrade

Beitragvon Kirk » 17.04.2019 20:58

Hallo
Von was für eine phpBB Version willst updaten?

Sabam
Mitglied
Beiträge: 6
Registriert: 02.03.2019 16:56

Re: PHP Version 5 zu klein für Upgrade

Beitragvon Sabam » 18.04.2019 12:00

Hi,
ich habe noch die 3.0.14

LG

Benutzeravatar
Kirk
Supporter
Supporter
Beiträge: 6375
Registriert: 24.05.2010 08:31
Kontaktdaten:

Re: PHP Version 5 zu klein für Upgrade

Beitragvon Kirk » 18.04.2019 12:28

phpBB 3.1 benötigt min. PHP 5.3.3 oder höher aber kleiner als PHP 7.0 (PHP 7.0 wird nicht unterstützt)
phpBB 3.2 benötigt min. PHP 5.4.7 oder höher, wenn du die PHP Version auf 5.4.7 setzt sollte es mit dem Update funktionieren, aber nicht auf PHP7.
Eine Anleitung für das Update findest du hier: phpBB 3.2 - Upgrade von phpBB 3.0

Sabam
Mitglied
Beiträge: 6
Registriert: 02.03.2019 16:56

Re: PHP Version 5 zu klein für Upgrade

Beitragvon Sabam » 22.04.2019 17:12

Code: Alles auswählen

wenn du die PHP Version auf 5.4.7 setzt sollte es mit dem Update funktionieren


Das ist es ja ich habe keine Ahnung wie man das macht?

Gruß und frohe Ostern
Sabam

Benutzeravatar
Kirk
Supporter
Supporter
Beiträge: 6375
Registriert: 24.05.2010 08:31
Kontaktdaten:

Re: PHP Version 5 zu klein für Upgrade

Beitragvon Kirk » 22.04.2019 18:03

Bei deinem Hoster hast du bestimmt die Möglichkeit in ein sogenanntes Benutzer Panel einzuloggen, schau mal dort nach ob du dort was umstellen kannst.
Wenn nicht einfach mal bei deinem Hoster nachfragen.

Benutzeravatar
waldkatze
Ehemaliger
Beiträge: 669
Registriert: 08.03.2013 21:50
Wohnort: Oberlausitz

Re: PHP Version 5 zu klein für Upgrade

Beitragvon waldkatze » 22.04.2019 20:06

Immer mehr Hoster setzen die php-Versionen 5.x außer Kraft.
Dir bleiben 3 Möglichkeiten:

1. Gegen Aufpreis pflegen einige Hoster die php-Version 5.x weiter, aber dann eben leider meistens bezahlungspflichtig.

2. Es gibt Möglichkeiten phpBB 3.0.14 mit php 7 lauffähig zu machen.
Das ist aber nicht empfehlenswert !!! Deshalb gebe ich auch keine Anleitung dazu.

3. Denk mal darüber nach dein Forum auf phpBB-Version 3.2.5 zu upgraden.
Läuft bei mir auch mit php 7.2
Siehe: viewtopic.php?t=242083#p1388481
Motorrad fahren, ist die schönste Sache die man angezogen machen kann...
Kein Support per PN oder Mail. Meine MODS / Extensions für phpBB

Sabam
Mitglied
Beiträge: 6
Registriert: 02.03.2019 16:56

Re: PHP Version 5 zu klein für Upgrade

Beitragvon Sabam » 24.04.2019 17:00

Hallo,
habe es mal meinem Hoster geschrieben, und der möchte nun wissen

Code: Alles auswählen

Welchen Motor hast du?
Welches Bedienfeld?
Und welche Version von PHP brauchst du?


Was meint der mit Motor und Bedienfeld ?

Würde mit der PHP Version 5.4.7 auch meine jetzige phpBB3.0 weiterlaufen ?

Benutzeravatar
Mahony
Ehemaliger
Beiträge: 11983
Registriert: 17.11.2005 22:33
Wohnort: Esslingen (Neckar)
Kontaktdaten:

Re: PHP Version 5 zu klein für Upgrade

Beitragvon Mahony » 24.04.2019 17:10

Hallo
Sabam hat geschrieben:Was meint der mit Motor und Bedienfeld ?

DAS solltest du besser deinen Hoster fragen!

Sabam hat geschrieben:Würde mit der PHP Version 5.4.7 auch meine jetzige phpBB3.0 weiterlaufen ?

Ja, würde sie (phpBB3.0.14 läuft bis PHP 5.6 ), wobei ein Upgrade dennoch anzuraten ist (allein schon aus Sicherheitsgründen, da es keine Updates für die phpBB3.0.x - Reihe mehr gibt).

Grüße: Mahony
Taekwondo in Berlin
Wer fragt, ist ein Narr für fünf Minuten, wer nicht fragt, ist ein Narr für immer.

Benutzeravatar
Crizzo
Administrator
Administrator
Beiträge: 10274
Registriert: 19.05.2005 21:45
Kontaktdaten:

Re: PHP Version 5 zu klein für Upgrade

Beitragvon Crizzo » 24.04.2019 17:12

Hi,

was genau hast du gefragt und die Antwort war nicht zufällig auf Englisch? Aber frag nach, was er meint.

Also im Prinzip brauchst du modeneres PHP und evtl. MySQL aufm Server, der Rest kann dir egal sein.

Grüße


Zurück zu „[3.0.x] Administration, Benutzung und Betrieb“