[3.3] youtu.be Probleme, Modbereich nicht sichtbar

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.2 und höher und die Konvertierung zu phpBB 3.3.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.3] oder [3.2] angeben
Antworten
Maxitune
Mitglied
Beiträge: 2
Registriert: 14.08.2020 13:47

[3.3] youtu.be Probleme, Modbereich nicht sichtbar

Beitrag von Maxitune »

Guten Tag, ich habe mehrere Probleme zu denen ich irgendwie keine Antwort finden konnte.

Wenn ich einen youtu.be-Link posten möchte mit der YouTube-BBCode Verknüpfung funktioniert das nicht.
BBcode: [youtube]https://www.youtube.com/watch?v={SIMPLETEXT}[/youtube]
Html: <object width="425" height="350"><param name="movie" value="https://www.youtube.com/v/{SIMPLETEXT}"></param><param name="wmode" value="transparent"></param><embed src="https://www.youtube.com/v/{SIMPLETEXT}" type="application/x-shockwave-flash" wmode="transparent" width="425" height="350"></embed></object>

Der Code funktioniert super für normale Links mit watch?v=xxx aber egal wie ich ihn verändere passt er nicht zu youtu.be. Hat jemand einen guten Html-Code dafür?

Und die zweite Frage: Bei der Forenübersicht habe ich direkt Zugriff auf den Admin- und Moderationsbereich. Gehe ich auf den Schnellzugriff und lasse mir bspw. die neuen Beiträeg anzeigen sehe ich nur noch den Adminbereich und nicht mehr den Button für den Moderationsbereich. Kann ich das irgendwie anzeigen lassen?
Bin in meinem Forum Administrator + Moderator. Hat es etwas damit zu tun?

Danke für die Hilfe!
hackepeter13
Valued Contributor
Beiträge: 3501
Registriert: 21.04.2004 12:22
Wohnort: Berlin
Kontaktdaten:

Re: [3.3] youtu.be Probleme, Modbereich nicht sichtbar

Beitrag von hackepeter13 »

Ganz simple:

Ändere deinen BBCode in:
[youtube]https://{SIMPLETEXT2}/watch?v={SIMPLETEXT}[/youtube]

und deinen HTML-Code kannst du unverändert lassen.

{SIMPLETEXT2} muss nicht in die HTML-Umwandlung eingebunden werden, somit hast du quasi eine dynamische Domain-Wahl beim BBCode.

Somit funktionieren alle Domains wie www.youtube.com, youtube.com oder de.youtube.com oder was es auch immer für Youtube Varianten.
Maxitune
Mitglied
Beiträge: 2
Registriert: 14.08.2020 13:47

Re: [3.3] youtu.be Probleme, Modbereich nicht sichtbar

Beitrag von Maxitune »

Hi hackepeter, danke für deine Antwort!
Leider funktioniert es nach dem Austausch vom BBCode trotzdem nicht.. Es wird dann lediglich der Link angezeigt.
Bspw: [youtube]https://youtu.be/Zm5WwuYcUwE[/youtube]
Zuletzt geändert von Dr.Death am 05.05.2022 18:40, insgesamt 2-mal geändert.
hackepeter13
Valued Contributor
Beiträge: 3501
Registriert: 21.04.2004 12:22
Wohnort: Berlin
Kontaktdaten:

Re: [3.3] youtu.be Probleme, Modbereich nicht sichtbar

Beitrag von hackepeter13 »

Maxitune hat geschrieben: 05.05.2022 14:52
hackepeter13 hat geschrieben: 04.05.2022 16:30 Ganz simple:

Ändere deinen BBCode in:
[youtube]https://{SIMPLETEXT2}/watch?v={SIMPLETEXT}[/youtube]
Hi hackepeter, danke für deine Antwort!
Leider funktioniert es nach dem Austausch vom BBCode trotzdem nicht.. Es wird dann lediglich der Link angezeigt.
Bspw: [youtube]https://youtu.be/Zm5WwuYcUwE[/youtube]
Ah wenn der Link so ist, also ohne dem "watch" Teil. dann geht das natürlich nicht so.
Benutzeravatar
BNa
Valued Contributor
Beiträge: 2968
Registriert: 12.04.2010 23:51
Kontaktdaten:

Re: [3.3] youtu.be Probleme, Modbereich nicht sichtbar

Beitrag von BNa »

Oder Du nimmst einfach nur den Identifier, dann ist es echt Jacke, wie die Url ist...

BBCode:

Code: Alles auswählen

[youtube]{IDENTIFIER}[/youtube]
Html-Ersetzung:

Code: Alles auswählen

<iframe title="YouTube" width="480" height="390" src="https://www.youtube.com/embed/{IDENTIFIER}" frameborder="0" allowfullscreen>
</iframe>
BBCode Usage:
Benutze nur den Code nach ?v= oder nach youtu.be/

z.B. [youtube]8IN32cB81Zc[/youtube]

Beispiel:
h t t p s : //youtu.be/8IN32cB81Zc
h t t p s : //w w w.youtube.com/watch?v=8IN32cB81Zc
Antworten

Zurück zu „Support-Forum“