Systemanforderungen für phpBB

Beschreibung: Damit phpBB auf einem Server installiert werden kann, müssen verschiedene Voraussetzungen erfüllt werden:

Kategorie: Wichtig, Installation und Update

Link zu diesem Artikel: Alles auswählen

[url=https://www.phpbb.de/kb/viewarticle?a=15&sid=3823b24745d9ccc436a9462847439f3c]Knowledge Base - Systemanforderungen für phpBB[/url]

Systemanforderungen

Damit phpBB auf einem Server installiert werden kann, müssen verschiedene Voraussetzungen erfüllt werden:

phpBB 3.3

  • SQL Datenbank:
    • MySQL 4.1.3 oder höher (MySQLi wird benötigt)
    • MariaDB 5.1 oder höher
    • PostgreSQL 8.3+
    • SQLite 3.6.15+
    • MS SQL Server 2000 oder höher (direkt oder vie ODBC oder mit dem nativem Adapter)
    • Oracle
  • PHP
    • Mindestanforderung: PHP 7.2.0 oder höher
    • Maximal möglich:
      • PHP 8.0 ab phpBB 3.3.3
      • PHP 8.1 ab phpBB 3.3.9
      • PHP 8.2 ab phpBB 3.3.12
      • PHP 8.3 ab phpBB 3.3.12
    • mit folgenden PHP Modulen:
      • json
      • mbstring
      • XML Unterstützung
    • Die Funktion getimagesize() muss aktiviert sein
    • Folgende PHP-Module werden nicht zwingend benötigt, ergänzen allerdings verschiedene Funktionen:
      • zlib Kompression
      • Remote FTP Unterstützung
      • GD Unterstützung

    phpBB 3.2

    • SQL Datenbank:
      • MySQL 3.23 oder höher (MySQLi wird unterstützt)
      • MariaDB 5.1 oder höher
      • PostgreSQL 8.3+
      • SQLite 2.8.2+
      • SQLite 3.6.15+
      • MS SQL Server 2000 oder höher (direkt oder vie ODBC oder mit dem nativem Adapter)
      • Oracle
    • PHP 5.4.7 oder höher und kleiner 7.3 (PHP 7.3 wird noch nicht unterstützt, Stand: phpBB 3.2.7)
    • mit folgenden PHP Modulen:
      • json
    • Die Funktion getimagesize() muss aktiviert sein
    • Folgende PHP-Module werden nicht zwingend benötigt, ergänzen allerdings verschiedene Funktionen:
      • zlib Kompression
      • Remote FTP Unterstützung
      • XML Unterstützung
      • GD Unterstützung