[3.2] Nach Update funktionieren keine RSS-Feed mehr

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.1.x und höher und die Konvertierung zu phpBB 3.2.x.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.1.x] oder [3.2.x] angeben.
rockmartin
Mitglied
Beiträge: 75
Registriert: 29.05.2013 08:40
Kontaktdaten:

[3.2] Nach Update funktionieren keine RSS-Feed mehr

Beitragvon rockmartin » 01.11.2017 08:38

Hallo in die Runde,

ich habe unser Forum von 3.1.10 (php 5.6) auf Version phpBB 3.2.1 (php 7.1) aktualisiert. nach dem Update funktionieren allerdings keine RSS-Feeds mehr. Beim Aufruf der Feed bekomme ich immer folgende Fehlermeldung:

Code: Alles auswählen

Fehler: Umleitungsfehler
Die aufgerufene Website leitet die Anfrage so um, dass sie nie beendet werden kann.
Dieses Problem kann manchmal auftreten, wenn Cookies deaktiviert oder abgelehnt werden.


Laut Log-File werden alle Feeds per 301 ins Nirvarna geschickt ? Dabei muss man aber auch sagen, das domain.com/feed per 301 weitergeleitet wird und domain.com/app.php/feed funktioniert. Was ich mir allerdings nicht erklären kann. Denn die URL´s von der phpBB Pages Extension werden auch korrekt umschreiben. Ich nutze die Standard .htaccess Datei und mod_rewrite ist auf dem Server aktiviert. Ich stehe echt auf dem Schlauch! :o

.htaccess Datei

Code: Alles auswählen

<IfModule mod_rewrite.c>
RewriteEngine on

#
# Uncomment the statement below if URL rewriting doesn't
# work properly. If you installed phpBB in a subdirectory
# of your site, properly set the argument for the statement.
# e.g.: if your domain is test.com and you installed phpBB
# in http://www.test.com/phpBB/index.php you have to set
# the statement RewriteBase /phpBB/
#
#RewriteBase /

#
# Uncomment the statement below if you want to make use of
# HTTP authentication and it does not already work.
# This could be required if you are for example using PHP via Apache CGI.
#
#RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]

#
# The following 3 lines will rewrite URLs passed through the front controller
# to not require app.php in the actual URL. In other words, a controller is
# by default accessed at /app.php/my/controller, but can also be accessed at
# /my/controller
#
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ app.php [QSA,L]

#
# If symbolic links are not already being followed,
# uncomment the line below.
# http://anothersysadmin.wordpress.com/2008/06/10/mod_rewrite-forbidden-403-with-apache-228/
#
#Options +FollowSymLinks
</IfModule>

# With Apache 2.4 the "Order, Deny" syntax has been deprecated and moved from
# module mod_authz_host to a new module called mod_access_compat (which may be
# disabled) and a new "Require" syntax has been introduced to mod_authz_host.
# We could just conditionally provide both versions, but unfortunately Apache
# does not explicitly tell us its version if the module mod_version is not
# available. In this case, we check for the availability of module
# mod_authz_core (which should be on 2.4 or higher only) as a best guess.
<IfModule mod_version.c>
   <IfVersion < 2.4>
      <Files "config.php">
         Order Allow,Deny
         Deny from All
      </Files>
      <Files "common.php">
         Order Allow,Deny
         Deny from All
      </Files>
   </IfVersion>
   <IfVersion >= 2.4>
      <Files "config.php">
         Require all denied
      </Files>
      <Files "common.php">
         Require all denied
      </Files>
   </IfVersion>
</IfModule>
<IfModule !mod_version.c>
   <IfModule !mod_authz_core.c>
      <Files "config.php">
         Order Allow,Deny
         Deny from All
      </Files>
      <Files "common.php">
         Order Allow,Deny
         Deny from All
      </Files>
   </IfModule>
   <IfModule mod_authz_core.c>
      <Files "config.php">
         Require all denied
      </Files>
      <Files "common.php">
         Require all denied
      </Files>
   </IfModule>
</IfModule>


Forum URL: https://forum-schlafapnoe.de/

Kann hier jemand helfen?

Benutzeravatar
Mahony
Ehemaliger
Beiträge: 10919
Registriert: 17.11.2005 22:33
Wohnort: Esslingen (Neckar)
Kontaktdaten:

Re: [3.2] Nach Update funktionieren keine RSS-Feed mehr

Beitragvon Mahony » 01.11.2017 09:49

Hallo
Ändere mal in der. htaccess #RewriteBase / nach RewriteBase /

Grüße: Mahony
Taekwondo in Berlin
Wer fragt, ist ein Narr für fünf Minuten, wer nicht fragt, ist ein Narr für immer.

rockmartin
Mitglied
Beiträge: 75
Registriert: 29.05.2013 08:40
Kontaktdaten:

Re: [3.2] Nach Update funktionieren keine RSS-Feed mehr

Beitragvon rockmartin » 01.11.2017 09:52

Habe ich gemacht und danach den Cache geleert. Funktioniert leider nicht.

rockmartin
Mitglied
Beiträge: 75
Registriert: 29.05.2013 08:40
Kontaktdaten:

Re: [3.2] Nach Update funktionieren keine RSS-Feed mehr

Beitragvon rockmartin » 01.11.2017 14:04

Scheint so als würde ich nicht alleine sein mit meinem Problem -> https://www.phpbb.com/community/viewtop ... p=14814821

die /feed.php hat sich von der Version 3.1.10 zu 3.2.1 auch geändert. Was genau wurde da geändert?

Talk19zehn
Ehemaliger
Beiträge: 4334
Registriert: 08.06.2009 12:03

Re: [3.2] Nach Update funktionieren keine RSS-Feed mehr

Beitragvon Talk19zehn » 01.11.2017 16:39

Hello, evtl. hilfreich/aufschlussreich:
https://www.phpbb.com/community/viewtop ... #p14837091

oder gar hier... ? :-?
https://www.bogleheads.org/forum/viewtopic.php?t=203186

LG

Edit: Der Sinn, der Hintergrund und Zweck
...(...)... die /feed.php hat sich von der Version 3.1.10 zu 3.2.1 auch geändert. Was genau wurde da geändert? ...(...)...

jener umfangreichen (Ver)Änderung würde auch mich interessieren.
Grüße
Zuletzt geändert von Talk19zehn am 01.11.2017 16:54, insgesamt 1-mal geändert.
Angaben stets ohne Gewähr, da von vielfachen Konstrukten abhängig.

Benutzeravatar
Mahony
Ehemaliger
Beiträge: 10919
Registriert: 17.11.2005 22:33
Wohnort: Esslingen (Neckar)
Kontaktdaten:

Re: [3.2] Nach Update funktionieren keine RSS-Feed mehr

Beitragvon Mahony » 01.11.2017 16:52

Hallo
Ist das "Umschreiben von URLs aktivieren:" auf Ja gestellt (unter Administrations-Bereich >>>im Reiter Allgemein >>> Server und Domain)?
Falls NICHT dann mach das mal bitte und prüfe ob es dann funktioniert.

Grüße: Mahony
Taekwondo in Berlin
Wer fragt, ist ein Narr für fünf Minuten, wer nicht fragt, ist ein Narr für immer.

rockmartin
Mitglied
Beiträge: 75
Registriert: 29.05.2013 08:40
Kontaktdaten:

Re: [3.2] Nach Update funktionieren keine RSS-Feed mehr

Beitragvon rockmartin » 02.11.2017 07:42

Moin Mahony,

das Umschreiben von URLs ist bei mir aktiviert. Ich habe gestern abend noch das ganze Web umgekrempelt nach einer Lösung. Leider erfolglos :-?

rockmartin
Mitglied
Beiträge: 75
Registriert: 29.05.2013 08:40
Kontaktdaten:

Re: [3.2] Nach Update funktionieren keine RSS-Feed mehr

Beitragvon rockmartin » 08.11.2017 08:23

Das Problem besteht leider immer noch.

Benutzeravatar
Mahony
Ehemaliger
Beiträge: 10919
Registriert: 17.11.2005 22:33
Wohnort: Esslingen (Neckar)
Kontaktdaten:

Re: [3.2] Nach Update funktionieren keine RSS-Feed mehr

Beitragvon Mahony » 08.11.2017 10:08

Hallo

rockmartin hat geschrieben:Das Problem besteht leider immer noch.


Dann poste doch mal bitte die folgenden Einstellungen:

Cookie-Domain:
Cookie-Name:
Cookie-Pfad:
Sicherer Server:

Erzwinge Server-URL-Einstellungen:
Server-Protokoll:
Domain-Name:
Server-Port:
Scriptpfad:



Grüße: Mahony
Taekwondo in Berlin
Wer fragt, ist ein Narr für fünf Minuten, wer nicht fragt, ist ein Narr für immer.

rockmartin
Mitglied
Beiträge: 75
Registriert: 29.05.2013 08:40
Kontaktdaten:

Re: [3.2] Nach Update funktionieren keine RSS-Feed mehr

Beitragvon rockmartin » 08.11.2017 10:45

Hallo Mahony,anbei die Infos.

Cookie-Domain: .forum-schlafapnoe.de
Cookie-Name: cookie_schlafap
Cookie-Pfad: /
Sicherer Server: Aktiviert

Erzwinge Server-URL-Einstellungen: Nein
Server-Protokoll: https://
Domain-Name: forum-schlafapnoe.de/
Server-Port: 443
Scriptpfad: /


Zurück zu „Support-Forum“