[3.2] [3.2.1] HTTP-Statuscode 500 statt 404

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.1.x und höher und die Konvertierung zu phpBB 3.2.x.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.1.x] oder [3.2.x] angeben.
pgsteffen
Mitglied
Beiträge: 8
Registriert: 08.02.2018 12:50

Re: [3.2] [3.2.1] HTTP-Statuscode 500 statt 404

Beitragvon pgsteffen » 08.02.2018 19:22

Hallo nochmal,
ehe ich jetzt noch mal eine Testinstallation mache:
Generiert die phpBB-Standardinstallation eine .htaccess?
Und wenn ja wie sieht die aus?

Gruß Steffen

Benutzeravatar
Mahony
Ehemaliger
Beiträge: 11363
Registriert: 17.11.2005 22:33
Wohnort: Esslingen (Neckar)
Kontaktdaten:

Re: [3.2] [3.2.1] HTTP-Statuscode 500 statt 404

Beitragvon Mahony » 08.02.2018 19:27

Hallo
pgsteffen hat geschrieben:Generiert die phpBB-Standardinstallation eine .htaccess?

Nein - generiert wird da nichts - es ist aber eine .htaccess Datei im phpBB-Paket enthalten.
Ich würde einfach die .htaccess-Datei mit einer originalen (aus dem Komplettpaket) überschreiben.

Grüße: Mahony
Taekwondo in Berlin
Wer fragt, ist ein Narr für fünf Minuten, wer nicht fragt, ist ein Narr für immer.

pgsteffen
Mitglied
Beiträge: 8
Registriert: 08.02.2018 12:50

Re: [3.2] [3.2.1] HTTP-Statuscode 500 statt 404

Beitragvon pgsteffen » 08.02.2018 19:34

Hallo,
gefunden, ist aber genau die, die ich "installiert" habe:

Code: Alles auswählen

<IfModule mod_rewrite.c>
RewriteEngine on

#
# Uncomment the statement below if URL rewriting doesn't
# work properly. If you installed phpBB in a subdirectory
# of your site, properly set the argument for the statement.
# e.g.: if your domain is test.com and you installed phpBB
# in http://www.test.com/phpBB/index.php you have to set
# the statement RewriteBase /phpBB/
#
#RewriteBase /

#
# Uncomment the statement below if you want to make use of
# HTTP authentication and it does not already work.
# This could be required if you are for example using PHP via Apache CGI.
#
#RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]

#
# The following 3 lines will rewrite URLs passed through the front controller
# to not require app.php in the actual URL. In other words, a controller is
# by default accessed at /app.php/my/controller, but can also be accessed at
# /my/controller
#
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ app.php [QSA,L]

#
# If symbolic links are not already being followed,
# uncomment the line below.
# http://anothersysadmin.wordpress.com/2008/06/10/mod_rewrite-forbidden-403-with-apache-228/
#
#Options +FollowSymLinks
</IfModule>

# With Apache 2.4 the "Order, Deny" syntax has been deprecated and moved from
# module mod_authz_host to a new module called mod_access_compat (which may be
# disabled) and a new "Require" syntax has been introduced to mod_authz_host.
# We could just conditionally provide both versions, but unfortunately Apache
# does not explicitly tell us its version if the module mod_version is not
# available. In this case, we check for the availability of module
# mod_authz_core (which should be on 2.4 or higher only) as a best guess.
<IfModule mod_version.c>
   <IfVersion < 2.4>
      <Files "config.php">
         Order Allow,Deny
         Deny from All
      </Files>
      <Files "common.php">
         Order Allow,Deny
         Deny from All
      </Files>
   </IfVersion>
   <IfVersion >= 2.4>
      <Files "config.php">
         Require all denied
      </Files>
      <Files "common.php">
         Require all denied
      </Files>
   </IfVersion>
</IfModule>
<IfModule !mod_version.c>
   <IfModule !mod_authz_core.c>
      <Files "config.php">
         Order Allow,Deny
         Deny from All
      </Files>
      <Files "common.php">
         Order Allow,Deny
         Deny from All
      </Files>
   </IfModule>
   <IfModule mod_authz_core.c>
      <Files "config.php">
         Require all denied
      </Files>
      <Files "common.php">
         Require all denied
      </Files>
   </IfModule>
</IfModule>


Lösche ich diese .htaccess bekomme ich statt 404 eine leere Seite vom hoster generiert.

Code: Alles auswählen

<!DOCTYPE html>
<html>
    <head>
        <meta charset="utf-8">
        <style type="text/css">
            html, body, #partner, iframe {
                height:100%;
                width:100%;
                margin:0;
                padding:0;
                border:0;
                outline:0;
                font-size:100%;
                vertical-align:baseline;
                background:transparent;
            }
            body {
                overflow:hidden;
            }
        </style>
        <meta content="NOW" name="expires">
        <meta content="index, follow, all" name="GOOGLEBOT">
        <meta content="index, follow, all" name="robots">
        <!-- Following Meta-Tag fixes scaling-issues on mobile devices -->
        <meta content="width=device-width; initial-scale=1.0; maximum-scale=1.0; user-scalable=0;" name="viewport">
    </head>
    <body>
        <div id="partner"></div>
        <script type="text/javascript">
            document.write(
                    '<script type="text/javascript" language="JavaScript"'
                            + 'src="//sedoparking.com/frmpark/'
                            + window.location.host + '/'
                            + '1und1parking6'
                            + '/park.js">'
                    + '<\/script>'
            );
        </script>
    </body>
</html>


Gruß Steffen

Benutzeravatar
Mahony
Ehemaliger
Beiträge: 11363
Registriert: 17.11.2005 22:33
Wohnort: Esslingen (Neckar)
Kontaktdaten:

Re: [3.2] [3.2.1] HTTP-Statuscode 500 statt 404

Beitragvon Mahony » 09.02.2018 07:34

Hallo
pgsteffen hat geschrieben:Lösche ich diese .htaccess bekomme ich statt 404 eine leere Seite vom hoster generiert.

Dann empfehle ich dir, wende dich mit dem Problem an deinen Hoster und schildere den Fall.
Der Hoster sollte das Problem beheben können.

Grüße: Mahony
Taekwondo in Berlin
Wer fragt, ist ein Narr für fünf Minuten, wer nicht fragt, ist ein Narr für immer.


Zurück zu „Support-Forum“