[3.2.9&3.3]Viele Probleme nach dem Update

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.2 und höher und die Konvertierung zu phpBB 3.3.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.3] oder [3.2] angeben
Benutzeravatar
Dr.Death
Moderator
Moderator
Beiträge: 16475
Registriert: 23.04.2003 08:22
Wohnort: Xanten
Kontaktdaten:

Re: [3.2.9&3.3]Viele Probleme nach dem Update

Beitrag von Dr.Death »

Dann ist eine Extension dabei, die den Fehler verursacht.....
Benutzeravatar
T-Rex
Mitglied
Beiträge: 17
Registriert: 24.03.2019 20:56
Wohnort: Bonn
Kontaktdaten:

Re: [3.2.9&3.3]Viele Probleme nach dem Update

Beitrag von T-Rex »

Steve Wuppertal hat geschrieben:
17.01.2020 08:23
Könnte es evtl. mit dem von Strato genutzten Betriebssystem der Shared-Hosting Paketen zusammen hängen ?

https://stackoverflow.com/questions/317 ... ot-writing
(vor allem der Antwortpost ist interessant)
Da würde ich _fast_ von ausgehen. Strato setzt hier SunOS 5.10 (= Oracle Solaris 10) ein. Aus meiner aktiven Zeit als Administrator für das IBM Datenbanksystem DB2 LUW weiss ich, dass sich Commands und Scripte auf einem System mit dem Solaris OS _teilweise_ anders verhalten als auf einem System mit Linux.

Ich betreue für den Meister meine Motorrad-Werkstatt softwaremäßig sein Forum. Er hat den Webspace für seine Webseite und das Forum auch bei Strato. Wenn ich im ACP mir die PHP Informationen anzeigen lasse, wird hier eben das u. a. OS angezeigt.

VG
Joachim (T-Rex, ein IT-Dinosaurier)
T-Rex, der IT-Dinosaurier (retired)

Ich bin /root, ich darf das!! :lol:

Benutzeravatar
IMC
Mitglied
Beiträge: 32
Registriert: 25.11.2018 20:32
Wohnort: Lüneburg
Kontaktdaten:

Re: [3.2.9&3.3]Viele Probleme nach dem Update

Beitrag von IMC »

Hallo,

gestern hat sich Strato bei mir zurück gemeldet und hat mit mitgeteilt das der Fehler in der Software (phpBB) zu suchen ist. Sie aber für diese aber keinen Support leisten. Diese Antwort ist für mich soweit auch OK.

Mittlerweile habe ich auch viel dazu gelernt. Deshalb glaube ich einen besseren Hack für das Problem "Failure while aqcuiring locks" gefunden zu haben. Ob es die richtige/beste Lösung ist kann ich leider nicht beurteilen da meine Programmierkenntnisse leider nicht so gut sind das ich das ganze Programm phpBB durchschaue.
Um so mehr bin ich auf die Lösung der Profis gespannt.

In der Datei phpbb/lock/flock.php Zeile 104.
Suche:

Code: Alles auswählen

if (!@flock($this->lock_fp, LOCK_EX))
Ersetze mit:

Code: Alles auswählen

if (!@flock($this->lock_fp, $mode == 'wb' ? LOCK_EX : LOCK_SH))
Grüße
Thorsten
Gruß, Thorsten
Benutzeravatar
BNa
Valued Contributor
Beiträge: 2702
Registriert: 12.04.2010 23:51
Kontaktdaten:

Re: [3.2.9&3.3]Viele Probleme nach dem Update

Beitrag von BNa »

Interessante Lösung.
Dann haben wir ja jetzt schon 2 Quick-Hacks mehr für das Problem :geek:
und das auch noch letztlich flotter als auf phpbb.com :grin:
Benutzeravatar
IMC
Mitglied
Beiträge: 32
Registriert: 25.11.2018 20:32
Wohnort: Lüneburg
Kontaktdaten:

Re: [3.2.9&3.3]Viele Probleme nach dem Update

Beitrag von IMC »

BNa hat geschrieben:
20.01.2020 18:13
Interessante Lösung.
Das hatte ich mir auch gedacht.
Im Orginal sind die Dateien sowohl im Schreib- wie auch im Lesemodus mit einer exklusive Sperre belegt worden. Im exkusive Modus kann die Datei nur von einem Prozess beschrieben oder gelesen werden. Wurde eine Datei im Lesemodus geöffnet und mit einer exklusive Sperre belegt verursachte das Strato System einen Fehler.

Im ersten Hack wurde die *.lock Datei einfach nach dem Zugriff gelöscht. Dann waren natürlich keine Dateien vorhanden die im Lesemodus geöffnet werden könnten. Also kein Fehler.

In meinem Hack werden die Dateien nicht gelöscht. Die bestehenden Dateien werden im Lesemodus geöffnet und mit einen Shared Lock belegt. Das bedeutet das diese von mehreren Prozessen gleichzeitig gelesen werden kann aber solange wie die Sperre drauf ist nich beschrieben werden kann.
Dadurch sollte der Cache von phpBB besser arbeiten.
Gruß, Thorsten
Benutzeravatar
T-Rex
Mitglied
Beiträge: 17
Registriert: 24.03.2019 20:56
Wohnort: Bonn
Kontaktdaten:

Re: [3.2.9&3.3]Viele Probleme nach dem Update

Beitrag von T-Rex »

Ich hab auf der Seite stackoverflow.com noch etwas zu flock() und SunOS 5.10 (Oracle Solaris 10) gefunden. Dies bezieht sich zwar auf die Programmierung unter C, daher bin ich nicht sicher ob dies vielleicht auch Auswirkungen auf die Funktion in PHP haben könnte:

https://stackoverflow.com/questions/590 ... laris-5-10

Ich interpretier dies so, dass der Locking-Mechanismus unter Solaris bzw. SunOS anders funktioniert wie unter Linux. :-?

Ich bin mit den Tiefen der Unixe und Linuxe nicht so vertraut. Nutze zwar privat Linux und für die Administration meines eigenen Rechners reichen meine bescheidenen Unix-Kenntnisse aus. Außerdem liegt meine Zeit als Software-Entwickler mehr als 20 Jahre zurück. :oops:
T-Rex, der IT-Dinosaurier (retired)

Ich bin /root, ich darf das!! :lol:

moby2006
Mitglied
Beiträge: 15
Registriert: 09.01.2020 13:53

Re: [3.2.9&3.3]Viele Probleme nach dem Update

Beitrag von moby2006 »

Dr.Death hat geschrieben:
20.01.2020 12:07
Dann ist eine Extension dabei, die den Fehler verursacht.....
Hattest Recht laufen jetzt alle Ex unter 3.3.0
Fehler wurde nicht immer angezeigt aber auf dem Server schon :-)

@Torsten
Vielen Dank versuch das gleich mal , morgen könnte ich dann klatt mein Live Forum Updaten.

Gruß
Steve Wuppertal
Mitglied
Beiträge: 156
Registriert: 09.05.2011 17:10
Wohnort: Wuppertal
Kontaktdaten:

Re: [3.2.9&3.3]Viele Probleme nach dem Update

Beitrag von Steve Wuppertal »

T-Rex hat geschrieben:
21.01.2020 09:54
Ich hab auf der Seite stackoverflow.com noch etwas zu flock() und SunOS 5.10 (Oracle Solaris 10) gefunden. Dies bezieht sich zwar auf die Programmierung unter C, daher bin ich nicht sicher ob dies vielleicht auch Auswirkungen auf die Funktion in PHP haben könnte:

https://stackoverflow.com/questions/590 ... laris-5-10

Ich interpretier dies so, dass der Locking-Mechanismus unter Solaris bzw. SunOS anders funktioniert wie unter Linux. :-?

Ich bin mit den Tiefen der Unixe und Linuxe nicht so vertraut. Nutze zwar privat Linux und für die Administration meines eigenen Rechners reichen meine bescheidenen Unix-Kenntnisse aus. Außerdem liegt meine Zeit als Software-Entwickler mehr als 20 Jahre zurück. :oops:
In diesem Fall hätte sowohl Strato als auch phpbb.com recht mit der Aussage, das es nicht an ihren Systemen liegen würde...
Es scheint ein Kompatibilitätsproblem zwischen der phpbb-Software und dem SunOS (Behandlung von flock) zu sein :roll:
Benutzeravatar
kjh-mov
Mitglied
Beiträge: 16
Registriert: 19.09.2017 07:53
Kontaktdaten:

Re: [3.2.9&3.3]Viele Probleme nach dem Update

Beitrag von kjh-mov »

Dr.Death hat geschrieben:
18.01.2020 15:21
Auf Strato Servern sollte wenn es geht noch kein Update durchgeführt werden, außer man weiß was man tut (dirty Workarounds).

Neue Information dazu werden hier und hier (engl.) bekannt gegeben.
Ich habe es derzeit auch aufgegeben, nachdem ich alle Varianten - auch die Fehlermeldungen - "nachgearbeitet" habe.

3.29 selbst ging problemlos.

Danke allen für Ihren guten Job und Einsatz, ums uns Stratoianern zu helfen. :grin: :cookie:
"Wer nichts weiß, muss alles glauben."
Marie von Ebner-Eschenbach
Benutzeravatar
IMC
Mitglied
Beiträge: 32
Registriert: 25.11.2018 20:32
Wohnort: Lüneburg
Kontaktdaten:

Re: [3.2.9&3.3]Viele Probleme nach dem Update

Beitrag von IMC »

kjh-mov hat geschrieben:
24.01.2020 05:42
Ich habe es derzeit auch aufgegeben, nachdem ich alle Varianten - auch die Fehlermeldungen - "nachgearbeitet" habe.
Hast Du auch meine Änderung ausprobiert? Läuft beim meinen Forum auf einen Stratoserver problemlos.
viewtopic.php?f=145&t=243987&start=70#p1400747

Behebt allerdings nicht das Problem mit inkompatibel Ext.
Gruß, Thorsten
Antworten

Zurück zu „Support-Forum“