[3.2] Return Path von All Inkl. bei Php Boardmails "falsch"

Fragen rund um die Installation, Administration und Benutzung von phpBB 3.1.x und höher und die Konvertierung zu phpBB 3.2.x.
Forumsregeln
Bitte im Thementitel den Präfix deiner phpBB-Version [3.1.x] oder [3.2.x] angeben.
Benutzeravatar
Joyce&Luna
Mitglied
Beiträge: 1448
Registriert: 24.11.2013 18:14
Wohnort: NRW
Kontaktdaten:

Re: [3.2] Return Path von All Inkl. bei Php Boardmails "falsch"

Beitragvon Joyce&Luna » 04.06.2017 22:32

Über die Massen-EMais geht es, aber nicht wenn ich eine PN verschicke, die kommt nicht an.

Anke
phpBB-Style-Design.de

Keine Antwort ist die eindeutigste Antwort, die man kriegen kann.
Support zu meinen Styles, bitte die Fragen im Forum stellen und nicht per PN. Danke!

Benutzeravatar
canonknipser
Supporter
Supporter
Beiträge: 1027
Registriert: 10.09.2011 11:14
Kontaktdaten:

Re: [3.2] Return Path von All Inkl. bei Php Boardmails "falsch"

Beitragvon canonknipser » 04.06.2017 22:52

Habs gerade auch getestet, ich bekomme Mails aus dem ACP und Registrierungsmails, aber auch PN-Mails. Natürlich muss die Benachrichtigung per Mail auch beim Empfänger aktiv sein ;)
Grüße, canonknipser
"there are only 10 types of people: those, who understand binary and those, who don't"
just arrived ;)
Kein Support via PN, nur im Board und (manchmal) im IRC

Benutzeravatar
Joyce&Luna
Mitglied
Beiträge: 1448
Registriert: 24.11.2013 18:14
Wohnort: NRW
Kontaktdaten:

Re: [3.2] Return Path von All Inkl. bei Php Boardmails "falsch"

Beitragvon Joyce&Luna » 04.06.2017 23:19

Also ich bekomme keine EMail, Einstellungen auch noch mal überprüft aber ich bekomme nichts.

Anke
phpBB-Style-Design.de

Keine Antwort ist die eindeutigste Antwort, die man kriegen kann.
Support zu meinen Styles, bitte die Fragen im Forum stellen und nicht per PN. Danke!

Benutzeravatar
canonknipser
Supporter
Supporter
Beiträge: 1027
Registriert: 10.09.2011 11:14
Kontaktdaten:

Re: [3.2] Return Path von All Inkl. bei Php Boardmails "falsch"

Beitragvon canonknipser » 04.06.2017 23:24

Spam-Ordner überprüft?
Gehört die Sendeadresse zum Postfach?
Welche Zieladresse verwendest du? gmx, web.de und andere 1&1er haben SPF-Prüfungen aktiviert, da kann es schon mal zu einem Abweisen von Mails kommen, wenn Absender-Mailadresse und Absender-Mailserver nicht zusammen passen.
Grüße, canonknipser
"there are only 10 types of people: those, who understand binary and those, who don't"
just arrived ;)
Kein Support via PN, nur im Board und (manchmal) im IRC

Benutzeravatar
Joyce&Luna
Mitglied
Beiträge: 1448
Registriert: 24.11.2013 18:14
Wohnort: NRW
Kontaktdaten:

Re: [3.2] Return Path von All Inkl. bei Php Boardmails "falsch"

Beitragvon Joyce&Luna » 04.06.2017 23:27

Ich benutze info@phpbb-style-design.de also eine erstelle EMail Adresse bei All inkl

Anke
phpBB-Style-Design.de

Keine Antwort ist die eindeutigste Antwort, die man kriegen kann.
Support zu meinen Styles, bitte die Fragen im Forum stellen und nicht per PN. Danke!

Benutzeravatar
couchpilot
Mitglied
Beiträge: 56
Registriert: 11.02.2017 18:11

Re: [3.2] Return Path von All Inkl. bei Php Boardmails "falsch"

Beitragvon couchpilot » 05.06.2017 11:16

Hi canonknipser,

jetzt von mir auch noch mal ne Rückmeldung. Ich dachte ja der Bug des "Testmail" Buttons bezöge sich nur auf die Eingabe des Passwortes und habe mich ausschließlich auf ihn verlassen und nach jeder Konfigurationsänderung darauf geklickt um zu schauen ob Mails kommen :roll:

Aber der Button funktioniert nur bei der php Einstellung, bei der SMTP Einstellung hat er überhaupt keine Funktionalität.

Also bei mir laufen die Mails jetzt auch über SMTP mit den von Dir genannten Einstellungen (Danke):

SMTP-Server-Adresse: xxx.kasserver.com
SMTP-Server-Port: Port 25
Authentifizierungsmethode für SMTP: "LOGIN"

Einige Benachrichtigungen kommen allerdings mit erheblicher Zeitverzögerung an, also bis zu 1,5 Stunden später als der Beitrag geschrieben wurde. Aber das ist ja wohl keine phpBB Sache, sondern eher ein Fehler beim Mailserver. Ich werd das mal beobachten und dann noch mal den Support bei All Inkl. bemühen. Vielleicht bekommt man das ja auch noch in den Griff.

Dankeschön für die wirklich hartnäckige und geduldige Unterstützung hier :wink:

LG Andi

Benutzeravatar
canonknipser
Supporter
Supporter
Beiträge: 1027
Registriert: 10.09.2011 11:14
Kontaktdaten:

Re: [3.2] Return Path von All Inkl. bei Php Boardmails "falsch"

Beitragvon canonknipser » 05.06.2017 12:21

couchpilot hat geschrieben:Einige Benachrichtigungen kommen allerdings mit erheblicher Zeitverzögerung an, also bis zu 1,5 Stunden später als der Beitrag geschrieben wurde. Aber das ist ja wohl keine phpBB Sache, sondern eher ein Fehler beim Mailserver. Ich werd das mal beobachten und dann noch mal den Support bei All Inkl. bemühen. Vielleicht bekommt man das ja auch noch in den Griff.

Wann EMails zugestellt werden, hängt auch davon ab, wieviel Traffic du auf deinem Board hast. Benachrichtigungsmails werden über den phpBB-Cron-Dienst gesteuert. Dieser Cron-Dienst wird, wenn du keinen externen Cron verwendest, bei jedem Aufruf deiner Seite (egal ob index, viewtopic, viewforum etc.) gestartet. Allerdings laufen da auch verschiedene Wartungsaufgaben rein, z.B. Löschen von veralteten Benachrichtigungen, Cache-Bereinigungen, etc. Bei jedem Seitenaufruf wird maximal eine Cron-Aufgabe abgearbeitet. Bei E-Mails wird zusätzlich noch auf eine maximal "Paket-Größe", sprich Anzahl der Mails, die gleichzeitig von einem Cron-Lauf abgearbeitet werden, geschaut. Wenn du mehrere 100 Mails im phpBB-Ausgang stehen hast, werden diese evtl. in mehreren Paketen abgearbeitet.
Wenn du also wenig Betrieb im Board hast, wird der Cron also auch wenig aufgerufen und Aufgaben tlw. spät abgearbeitet.

Ein andere Sache ist bei den Empfänger-Mail-Postfächern zu beachten. Manche Provider (u.a. auch allinkl) haben das sog. Grey-Listing als Anti-Spam-Maßnahme aktiviert. Hier wird eine Mail von einem unbekannten Absender erst einmal temporär zurückgewiesen und erst nach einem erneuten Zustellversuch angenommen. Der zweite Zustellversuch kann dann schon mal geraume Zeit dauern.
Grüße, canonknipser
"there are only 10 types of people: those, who understand binary and those, who don't"
just arrived ;)
Kein Support via PN, nur im Board und (manchmal) im IRC

Benutzeravatar
couchpilot
Mitglied
Beiträge: 56
Registriert: 11.02.2017 18:11

Re: [3.2] Return Path von All Inkl. bei Php Boardmails "falsch"

Beitragvon couchpilot » 07.06.2017 00:42

Danke für diese ausführlichen Informationen.

Ich hab das jetzt einige Tage beobachtet und es kam bisher nicht mehr zu solchen großen Verzögerungen. Da bin ich auch ganz froh drüber, denn ich hätte jetzt auch nicht unbedingt Lust darauf mich noch in das Thema

Code: Alles auswählen

bin/phpbbcli.php cron:run
(das hast Du wahrscheinlich gemeint ?) einzuarbeiten. Obwohl das wahrscheinlich auch einfacher ist als es erst mal scheint. Hab ja auch so schon cronjobs angelegt, dürfte ja eigentlich nicht so schwer sein, wenn man das Script nicht auch selber schreiben muß :)

Aber ich bin froh wenn ich da nicht ran muß.

LG Andi

Benutzeravatar
canonknipser
Supporter
Supporter
Beiträge: 1027
Registriert: 10.09.2011 11:14
Kontaktdaten:

Re: [3.2] Return Path von All Inkl. bei Php Boardmails "falsch"

Beitragvon canonknipser » 09.06.2017 22:00

So, wir (Joyce&Luna und ich) haben noch ein wenig gebastelt, weil bei ihrem Forum zwar "normale" Mails (Massen-Mail, Registrierung, Mail-Addy-Änderung etc.) ankamen, aber keine Benachrichtigungsmails zu PN etc.
Nach Langem hin und her hat es mit folgenden Einstellungen geklappt:
  • Beim smtp-Server muss das Protokoll vorangestellt werden: ssl://xxx.kasserver.com
  • Port ist 465
  • LOGIN, User und Passwort wie gehabt
  • und ganz wichtig: Die E-Mail-Paketgröße muss auf 0 stehen (Standard ist 20)
Grüße, canonknipser
"there are only 10 types of people: those, who understand binary and those, who don't"
just arrived ;)
Kein Support via PN, nur im Board und (manchmal) im IRC

Benutzeravatar
Joyce&Luna
Mitglied
Beiträge: 1448
Registriert: 24.11.2013 18:14
Wohnort: NRW
Kontaktdaten:

Re: [3.2] Return Path von All Inkl. bei Php Boardmails "falsch"

Beitragvon Joyce&Luna » 09.06.2017 22:05

War schon komisch, das nur die besagten Dinge funktionierten.

Ich danke dir für deine Geduld und für die Optimale Lösung.
Denn ich hatte eigentlich schon aufgegeben.

Anke
phpBB-Style-Design.de

Keine Antwort ist die eindeutigste Antwort, die man kriegen kann.
Support zu meinen Styles, bitte die Fragen im Forum stellen und nicht per PN. Danke!


Zurück zu „Support-Forum“